aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/gdisp/HX8347D
diff options
context:
space:
mode:
authorJoel Bodenmann <joel@unormal.org>2013-07-21 17:42:25 +0200
committerJoel Bodenmann <joel@unormal.org>2013-07-21 17:42:25 +0200
commitd98e6c5d0d6c048c99aeda810da10e6a6a130325 (patch)
tree397a911a667c873bcd68419307519210fe150e9b /drivers/gdisp/HX8347D
parentc29950c7670397d60b32e92fa4aadb29fea227a4 (diff)
downloaduGFX-d98e6c5d0d6c048c99aeda810da10e6a6a130325.tar.gz
uGFX-d98e6c5d0d6c048c99aeda810da10e6a6a130325.tar.bz2
uGFX-d98e6c5d0d6c048c99aeda810da10e6a6a130325.zip
cleaned up board file mess
Diffstat (limited to 'drivers/gdisp/HX8347D')
-rw-r--r--drivers/gdisp/HX8347D/gdisp_lld.c10
-rw-r--r--drivers/gdisp/HX8347D/gdisp_lld_board_template.h120
-rw-r--r--drivers/gdisp/HX8347D/readme.txt24
3 files changed, 121 insertions, 33 deletions
diff --git a/drivers/gdisp/HX8347D/gdisp_lld.c b/drivers/gdisp/HX8347D/gdisp_lld.c
index 41850600..b19e2c41 100644
--- a/drivers/gdisp/HX8347D/gdisp_lld.c
+++ b/drivers/gdisp/HX8347D/gdisp_lld.c
@@ -40,15 +40,7 @@
/* Driver local functions. */
/*===========================================================================*/
-#if defined(GDISP_USE_CUSTOM_BOARD) && GDISP_USE_CUSTOM_BOARD
- /* Include the user supplied board definitions */
- #include "gdisp_lld_board.h"
-#elif defined(BOARD_ST_STM32F4_DISCOVERY)
- #include "gdisp_lld_board_st_stm32f4_discovery.h"
-#else
- /* Include the user supplied board definitions */
- #include "gdisp_lld_board.h"
-#endif
+#include "gdisp_lld_board.h"
// Some common routines and macros
#define write_reg(reg, data) { write_index(reg); write_data(data); }
diff --git a/drivers/gdisp/HX8347D/gdisp_lld_board_template.h b/drivers/gdisp/HX8347D/gdisp_lld_board_template.h
new file mode 100644
index 00000000..8c67e20d
--- /dev/null
+++ b/drivers/gdisp/HX8347D/gdisp_lld_board_template.h
@@ -0,0 +1,120 @@
+/*
+ * This file is subject to the terms of the GFX License. If a copy of
+ * the license was not distributed with this file, you can obtain one at:
+ *
+ * http://chibios-gfx.com/license.html
+ */
+
+/**
+ * @file drivers/gdisp/HX8347D/gdisp_lld_board_template.h
+ * @brief GDISP Graphic Driver subsystem board SPI interface for the HX8347D display.
+ *
+ * @addtogroup GDISP
+ * @{
+ */
+
+#ifndef _GDISP_LLD_BOARD_H
+#define _GDISP_LLD_BOARD_H
+
+/**
+ * @brief Initialise the board for the display.
+ * @notes This board definition uses GPIO and assumes exclusive access to these GPIO pins
+ *
+ * @notapi
+ */
+static inline void init_board(void) {
+
+}
+
+/**
+ * @brief Set or clear the lcd reset pin.
+ *
+ * @param[in] state TRUE = lcd in reset, FALSE = normal operation
+ *
+ * @notapi
+ */
+static inline void setpin_reset(bool_t state) {
+
+}
+
+/**
+ * @brief Set the lcd back-light level.
+ *
+ * @param[in] percent 0 to 100%
+ *
+ * @notapi
+ */
+static inline void set_backlight(uint8_t percent) {
+
+}
+
+/**
+ * @brief Take exclusive control of the bus
+ * @note Not needed, not implemented
+ *
+ * @notapi
+ */
+static inline void acquire_bus(void) {
+
+}
+
+/**
+ * @brief Release exclusive control of the bus
+ * @note Not needed, not implemented
+ *
+ * @notapi
+ */
+static inline void release_bus(void) {
+
+}
+
+/**
+ * @brief Send data to the index register.
+ *
+ * @param[in] index The index register to set
+ *
+ * @notapi
+ */
+static inline void write_index(uint8_t cmd) {
+
+}
+
+/**
+ * @brief Send data to the lcd.
+ *
+ * @param[in] data The data to send
+ *
+ * @notapi
+ */
+static inline void write_data(uint8_t data) {
+
+
+
+}
+
+static inline void write_ram8(uint8_t data1, uint8_t data2) {
+
+}
+
+static inline void write_ram16(uint16_t data) {
+
+}
+
+#if GDISP_HARDWARE_READPIXEL || defined(__DOXYGEN__)
+/**
+ * @brief Read data from the lcd.
+ *
+ * @return The data from the lcd
+ * @note The chip select may need to be asserted/de-asserted
+ * around the actual spi read
+ *
+ * @notapi
+ */
+static inline uint16_t read_data(void) {
+
+}
+#endif
+
+#endif /* _GDISP_LLD_BOARD_H */
+/** @} */
+
diff --git a/drivers/gdisp/HX8347D/readme.txt b/drivers/gdisp/HX8347D/readme.txt
deleted file mode 100644
index d0000287..00000000
--- a/drivers/gdisp/HX8347D/readme.txt
+++ /dev/null
@@ -1,24 +0,0 @@
-Description:
-
-Driver for LCD with 4-wire serial interface (65k colors).
-
-To use this driver:
-
-1. Add in your gfxconf.h:
- a) #define GFX_USE_GDISP TRUE
-
- b) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
-
- c) If you are not using a known board then create a gdisp_lld_board.h file
- and ensure it is on your include path.
- Use the gdisp_lld_board_st_stm32f4_discovery.h file as a basis.
- Currently known boards are:
- BOARD_ST_STM32F4_DISCOVERY
- Board configuration assume that you have STM32_PWM_USE_TIM4 set to TRUE in your mcuconf.h.
-
- d) The following are optional - define them if you are not using the defaults below:
- #define GDISP_SCREEN_WIDTH 240
- #define GDISP_SCREEN_HEIGHT 320
-
-2. To your makefile add the following lines:
- include $(GFXLIB)/drivers/gdisp/HX8347D/gdisp_lld.mk