aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/gdisp/ILI9325
diff options
context:
space:
mode:
authorJoel Bodenmann <joel@unormal.org>2013-07-21 17:42:25 +0200
committerJoel Bodenmann <joel@unormal.org>2013-07-21 17:42:25 +0200
commitd98e6c5d0d6c048c99aeda810da10e6a6a130325 (patch)
tree397a911a667c873bcd68419307519210fe150e9b /drivers/gdisp/ILI9325
parentc29950c7670397d60b32e92fa4aadb29fea227a4 (diff)
downloaduGFX-d98e6c5d0d6c048c99aeda810da10e6a6a130325.tar.gz
uGFX-d98e6c5d0d6c048c99aeda810da10e6a6a130325.tar.bz2
uGFX-d98e6c5d0d6c048c99aeda810da10e6a6a130325.zip
cleaned up board file mess
Diffstat (limited to 'drivers/gdisp/ILI9325')
-rw-r--r--drivers/gdisp/ILI9325/gdisp_lld.c9
-rw-r--r--drivers/gdisp/ILI9325/gdisp_lld_board_template.h (renamed from drivers/gdisp/ILI9325/gdisp_lld_board_example.h)15
-rw-r--r--drivers/gdisp/ILI9325/readme.txt15
3 files changed, 8 insertions, 31 deletions
diff --git a/drivers/gdisp/ILI9325/gdisp_lld.c b/drivers/gdisp/ILI9325/gdisp_lld.c
index a87f999e..6d80dc3f 100644
--- a/drivers/gdisp/ILI9325/gdisp_lld.c
+++ b/drivers/gdisp/ILI9325/gdisp_lld.c
@@ -20,14 +20,7 @@
/* Include the emulation code for things we don't support */
#include "gdisp/lld/emulation.c"
-#if defined(GDISP_USE_CUSTOM_BOARD) && GDISP_USE_CUSTOM_BOARD
- /* Include the user supplied board definitions */
- #include "gdisp_lld_board.h"
-#elif defined(BOARD_HY_STM32_100P)
- #include "gdisp_lld_board_hy_stm32_100p.h"
-#else
- #include "gdisp_lld_board.h"
-#endif
+#include "gdisp_lld_board.h"
/*===========================================================================*/
/* Driver local definitions. */
diff --git a/drivers/gdisp/ILI9325/gdisp_lld_board_example.h b/drivers/gdisp/ILI9325/gdisp_lld_board_template.h
index 72358b89..3f3eea4c 100644
--- a/drivers/gdisp/ILI9325/gdisp_lld_board_example.h
+++ b/drivers/gdisp/ILI9325/gdisp_lld_board_template.h
@@ -6,7 +6,7 @@
*/
/**
- * @file drivers/gdisp/ILI9325/gdisp_lld_board_example.h
+ * @file drivers/gdisp/ILI9325/gdisp_lld_board_template.h
* @brief GDISP Graphic Driver subsystem board interface for the ILI9325 display.
*
* @addtogroup GDISP
@@ -17,28 +17,27 @@
#define GDISP_LLD_BOARD_H
static inline void gdisp_lld_init_board(void) {
- #error "ILI9325: You must implement the init_board routine for your board"
+
}
static inline void gdisp_lld_reset_pin(bool_t state) {
- #error "ILI9325: You must implement setpin_reset routine for your board"
+
}
static inline void gdisp_lld_write_index(uint16_t data) {
- #error "ILI9325: You must implement write_index routine for your board"
+
}
static inline void gdisp_lld_write_data(uint16_t data) {
- #error "ILI9325: You must implement write_data routine for your board"
+
}
static inline uint16_t gdisp_lld_read_data(void) {
- #error "ILI9325: You must implement read_data routine for your board"
+
}
-/* if not available, just ignore the argument and return */
static inline uint16_t gdisp_lld_backlight(uint8_t percentage) {
- #error "ILI9325: You must implement set_backlight routine for your board"
+
}
#endif /* GDISP_LLD_BOARD_H */
diff --git a/drivers/gdisp/ILI9325/readme.txt b/drivers/gdisp/ILI9325/readme.txt
deleted file mode 100644
index 9bd96e6a..00000000
--- a/drivers/gdisp/ILI9325/readme.txt
+++ /dev/null
@@ -1,15 +0,0 @@
-To use this driver:
-
-1. Add in your gfxconf.h:
- a) #define GFX_USE_GDISP TRUE
-
- b) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
-
- d) If you are not using a known board then create a gdisp_lld_board.h file
- and ensure it is on your include path.
- Use the gdisp_lld_board_example.h file as a basis.
- Currently known boards are:
- HY_STM32_100p
-
-2. To your makefile add the following lines:
- include $(GFXLIB)/drivers/gdisp/ILI9325/gdisp_lld.mk