aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/gdisp/Nokia6610GE12
diff options
context:
space:
mode:
authorJoel Bodenmann <joel@unormal.org>2013-07-21 17:42:25 +0200
committerJoel Bodenmann <joel@unormal.org>2013-07-21 17:42:25 +0200
commitd98e6c5d0d6c048c99aeda810da10e6a6a130325 (patch)
tree397a911a667c873bcd68419307519210fe150e9b /drivers/gdisp/Nokia6610GE12
parentc29950c7670397d60b32e92fa4aadb29fea227a4 (diff)
downloaduGFX-d98e6c5d0d6c048c99aeda810da10e6a6a130325.tar.gz
uGFX-d98e6c5d0d6c048c99aeda810da10e6a6a130325.tar.bz2
uGFX-d98e6c5d0d6c048c99aeda810da10e6a6a130325.zip
cleaned up board file mess
Diffstat (limited to 'drivers/gdisp/Nokia6610GE12')
-rw-r--r--drivers/gdisp/Nokia6610GE12/gdisp_lld.c10
-rw-r--r--drivers/gdisp/Nokia6610GE12/gdisp_lld_board_template.h (renamed from drivers/gdisp/Nokia6610GE12/gdisp_lld_board_example.h)224
-rw-r--r--drivers/gdisp/Nokia6610GE12/readme.txt15
3 files changed, 109 insertions, 140 deletions
diff --git a/drivers/gdisp/Nokia6610GE12/gdisp_lld.c b/drivers/gdisp/Nokia6610GE12/gdisp_lld.c
index a200d9fe..74043c96 100644
--- a/drivers/gdisp/Nokia6610GE12/gdisp_lld.c
+++ b/drivers/gdisp/Nokia6610GE12/gdisp_lld.c
@@ -54,15 +54,7 @@
/* Driver local functions. */
/*===========================================================================*/
-#if defined(GDISP_USE_CUSTOM_BOARD) && GDISP_USE_CUSTOM_BOARD
- /* Include the user supplied board definitions */
- #include "gdisp_lld_board.h"
-#elif defined(BOARD_OLIMEX_SAM7_EX256)
- #include "gdisp_lld_board_olimexsam7ex256.h"
-#else
- /* Include the user supplied board definitions */
- #include "gdisp_lld_board.h"
-#endif
+#include "gdisp_lld_board.h"
// Some macros just to make reading the code easier
#define delayms(ms) gfxSleepMilliseconds(ms)
diff --git a/drivers/gdisp/Nokia6610GE12/gdisp_lld_board_example.h b/drivers/gdisp/Nokia6610GE12/gdisp_lld_board_template.h
index f4058190..8aeb633b 100644
--- a/drivers/gdisp/Nokia6610GE12/gdisp_lld_board_example.h
+++ b/drivers/gdisp/Nokia6610GE12/gdisp_lld_board_template.h
@@ -4,119 +4,111 @@
*
* http://chibios-gfx.com/license.html
*/
-
-/**
- * @file drivers/gdisp/Nokia6610GE12/gdisp_lld_board_example.h
- * @brief GDISP Graphic Driver subsystem board interface for the Nokia6610 GE12 display.
- *
- * @addtogroup GDISP
- * @{
- */
-
-#ifndef _GDISP_LLD_BOARD_H
-#define _GDISP_LLD_BOARD_H
-
-/**
- * @brief Initialise the board for the display.
- * @notes Performs the following functions:
- * 1. initialise the spi port used by your display
- * 2. initialise the reset pin (initial state not-in-reset)
- * 3. initialise the chip select pin (initial state not-active)
- * 4. initialise the backlight pin (initial state back-light off)
- *
- * @notapi
- */
-static inline void init_board(void) {
- /* Code here */
- #error "gdispNokia6610GE12: You must supply a definition for init_board for your board"
-}
-
-/**
- * @brief Set or clear the lcd reset pin.
- *
- * @param[in] state TRUE = lcd in reset, FALSE = normal operation
- *
- * @notapi
- */
-static inline void setpin_reset(bool_t state) {
- /* Code here */
- #error "gdispNokia6610GE12: You must supply a definition for setpin_reset for your board"
-}
-
-/**
- * @brief Set the lcd back-light level.
- * @note For now 0% turns the backlight off, anything else the backlight is on.
- * While the hardware supports PWM backlight control, we are not using it
- * yet.
- *
- * @param[in] percent 0 to 100%
- *
- * @notapi
- */
-static inline void set_backlight(uint8_t percent) {
- /* Code here */
- #error "gdispNokia6610GE12: You must supply a definition for set_backlight for your board"
-}
-
-/**
- * @brief Take exclusive control of the bus
- *
- * @notapi
- */
-static inline void acquire_bus(void) {
- /* Code here */
- #error "gdispNokia6610GE12: You must supply a definition for acquire_bus for your board"
-}
-
-/**
- * @brief Release exclusive control of the bus
- *
- * @notapi
- */
-static inline void release_bus(void) {
- /* Code here */
- #error "gdispNokia6610GE12: You must supply a definition for release_bus for your board"
-}
-
-/**
- * @brief Send an 8 bit command to the lcd.
- *
- * @param[in] cmd The command to send
- *
- * @notapi
- */
-static inline void write_cmd(uint16_t cmd) {
- /* Code here */
- #error "gdispNokia6610GE12: You must supply a definition for write_cmd for your board"
-}
-
-/**
- * @brief Send an 8 bit data to the lcd.
- *
- * @param[in] data The data to send
- *
- * @notapi
- */
-static inline void write_data(uint16_t data) {
- /* Code here */
- #error "gdispNokia6610GE12: You must supply a definition for write_data for your board"
-}
-
-#if GDISP_HARDWARE_READPIXEL || GDISP_HARDWARE_SCROLL || defined(__DOXYGEN__)
-/**
- * @brief Read data from the lcd.
- *
- * @return The data from the lcd
- * @note The chip select may need to be asserted/de-asserted
- * around the actual spi read
- *
- * @notapi
- */
-static inline uint16_t read_data(void) {
- /* Code here */
- #error "gdispNokia6610GE12: You must supply a definition for read_data for your board"
-}
-#endif
-
-#endif /* _GDISP_LLD_BOARD_H */
-/** @} */
+
+/**
+ * @file drivers/gdisp/Nokia6610GE8/gdisp_lld_board_template.h
+ * @brief GDISP Graphic Driver subsystem board interface for the Nokia6610 GE8 display.
+ *
+ * @addtogroup GDISP
+ * @{
+ */
+
+#ifndef _GDISP_LLD_BOARD_H
+#define _GDISP_LLD_BOARD_H
+
+/**
+ * @brief Initialise the board for the display.
+ * @notes Performs the following functions:
+ * 1. initialise the spi port used by your display
+ * 2. initialise the reset pin (initial state not-in-reset)
+ * 3. initialise the chip select pin (initial state not-active)
+ * 4. initialise the backlight pin (initial state back-light off)
+ *
+ * @notapi
+ */
+static inline void init_board(void) {
+
+}
+
+/**
+ * @brief Set or clear the lcd reset pin.
+ *
+ * @param[in] state TRUE = lcd in reset, FALSE = normal operation
+ *
+ * @notapi
+ */
+static inline void setpin_reset(bool_t state) {
+
+}
+
+/**
+ * @brief Set the lcd back-light level.
+ * @note For now 0% turns the backlight off, anything else the backlight is on.
+ * While the hardware supports PWM backlight control, we are not using it
+ * yet.
+ *
+ * @param[in] percent 0 to 100%
+ *
+ * @notapi
+ */
+static inline void set_backlight(uint8_t percent) {
+
+}
+
+/**
+ * @brief Take exclusive control of the bus
+ *
+ * @notapi
+ */
+static inline void acquire_bus(void) {
+
+}
+
+/**
+ * @brief Release exclusive control of the bus
+ *
+ * @notapi
+ */
+static inline void release_bus(void) {
+
+}
+
+/**
+ * @brief Send an 8 bit command to the lcd.
+ *
+ * @param[in] cmd The command to send
+ *
+ * @notapi
+ */
+static inline void write_cmd(uint16_t cmd) {
+
+}
+
+/**
+ * @brief Send an 8 bit data to the lcd.
+ *
+ * @param[in] data The data to send
+ *
+ * @notapi
+ */
+static inline void write_data(uint16_t data) {
+
+}
+
+#if GDISP_HARDWARE_READPIXEL || GDISP_HARDWARE_SCROLL || defined(__DOXYGEN__)
+/**
+ * @brief Read data from the lcd.
+ *
+ * @return The data from the lcd
+ * @note The chip select may need to be asserted/de-asserted
+ * around the actual spi read
+ *
+ * @notapi
+ */
+static inline uint16_t read_data(void) {
+
+}
+#endif
+
+#endif /* _GDISP_LLD_BOARD_H */
+/** @} */
diff --git a/drivers/gdisp/Nokia6610GE12/readme.txt b/drivers/gdisp/Nokia6610GE12/readme.txt
deleted file mode 100644
index bc0ee248..00000000
--- a/drivers/gdisp/Nokia6610GE12/readme.txt
+++ /dev/null
@@ -1,15 +0,0 @@
-This driver is for the Nokia6610 Philips (GE12) controller
-
-To use this driver:
-
-1. Add in your gfxconf.h:
- a) #define GFX_USE_GDISP TRUE
- b) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
- c) If you are not using a known board then create a gdisp_lld_board.h file
- and ensure it is on your include path.
- Use the gdisp_lld_board_example.h file as a basis.
- Currently known boards are:
- Olimex SAM7-EX256
-
-2. To your makefile add the following lines:
- include $(GFXLIB)/drivers/gdisp/Nokia6610GE12/gdisp_lld.mk