aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/gdisp/RA8875/readme.txt
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2013-06-22 23:14:54 +1000
committerinmarket <andrewh@inmarket.com.au>2013-06-22 23:14:54 +1000
commitc8300fe9c2c7facff1ad32978a5d961690473de4 (patch)
tree0e653df0a5d733e254b2d5d3a463968285340837 /drivers/gdisp/RA8875/readme.txt
parentd362d9603e9d161e7006282f882205754e5afc58 (diff)
parent9aa1e95423f681277d048bed6b9acc5101f2cbe2 (diff)
downloaduGFX-c8300fe9c2c7facff1ad32978a5d961690473de4.tar.gz
uGFX-c8300fe9c2c7facff1ad32978a5d961690473de4.tar.bz2
uGFX-c8300fe9c2c7facff1ad32978a5d961690473de4.zip
Merge branch 'master' into GWIN
Diffstat (limited to 'drivers/gdisp/RA8875/readme.txt')
-rw-r--r--drivers/gdisp/RA8875/readme.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/drivers/gdisp/RA8875/readme.txt b/drivers/gdisp/RA8875/readme.txt
new file mode 100644
index 00000000..ff4222b3
--- /dev/null
+++ b/drivers/gdisp/RA8875/readme.txt
@@ -0,0 +1,38 @@
+To use this driver:
+
+1. Add in your halconf.h:
+ a) #define GFX_USE_GDISP TRUE
+ b) Any optional high level driver defines (see gdisp.h) eg: #define GDISP_NEED_MULTITHREAD TRUE
+ c) One (only) of:
+ #define GDISP_USE_GPIO
+ #define GDISP_USE_FSMC
+ d) If you want to use DMA (only works with FSMC):
+ #define GDISP_USE_DMA
+ #define GDISP_DMA_STREAM STM32_DMA2_STREAM6 //You can change the DMA channel according to your needs
+
+2. Edit gdisp_lld_panel.h with your panel properties
+
+3. To your makefile add the following lines:
+ include $(GFXLIB)/drivers/gdisp/RA8875/gdisp_lld.mk
+
+
+Example FSMC config with DMA:
+
+#define GDISP_SCREEN_WIDTH 480
+#define GDISP_SCREEN_HEIGHT 272
+
+#define GDISP_USE_FSMC
+
+#define GDISP_USE_DMA
+#define GDISP_DMA_STREAM STM32_DMA2_STREAM6
+
+#if defined(GDISP_USE_GPIO)
+
+ #define GDISP_CMD_PORT GPIOC
+ #define GDISP_DATA_PORT GPIOD
+
+ #define GDISP_CS 0
+ #define GDISP_RS 1
+ #define GDISP_WR 2
+ #define GDISP_RD 3
+#endif