aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/gdisp/S6D1121/readme.txt
diff options
context:
space:
mode:
authorTectu <joel@unormal.org>2012-08-14 02:10:57 +0200
committerTectu <joel@unormal.org>2012-08-14 02:10:57 +0200
commite6373df68bbfc508493aabaec2b56335f8a8d6b0 (patch)
tree18c57aafd64b5e7d7dd64d028713224b4918c171 /drivers/gdisp/S6D1121/readme.txt
parent975faaab679c7a872e0390ac533abf79b08dedbf (diff)
downloaduGFX-e6373df68bbfc508493aabaec2b56335f8a8d6b0.tar.gz
uGFX-e6373df68bbfc508493aabaec2b56335f8a8d6b0.tar.bz2
uGFX-e6373df68bbfc508493aabaec2b56335f8a8d6b0.zip
removed gdisp prefix on gdisp drivers
Diffstat (limited to 'drivers/gdisp/S6D1121/readme.txt')
-rw-r--r--drivers/gdisp/S6D1121/readme.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/drivers/gdisp/S6D1121/readme.txt b/drivers/gdisp/S6D1121/readme.txt
new file mode 100644
index 00000000..fc24d4a2
--- /dev/null
+++ b/drivers/gdisp/S6D1121/readme.txt
@@ -0,0 +1,16 @@
+To use this driver:
+
+1. Add in your halconf.h:
+ a) #define HAL_USE_GDISP TRUE
+ b) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
+ c) One (only) of:
+ #define LCD_USE_GPIO
+ #define LCD_USE_SPI
+ #define LCD_USE_FSMC
+ d) All of the following (with appropriate values):
+ #define SCREEN_WIDTH 320
+ #define SCREEN_HEIGHT 240
+
+2. To your makefile add the following lines:
+ include $(CHIBIOS)/os/halext/halext.mk
+ include $(CHIBIOS)/os/halext/drivers/gdispS6d1121/gdisp_lld.mk