aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/gdisp/SSD1963/readme.txt
diff options
context:
space:
mode:
authorJoel Bodenmann <joel@unormal.org>2013-02-11 09:25:26 +0100
committerJoel Bodenmann <joel@unormal.org>2013-02-11 09:25:26 +0100
commit885b3d53b3a491c62fb0634b78cb9857723ac15d (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /drivers/gdisp/SSD1963/readme.txt
parent851e5fb09bdc086d734647128fd3051c3a8528e2 (diff)
downloaduGFX-885b3d53b3a491c62fb0634b78cb9857723ac15d.tar.gz
uGFX-885b3d53b3a491c62fb0634b78cb9857723ac15d.tar.bz2
uGFX-885b3d53b3a491c62fb0634b78cb9857723ac15d.zip
removed GDISP_LLD() macro
Diffstat (limited to 'drivers/gdisp/SSD1963/readme.txt')
-rw-r--r--drivers/gdisp/SSD1963/readme.txt38
1 files changed, 0 insertions, 38 deletions
diff --git a/drivers/gdisp/SSD1963/readme.txt b/drivers/gdisp/SSD1963/readme.txt
deleted file mode 100644
index 567faf58..00000000
--- a/drivers/gdisp/SSD1963/readme.txt
+++ /dev/null
@@ -1,38 +0,0 @@
-To use this driver:
-
-1. Add in your halconf.h:
- a) #define GFX_USE_GDISP TRUE
- b) Any optional high level driver defines (see gdisp.h) eg: #define GDISP_NEED_MULTITHREAD TRUE
- c) One (only) of:
- #define GDISP_USE_GPIO
- #define GDISP_USE_FSMC
- d) If you want to use DMA (only works with FSMC):
- #define GDISP_USE_DMA
- #define GDISP_DMA_STREAM STM32_DMA2_STREAM6 //You can change the DMA channel according to your needs
-
-2. Edit gdisp_lld_panel.h with your panel properties
-
-3. To your makefile add the following lines:
- include $(GFXLIB)/drivers/gdisp/SSD1963/gdisp_lld.mk
-
-
-Example FSMC config with DMA:
-
-#define GDISP_SCREEN_WIDTH 480
-#define GDISP_SCREEN_HEIGHT 272
-
-#define GDISP_USE_FSMC
-
-#define GDISP_USE_DMA
-#define GDISP_DMA_STREAM STM32_DMA2_STREAM6
-
-#if defined(GDISP_USE_GPIO)
-
- #define GDISP_CMD_PORT GPIOC
- #define GDISP_DATA_PORT GPIOD
-
- #define GDISP_CS 0
- #define GDISP_RS 1
- #define GDISP_WR 2
- #define GDISP_RD 3
-#endif