aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/gdisp/SSD1963/readme.txt
diff options
context:
space:
mode:
authormobyfab <mobyfab@free.fr>2012-08-30 22:40:28 +0200
committermobyfab <mobyfab@free.fr>2012-08-30 22:40:28 +0200
commitc67453a0be1629e9b28868bf1d1055f702edec21 (patch)
tree2cc0fb29a115381af2377d9cda643587f21f46f2 /drivers/gdisp/SSD1963/readme.txt
parent661d0bb2fe91098e2ae9153f16a3f0442b558401 (diff)
downloaduGFX-c67453a0be1629e9b28868bf1d1055f702edec21.tar.gz
uGFX-c67453a0be1629e9b28868bf1d1055f702edec21.tar.bz2
uGFX-c67453a0be1629e9b28868bf1d1055f702edec21.zip
Adding SSD1963
Diffstat (limited to 'drivers/gdisp/SSD1963/readme.txt')
-rw-r--r--drivers/gdisp/SSD1963/readme.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/drivers/gdisp/SSD1963/readme.txt b/drivers/gdisp/SSD1963/readme.txt
new file mode 100644
index 00000000..2496fc51
--- /dev/null
+++ b/drivers/gdisp/SSD1963/readme.txt
@@ -0,0 +1,35 @@
+To use this driver template
+ 1. Copy this entire directory (including the directory itself)
+ into halext/drivers
+ 2. Rename the directory to match your hardware.
+ 3. Customise each file in the directory including the .mk file
+ and this file. An example for this file is below...
+ 4. Keep any board specific code in a file you create called
+ gdisp_lld_board_yourboardname.h and adjust gdisp.c to match.
+ This enables someone porting to a new board to add another
+ suitable boad definition without worrying about the rest of
+ the driver. See the gdispNokia6610 driver as an example.
+
+------------------------------------------------------------------
+To use this driver:
+
+1. Add in your halconf.h:
+ a) #define HAL_USE_GDISP TRUE
+ b) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
+ c) One (only) of:
+ #define LCD_USE_GPIO
+ #define LCD_USE_SPI
+ #define LCD_USE_FSMC
+ d) All of the following (with appropriate values):
+ #define SCREEN_WIDTH 128
+ #define SCREEN_HEIGHT 128
+ e) If you are not using a known board then create a gdisp_lld_board.h file
+ and ensure it is on your include path.
+ Use the gdisp_lld_board_example.h file as a basis.
+ Currently known boards are:
+ XXXXXXXXX
+
+
+2. To your makefile add the following lines:
+ include $(CHIBIOS)/os/halext/halext.mk
+ include $(CHIBIOS)/os/halext/drivers/gdispXXXXX/gdisp_lld.mk