aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/gdisp/SSD2119/readme.txt
diff options
context:
space:
mode:
authorMateusz Tomaszkiewicz <silentdemon@gmail.com>2013-02-21 22:46:47 +0100
committerMateusz Tomaszkiewicz <silentdemon@gmail.com>2013-02-21 22:46:47 +0100
commitcec4628a9777233c699bda86a747f49de576105b (patch)
treec99b2df689291eb384f2356a80e102b49c6824ac /drivers/gdisp/SSD2119/readme.txt
parentd9a92aa30cd5d917bd0a8450b2dc8ceb6f67f750 (diff)
downloaduGFX-cec4628a9777233c699bda86a747f49de576105b.tar.gz
uGFX-cec4628a9777233c699bda86a747f49de576105b.tar.bz2
uGFX-cec4628a9777233c699bda86a747f49de576105b.zip
SSD2119: backlight control
- Backlight uses PWM on TIM4 CH2. - Updated readme. - Updated gdisp_lld.c: moved from lld_gdisp_* to gdisp_lld_* functions names format. - One forgotten GDISP_LLD() macro removal. - General code cleanup (make diff with -w parameter ;))
Diffstat (limited to 'drivers/gdisp/SSD2119/readme.txt')
-rw-r--r--drivers/gdisp/SSD2119/readme.txt45
1 files changed, 25 insertions, 20 deletions
diff --git a/drivers/gdisp/SSD2119/readme.txt b/drivers/gdisp/SSD2119/readme.txt
index e9f6558a..f77e6259 100644
--- a/drivers/gdisp/SSD2119/readme.txt
+++ b/drivers/gdisp/SSD2119/readme.txt
@@ -1,20 +1,25 @@
-To use this driver:
-
-1. Add in your halconf.h:
- a) #define GFX_USE_GDISP TRUE
-
- b) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
-
- c) If you are not using a known board then create a gdisp_lld_board.h file
- and ensure it is on your include path.
- Use the gdisp_lld_board_embest_dmstf4bb_fsmc.h or gdisp_lld_board_embest_dmstf4bb_fsmc.h file as a basis.
- Currently known boards are:
- BOARD_EMBEST_DMSTF4BB - GPIO interface
- BOARD_EMBEST_DMSTF4BB_FSMC - FSMC interface
-
- d) The following are optional - define them if you are not using the defaults below:
- #define GDISP_SCREEN_WIDTH 320
- #define GDISP_SCREEN_HEIGHT 240
-
-2. To your makefile add the following lines:
- include $(GFXLIB)/drivers/gdisp/SSD2119/gdisp_lld.mk
+Description:
+
+Driver for LCD with 16-bit interface in 8080 mode (65k colors).
+
+To use this driver:
+
+1. Add in your halconf.h:
+ a) #define GFX_USE_GDISP TRUE
+
+ b) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
+
+ c) If you are not using a known board then create a gdisp_lld_board.h file
+ and ensure it is on your include path.
+ Use the gdisp_lld_board_embest_dmstf4bb_fsmc.h or gdisp_lld_board_embest_dmstf4bb_fsmc.h file as a basis.
+ Currently known boards are:
+ BOARD_EMBEST_DMSTF4BB - GPIO interface
+ BOARD_EMBEST_DMSTF4BB_FSMC - FSMC interface
+ Both board configurations assume you have STM32_PWM_USE_TIM4 set to TRUE in your mcuconf.h.
+
+ d) The following are optional - define them if you are not using the defaults below:
+ #define GDISP_SCREEN_WIDTH 320
+ #define GDISP_SCREEN_HEIGHT 240
+
+2. To your makefile add the following lines:
+ include $(GFXLIB)/drivers/gdisp/SSD2119/gdisp_lld.mk