aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/gdisp/TestStub/readme.txt
diff options
context:
space:
mode:
authorTectu <joel@unormal.org>2012-08-14 02:10:57 +0200
committerTectu <joel@unormal.org>2012-08-14 02:10:57 +0200
commite6373df68bbfc508493aabaec2b56335f8a8d6b0 (patch)
tree18c57aafd64b5e7d7dd64d028713224b4918c171 /drivers/gdisp/TestStub/readme.txt
parent975faaab679c7a872e0390ac533abf79b08dedbf (diff)
downloaduGFX-e6373df68bbfc508493aabaec2b56335f8a8d6b0.tar.gz
uGFX-e6373df68bbfc508493aabaec2b56335f8a8d6b0.tar.bz2
uGFX-e6373df68bbfc508493aabaec2b56335f8a8d6b0.zip
removed gdisp prefix on gdisp drivers
Diffstat (limited to 'drivers/gdisp/TestStub/readme.txt')
-rw-r--r--drivers/gdisp/TestStub/readme.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/drivers/gdisp/TestStub/readme.txt b/drivers/gdisp/TestStub/readme.txt
new file mode 100644
index 00000000..83611acf
--- /dev/null
+++ b/drivers/gdisp/TestStub/readme.txt
@@ -0,0 +1,17 @@
+This low level driver is a test stub that doesn't talk to any
+real hardware. It is included to allow testing of the compilation
+process.
+
+Do not use this driver as a template for new drivers. Use the
+ templates/gdispXXXXX directory for that.
+
+To use this driver:
+
+1. Add in your halconf.h:
+ a) #define HAL_USE_GDISP TRUE
+ b) Any optional high level driver defines (see gdisp.h)
+ you want to compile test eg: GDISP_NEED_MULTITHREAD
+
+2. To your makefile add the following lines:
+ include $(CHIBIOS)/os/halext/halext.mk
+ include $(CHIBIOS)/os/halext/drivers/gdispTestStub/gdisp_lld.mk