aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/gdisp/framebuffer
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2018-02-27 17:44:21 +1000
committerinmarket <andrewh@inmarket.com.au>2018-02-27 17:44:21 +1000
commitf265924396167729e8d9fb36a0383263f36c1270 (patch)
tree28843eb24b18999cf0217ecb0fe935f133901066 /drivers/gdisp/framebuffer
parent14786e97b618b8bc2a0ff1c732d45288fe550e33 (diff)
downloaduGFX-f265924396167729e8d9fb36a0383263f36c1270.tar.gz
uGFX-f265924396167729e8d9fb36a0383263f36c1270.tar.bz2
uGFX-f265924396167729e8d9fb36a0383263f36c1270.zip
First set of V3 macro changes
Diffstat (limited to 'drivers/gdisp/framebuffer')
-rw-r--r--drivers/gdisp/framebuffer/board_framebuffer_template.h2
-rw-r--r--drivers/gdisp/framebuffer/gdisp_lld_config.h6
-rw-r--r--drivers/gdisp/framebuffer/readme.txt2
3 files changed, 5 insertions, 5 deletions
diff --git a/drivers/gdisp/framebuffer/board_framebuffer_template.h b/drivers/gdisp/framebuffer/board_framebuffer_template.h
index 0ee08ef2..3e74e92b 100644
--- a/drivers/gdisp/framebuffer/board_framebuffer_template.h
+++ b/drivers/gdisp/framebuffer/board_framebuffer_template.h
@@ -11,7 +11,7 @@
#endif
// Uncomment this if your frame buffer device requires flushing
-//#define GDISP_HARDWARE_FLUSH TRUE
+//#define GDISP_HARDWARE_FLUSH GFXON
#ifdef GDISP_DRIVER_VMT
diff --git a/drivers/gdisp/framebuffer/gdisp_lld_config.h b/drivers/gdisp/framebuffer/gdisp_lld_config.h
index 08dbbb39..c12fa401 100644
--- a/drivers/gdisp/framebuffer/gdisp_lld_config.h
+++ b/drivers/gdisp/framebuffer/gdisp_lld_config.h
@@ -14,9 +14,9 @@
/* Driver hardware support. */
/*===========================================================================*/
-#define GDISP_HARDWARE_DRAWPIXEL TRUE
-#define GDISP_HARDWARE_PIXELREAD TRUE
-#define GDISP_HARDWARE_CONTROL TRUE
+#define GDISP_HARDWARE_DRAWPIXEL GFXON
+#define GDISP_HARDWARE_PIXELREAD GFXON
+#define GDISP_HARDWARE_CONTROL GFXON
// Any other support comes from the board file
#include "board_framebuffer.h"
diff --git a/drivers/gdisp/framebuffer/readme.txt b/drivers/gdisp/framebuffer/readme.txt
index e13321e4..ead74122 100644
--- a/drivers/gdisp/framebuffer/readme.txt
+++ b/drivers/gdisp/framebuffer/readme.txt
@@ -1,7 +1,7 @@
To use this driver:
1. Add in your gfxconf.h:
- a) #define GFX_USE_GDISP TRUE
+ a) #define GFX_USE_GDISP GFXON
2. To your makefile add the following lines:
include $(GFXLIB)/gfx.mk