aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/multiple/SDL/readme.txt
diff options
context:
space:
mode:
authorOleg Gerasimov <ogerasimov@gmail.com>2016-08-08 00:11:29 +0300
committerOleg Gerasimov <ogerasimov@gmail.com>2016-08-08 00:11:29 +0300
commitcbb06179813b0ae2c54c2b8d0ff14b71dfd1914e (patch)
tree51f7ba6ba0a8c0be6ddbc5dbe606bcfe379e0fd4 /drivers/multiple/SDL/readme.txt
parent0c695b2471c347847e579aa19ada5612341bfc2d (diff)
downloaduGFX-cbb06179813b0ae2c54c2b8d0ff14b71dfd1914e.tar.gz
uGFX-cbb06179813b0ae2c54c2b8d0ff14b71dfd1914e.tar.bz2
uGFX-cbb06179813b0ae2c54c2b8d0ff14b71dfd1914e.zip
Added SDL multiply driver
Diffstat (limited to 'drivers/multiple/SDL/readme.txt')
-rw-r--r--drivers/multiple/SDL/readme.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/drivers/multiple/SDL/readme.txt b/drivers/multiple/SDL/readme.txt
new file mode 100644
index 00000000..3bbaec59
--- /dev/null
+++ b/drivers/multiple/SDL/readme.txt
@@ -0,0 +1,26 @@
+To use this driver:
+
+This driver is special in that it implements both the gdisp low level driver
+and a touchscreen driver.
+
+1. Add in your gfxconf.h:
+ a) #define GFX_USE_GDISP TRUE
+ b) #define GFX_USE_GINPUT TRUE
+ #define GINPUT_USE_MOUSE TRUE
+ c) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
+ d) Optionally the following (with appropriate values):
+ #define GDISP_SCREEN_WIDTH 640
+ #define GDISP_SCREEN_HEIGHT 480
+
+2. To your makefile add the following lines:
+ include $(GFXLIB)/gfx.mk
+ include $(GFXLIB)/drivers/multiple/SDL/gdisp_lld.mk
+
+3. Install sdl2
+ on Linux:
+ sudo apt-get install libsdl2-dev
+ on OSX:
+ brew install sdl2 --universal
+
+4. Modify your makefile to add `sdl2-config --libs --cflags` to the CFLAGS line. i.e.
+ CFLAGS = `sdl2-config --libs --cflags`