aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/multiple/Win32/readme.txt
diff options
context:
space:
mode:
authorAndrew Hannam <andrewh@inmarket.com.au>2012-11-26 18:45:26 +1000
committerAndrew Hannam <andrewh@inmarket.com.au>2012-11-26 18:45:26 +1000
commit8275c8820f230342939a2410dd0b24c0f26a14e5 (patch)
treefcb202fb077e7d78e1381e5ef531bbf96dcca3cf /drivers/multiple/Win32/readme.txt
parent6cc2bc280cc7dc4cb546d94219210d65c15df2e1 (diff)
downloaduGFX-8275c8820f230342939a2410dd0b24c0f26a14e5.tar.gz
uGFX-8275c8820f230342939a2410dd0b24c0f26a14e5.tar.bz2
uGFX-8275c8820f230342939a2410dd0b24c0f26a14e5.zip
Ginput and structure changes
GINPUT Touch including drivers GTIMER fixes GEVENT fixes GWIN button completion Structure changes to better seperate sections of a sub-system
Diffstat (limited to 'drivers/multiple/Win32/readme.txt')
-rw-r--r--drivers/multiple/Win32/readme.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/drivers/multiple/Win32/readme.txt b/drivers/multiple/Win32/readme.txt
new file mode 100644
index 00000000..6151f2f2
--- /dev/null
+++ b/drivers/multiple/Win32/readme.txt
@@ -0,0 +1,22 @@
+To use this driver:
+
+This driver is special in that it implements both the gdisp low level driver
+and a touchscreen driver.
+
+1. Add in your halconf.h:
+ a) #define GFX_USE_GDISP TRUE
+ b) #define GFX_USE_GINPUT TRUE
+ #define GINPUT_USE_MOUSE TRUE
+ c) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
+ d) All of the following (with appropriate values):
+ #define GDISP_SCREEN_WIDTH 640
+ #define GDISP_SCREEN_HEIGHT 480
+
+
+2. To your makefile add the following lines:
+ include $(GFXLIB)/gfx.mk
+ include $(GFXLIB)/drivers/multiple/Win32/gdisp_lld.mk
+
+3. Modify your makefile to add -lgdi32 to the DLIBS line. i.e.
+ DLIBS = -lws2_32 -lgdi32
+