aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/touchscreen
diff options
context:
space:
mode:
authorJoel Bodenmann <joel.bodenmann@hevs.ch>2012-11-10 00:05:01 +0100
committerJoel Bodenmann <joel.bodenmann@hevs.ch>2012-11-10 00:05:01 +0100
commit87b6d98055afff7c46bd6bdd7db7ba7c1d8e7a57 (patch)
tree515085fe2b901604f1e88c6645583827ee3922b1 /drivers/touchscreen
parent995c9835c282e8904ff918e325f0491249bdcc89 (diff)
downloaduGFX-87b6d98055afff7c46bd6bdd7db7ba7c1d8e7a57.tar.gz
uGFX-87b6d98055afff7c46bd6bdd7db7ba7c1d8e7a57.tar.bz2
uGFX-87b6d98055afff7c46bd6bdd7db7ba7c1d8e7a57.zip
renamed touchpad into touchscreen
Diffstat (limited to 'drivers/touchscreen')
-rw-r--r--drivers/touchscreen/ADS7843/readme.txt8
-rw-r--r--drivers/touchscreen/ADS7843/touchscreen_lld.c241
-rw-r--r--drivers/touchscreen/ADS7843/touchscreen_lld.mk6
-rw-r--r--drivers/touchscreen/ADS7843/touchscreen_lld_config.h45
-rw-r--r--drivers/touchscreen/XPT2046/readme.txt8
-rw-r--r--drivers/touchscreen/XPT2046/touchscreen_lld.c241
-rw-r--r--drivers/touchscreen/XPT2046/touchscreen_lld.mk6
-rw-r--r--drivers/touchscreen/XPT2046/touchscreen_lld_config.h45
8 files changed, 600 insertions, 0 deletions
diff --git a/drivers/touchscreen/ADS7843/readme.txt b/drivers/touchscreen/ADS7843/readme.txt
new file mode 100644
index 00000000..85f40da5
--- /dev/null
+++ b/drivers/touchscreen/ADS7843/readme.txt
@@ -0,0 +1,8 @@
+To use this driver:
+
+1. Add in your halconf.h:
+ a) #define GFX_USE_TOUCHSCREEN TRUE
+
+2. To your makefile add the following lines:
+ include $(GFXLIB)/drivers/touchscreen/ADS7843/touchscreen_lld.mk
+
diff --git a/drivers/touchscreen/ADS7843/touchscreen_lld.c b/drivers/touchscreen/ADS7843/touchscreen_lld.c
new file mode 100644
index 00000000..98e25383
--- /dev/null
+++ b/drivers/touchscreen/ADS7843/touchscreen_lld.c
@@ -0,0 +1,241 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file drivers/touchscreen/ADS7843/touchscreen_lld.c
+ * @brief Touchscreen Driver subsystem low level driver source.
+ *
+ * @addtogroup TOUCHSCREEN
+ * @{
+ */
+
+#include "ch.h"
+#include "hal.h"
+#include "touchscreen.h"
+
+#if GFX_USE_TOUCHSCREEN /*|| defined(__DOXYGEN__)*/
+
+/*===========================================================================*/
+/* Driver local definitions. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver exported variables. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver local variables. */
+/*===========================================================================*/
+#if !defined(__DOXYGEN__)
+ /* Local copy of the current touchscreen driver */
+ static const TouchscreenDriver *tsDriver;
+
+ static uint16_t sampleBuf[7];
+#endif
+
+/*===========================================================================*/
+/* Driver local functions. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver interrupt handlers. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver exported functions. */
+/*===========================================================================*/
+
+/* ---- Required Routines ---- */
+
+/**
+ * @brief Low level touchscreen driver initialization.
+ *
+ * @param[in] ts The touchscreen driver
+ *
+ * @notapi
+ */
+void ts_lld_init(const TouchscreenDriver *ts) {
+ tsDriver = ts;
+
+ if(tsDriver->direct_init)
+ spiStart(tsDriver->spip, tsDriver->spicfg);
+}
+
+
+/**
+ * @brief Reads a conversion from the touchscreen
+ *
+ * @param[in] cmd The command bits to send to the touchscreen
+ *
+ * @return The read value 12-bit right-justified
+ *
+ * @note This function only reads data, it is assumed that the pins are
+ * configured properly and the bus has been acquired beforehand
+ *
+ * @notapi
+ */
+uint16_t ts_lld_read_value(uint8_t cmd) {
+ static uint8_t txbuf[3] = {0};
+ static uint8_t rxbuf[3] = {0};
+ uint16_t ret;
+
+ txbuf[0] = cmd;
+
+ spiExchange(tsDriver->spip, 3, txbuf, rxbuf);
+
+ ret = (rxbuf[1] << 5) | (rxbuf[2] >> 3);
+
+ return ret;
+}
+
+/**
+ * @brief 7-point median filtering code for touchscreen samples
+ *
+ * @note This is an internally used routine only.
+ *
+ * @notapi
+ */
+static void ts_lld_filter(void) {
+ uint16_t temp;
+ int i,j;
+
+ for(i = 0; i < 4; i++) {
+ for(j = i; j < 7; j++) {
+ if(sampleBuf[i] > sampleBuf[j]) {
+ /* Swap the values */
+ temp = sampleBuf[i];
+ sampleBuf[i] = sampleBuf[j];
+ sampleBuf[j] = temp;
+ }
+ }
+ }
+}
+
+/**
+ * @brief Reads out the X direction.
+ *
+ * @note The samples are median filtered for greater noise reduction
+ *
+ * @notapi
+ */
+uint16_t ts_lld_read_x(void) {
+ int i;
+
+#if defined(SPI_USE_MUTUAL_EXCLUSION)
+ spiAcquireBus(tsDriver->spip);
+#endif
+
+ TOUCHSCREEN_SPI_PROLOGUE();
+ palClearPad(tsDriver->spicfg->ssport, tsDriver->spicfg->sspad);
+
+ /* Discard the first conversion - very noisy and keep the ADC on hereafter
+ * till we are done with the sampling. Note that PENIRQ is disabled.
+ */
+ ts_lld_read_value(0xD1);
+
+ for(i = 0; i < 7; i++) {
+ sampleBuf[i] = ts_lld_read_value(0xD1);
+ }
+
+ /* Switch on PENIRQ once again - perform a dummy read */
+ ts_lld_read_value(0xD0);
+
+ palSetPad(tsDriver->spicfg->ssport, tsDriver->spicfg->sspad);
+ TOUCHSCREEN_SPI_EPILOGUE();
+
+#if defined(SPI_USE_MUTUAL_EXCLUSION)
+ spiReleaseBus(tsDriver->spip);
+#endif
+
+ /* Find the median - use selection sort */
+ ts_lld_filter();
+
+ return sampleBuf[3];
+}
+
+/*
+ * @brief Reads out the Y direction.
+ *
+ * @notapi
+ */
+uint16_t ts_lld_read_y(void) {
+ int i;
+
+#if defined(SPI_USE_MUTUAL_EXCLUSION)
+ spiAcquireBus(tsDriver->spip);
+#endif
+
+ TOUCHSCREEN_SPI_PROLOGUE();
+ palClearPad(tsDriver->spicfg->ssport, tsDriver->spicfg->sspad);
+
+ /* Discard the first conversion - very noisy and keep the ADC on hereafter
+ * till we are done with the sampling. Note that PENIRQ is disabled.
+ */
+ ts_lld_read_value(0x91);
+
+ for(i = 0; i < 7; i++) {
+ sampleBuf[i] = ts_lld_read_value(0x91);
+ }
+
+ /* Switch on PENIRQ once again - perform a dummy read */
+ ts_lld_read_value(0x90);
+
+ palSetPad(tsDriver->spicfg->ssport, tsDriver->spicfg->sspad);
+ TOUCHSCREEN_SPI_EPILOGUE();
+
+#ifdef SPI_USE_MUTUAL_EXCLUSION
+ spiReleaseBus(tsDriver->spip);
+#endif
+
+ /* Find the median - use selection sort */
+ ts_lld_filter();
+
+ return sampleBuf[3];
+}
+
+/* ---- Optional Routines ---- */
+#if TOUCHSCREEN_HAS_IRQ || defined(__DOXYGEN__)
+ /*
+ * @brief for checking if touchpad is pressed or not.
+ *
+ * @return 1 if pressed / 0 if not pressed
+ *
+ * @notapi
+ */
+ uint8_t ts_lld_irq(void) {
+ return (!palReadPad(tsDriver->tsIRQPort, tsDriver->tsIRQPin));
+ }
+#endif
+
+#if TOUCHSCREEN_HAS_PRESSURE || defined(__DOXYGEN__)
+ /*
+ * @brief Reads out the Z direction / pressure.
+ *
+ * @notapi
+ */
+ uint16_t ts_lld_read_z(void) {
+ /* ToDo */
+ return 42;
+ }
+#endif
+
+#endif /* GFX_USE_TOUCHSCREEN */
+/** @} */
+
diff --git a/drivers/touchscreen/ADS7843/touchscreen_lld.mk b/drivers/touchscreen/ADS7843/touchscreen_lld.mk
new file mode 100644
index 00000000..c58f6647
--- /dev/null
+++ b/drivers/touchscreen/ADS7843/touchscreen_lld.mk
@@ -0,0 +1,6 @@
+# List the required driver.
+GFXSRC += $(GFXLIB)/drivers/touchscreen/ADS7843/touchscreen_lld.c
+
+# Required include directories
+GFXINC += $(GFXLIB)/drivers/touchscreen/ADS7843
+
diff --git a/drivers/touchscreen/ADS7843/touchscreen_lld_config.h b/drivers/touchscreen/ADS7843/touchscreen_lld_config.h
new file mode 100644
index 00000000..5769c288
--- /dev/null
+++ b/drivers/touchscreen/ADS7843/touchscreen_lld_config.h
@@ -0,0 +1,45 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file drivers/touchscreen/ADS7843/touchscreen_lld_config.h
+ * @brief Touchscreen Driver subsystem low level driver.
+ *
+ * @addtogroup TOUCHSCREEN
+ * @{
+ */
+
+#ifndef TOUCHSCREEN_LLD_CONFIG_H
+#define TOUCHSCREEN_LLD_CONFIG_H
+
+#if GFX_USE_TOUCHSCREEN /*|| defined(__DOXYGEN__)*/
+
+/*===========================================================================*/
+/* Driver hardware support. */
+/*===========================================================================*/
+
+#define TOUCHSCREEN_HAS_IRQ TRUE
+#define TOUCHSCREEN_HAS_PRESSURE FALSE
+
+#endif /* GFX_USE_TOUCHSCREEN */
+
+#endif /* TOUCHSCREEN_LLD_CONFIG_H */
+/** @} */
+
diff --git a/drivers/touchscreen/XPT2046/readme.txt b/drivers/touchscreen/XPT2046/readme.txt
new file mode 100644
index 00000000..a81caf67
--- /dev/null
+++ b/drivers/touchscreen/XPT2046/readme.txt
@@ -0,0 +1,8 @@
+To use this driver:
+
+1. Add in your halconf.h:
+ a) #define GFX_USE_TOUCHSCREEN TRUE
+
+2. To your makefile add the following lines:
+ include $(GFXLIB)/drivers/touchscreen/XPT2046/touchscreen_lld.mk
+
diff --git a/drivers/touchscreen/XPT2046/touchscreen_lld.c b/drivers/touchscreen/XPT2046/touchscreen_lld.c
new file mode 100644
index 00000000..90bf0032
--- /dev/null
+++ b/drivers/touchscreen/XPT2046/touchscreen_lld.c
@@ -0,0 +1,241 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file drivers/touchscreen/XPT2046/touchscreen_lld.c
+ * @brief Touchscreen Driver subsystem low level driver source.
+ *
+ * @addtogroup TOUCHSCREEN
+ * @{
+ */
+
+#include "ch.h"
+#include "hal.h"
+#include "touchscreen.h"
+
+#if GFX_USE_TOUCHSCREEN /*|| defined(__DOXYGEN__)*/
+
+/*===========================================================================*/
+/* Driver local definitions. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver exported variables. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver local variables. */
+/*===========================================================================*/
+#if !defined(__DOXYGEN__)
+ /* Local copy of the current touchpad driver */
+ static const TouchscreenDriver *tsDriver;
+
+ static uint16_t sampleBuf[7];
+#endif
+
+/*===========================================================================*/
+/* Driver local functions. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver interrupt handlers. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver exported functions. */
+/*===========================================================================*/
+
+/* ---- Required Routines ---- */
+
+/**
+ * @brief Low level Touchscreen driver initialization.
+ *
+ * @param[in] ts The touchscreen driver struct
+ *
+ * @notapi
+ */
+void ts_lld_init(const TouchscreenDriver *ts) {
+ tsDriver = ts;
+
+ if(tsDriver->direct_init)
+ spiStart(tsDriver->spip, tsDriver->spicfg);
+}
+
+
+/**
+ * @brief Reads a conversion from the touchscreen
+ *
+ * @param[in] cmd The command bits to send to the touchscreen
+ *
+ * @return The read value 12-bit right-justified
+ *
+ * @note This function only reads data, it is assumed that the pins are
+ * configured properly and the bus has been acquired beforehand
+ *
+ * @notapi
+ */
+uint16_t ts_lld_read_value(uint8_t cmd) {
+ static uint8_t txbuf[3] = {0};
+ static uint8_t rxbuf[3] = {0};
+ uint16_t ret;
+
+ txbuf[0] = cmd;
+
+ spiExchange(tsDriver->spip, 3, txbuf, rxbuf);
+
+ ret = (rxbuf[1] << 5) | (rxbuf[2] >> 3);
+
+ return ret;
+}
+
+/**
+ * @brief 7-point median filtering code for touchscreen samples
+ *
+ * @note This is an internally used routine only.
+ *
+ * @notapi
+ */
+static void ts_lld_filter(void) {
+ uint16_t temp;
+ int i,j;
+
+ for(i = 0; i < 4; i++) {
+ for(j = i; j < 7; j++) {
+ if(sampleBuf[i] > sampleBuf[j]) {
+ /* Swap the values */
+ temp = sampleBuf[i];
+ sampleBuf[i] = sampleBuf[j];
+ sampleBuf[j] = temp;
+ }
+ }
+ }
+}
+
+/**
+ * @brief Reads out the X direction.
+ *
+ * @note The samples are median filtered for greater noise reduction
+ *
+ * @notapi
+ */
+uint16_t ts_lld_read_x(void) {
+ int i;
+
+#if defined(SPI_USE_MUTUAL_EXCLUSION)
+ spiAcquireBus(tsDriver->spip);
+#endif
+
+ TOUCHSCREEN_SPI_PROLOGUE();
+ palClearPad(tsDriver->spicfg->ssport, tsDriver->spicfg->sspad);
+
+ /* Discard the first conversion - very noisy and keep the ADC on hereafter
+ * till we are done with the sampling. Note that PENIRQ is disabled.
+ */
+ ts_lld_read_value(0xD1);
+
+ for(i = 0; i < 7; i++) {
+ sampleBuf[i] = ts_lld_read_value(0xD1);
+ }
+
+ /* Switch on PENIRQ once again - perform a dummy read */
+ ts_lld_read_value(0xD0);
+
+ palSetPad(tsDriver->spicfg->ssport, tsDriver->spicfg->sspad);
+ TOUCHSCREEN_SPI_EPILOGUE();
+
+#if defined(SPI_USE_MUTUAL_EXCLUSION)
+ spiReleaseBus(tsDriver->spip);
+#endif
+
+ /* Find the median - use selection sort */
+ ts_lld_filter();
+
+ return sampleBuf[3];
+}
+
+/*
+ * @brief Reads out the Y direction.
+ *
+ * @notapi
+ */
+uint16_t ts_lld_read_y(void) {
+ int i;
+
+#if defined(SPI_USE_MUTUAL_EXCLUSION)
+ spiAcquireBus(tsDriver->spip);
+#endif
+
+ TOUCHSCREEN_SPI_PROLOGUE();
+ palClearPad(tsDriver->spicfg->ssport, tsDriver->spicfg->sspad);
+
+ /* Discard the first conversion - very noisy and keep the ADC on hereafter
+ * till we are done with the sampling. Note that PENIRQ is disabled.
+ */
+ ts_lld_read_value(0x91);
+
+ for(i = 0; i < 7; i++) {
+ sampleBuf[i] = ts_lld_read_value(0x91);
+ }
+
+ /* Switch on PENIRQ once again - perform a dummy read */
+ ts_lld_read_value(0x90);
+
+ palSetPad(tsDriver->spicfg->ssport, tsDriver->spicfg->sspad);
+ TOUCHSCREEN_SPI_EPILOGUE();
+
+#ifdef SPI_USE_MUTUAL_EXCLUSION
+ spiReleaseBus(tsDriver->spip);
+#endif
+
+ /* Find the median - use selection sort */
+ ts_lld_filter();
+
+ return sampleBuf[3];
+}
+
+/* ---- Optional Routines ---- */
+#if TOUCHSCREEN_HAS_IRQ || defined(__DOXYGEN__)
+ /*
+ * @brief for checking if touchscreen is pressed or not.
+ *
+ * @return 1 if pressed / 0 if not pressed
+ *
+ * @notapi
+ */
+ uint8_t ts_lld_irq(void) {
+ return (!palReadPad(tsDriver->tsIRQPort, tsDriver->tsIRQPin));
+ }
+#endif
+
+#if TOUCHSCREEN_HAS_PRESSURE || defined(__DOXYGEN__)
+ /*
+ * @brief Reads out the Z direction / pressure.
+ *
+ * @notapi
+ */
+ uint16_t ts_lld_read_z(void) {
+ /* ToDo */
+ return 42;
+ }
+#endif
+
+#endif /* GFX_USE_TOUCHSCREEN */
+/** @} */
+
diff --git a/drivers/touchscreen/XPT2046/touchscreen_lld.mk b/drivers/touchscreen/XPT2046/touchscreen_lld.mk
new file mode 100644
index 00000000..39d5caf9
--- /dev/null
+++ b/drivers/touchscreen/XPT2046/touchscreen_lld.mk
@@ -0,0 +1,6 @@
+# List the required driver.
+GFXSRC += $(GFXLIB)/drivers/touchscreen/XPT2046/touchscreen_lld.c
+
+# Required include directories
+GFXINC += $(GFXLIB)/drivers/touchscreen/XPT2046
+
diff --git a/drivers/touchscreen/XPT2046/touchscreen_lld_config.h b/drivers/touchscreen/XPT2046/touchscreen_lld_config.h
new file mode 100644
index 00000000..1bb8718e
--- /dev/null
+++ b/drivers/touchscreen/XPT2046/touchscreen_lld_config.h
@@ -0,0 +1,45 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file drivers/touchscreen/XPT2046/touchscreen_lld_config.h
+ * @brief Touchscreen Driver subsystem low level driver.
+ *
+ * @addtogroup TOUCHSCREEN
+ * @{
+ */
+
+#ifndef TOUCHSCREEN_LLD_CONFIG_H
+#define TOUCHSCREEN_LLD_CONFIG_H
+
+#if GFX_USE_TOUCHSCREEN /*|| defined(__DOXYGEN__)*/
+
+/*===========================================================================*/
+/* Driver hardware support. */
+/*===========================================================================*/
+
+#define TOUCHSCREEN_HAS_IRQ TRUE
+#define TOUCHSCREEN_HAS_PRESSURE TRUE
+
+#endif /* GFX_USE_TOUCHSCREEN */
+
+#endif /* TOUCHSCREEN_LLD_CONFIG_H */
+/** @} */
+