aboutsummaryrefslogtreecommitdiffstats
path: root/drivers
diff options
context:
space:
mode:
authorJoel Bodenmann <joel@unormal.org>2013-03-08 00:56:59 +0100
committerJoel Bodenmann <joel@unormal.org>2013-03-08 00:56:59 +0100
commit0400ba0e2d0e20ecf2dcf1081fbb30cee2140794 (patch)
tree17ddca026a4dbc0cd6e3c1bc53227e7d96b9ea5b /drivers
parent93d506ef22faa162007607ff3ea614c981dc1654 (diff)
downloaduGFX-0400ba0e2d0e20ecf2dcf1081fbb30cee2140794.tar.gz
uGFX-0400ba0e2d0e20ecf2dcf1081fbb30cee2140794.tar.bz2
uGFX-0400ba0e2d0e20ecf2dcf1081fbb30cee2140794.zip
added basic STMPE811 skeleton
Diffstat (limited to 'drivers')
-rw-r--r--drivers/ginput/touch/STMPE811/ginput_lld.mk5
-rw-r--r--drivers/ginput/touch/STMPE811/ginput_lld_mouse.c138
-rw-r--r--drivers/ginput/touch/STMPE811/ginput_lld_mouse_board_embest_lcd.h92
-rw-r--r--drivers/ginput/touch/STMPE811/ginput_lld_mouse_board_example.h88
-rw-r--r--drivers/ginput/touch/STMPE811/ginput_lld_mouse_config.h45
-rw-r--r--drivers/ginput/touch/STMPE811/readme.txt9
6 files changed, 377 insertions, 0 deletions
diff --git a/drivers/ginput/touch/STMPE811/ginput_lld.mk b/drivers/ginput/touch/STMPE811/ginput_lld.mk
new file mode 100644
index 00000000..f6d77f1c
--- /dev/null
+++ b/drivers/ginput/touch/STMPE811/ginput_lld.mk
@@ -0,0 +1,5 @@
+# List the required driver.
+GFXSRC += $(GFXLIB)/drivers/ginput/touch/STMPE811/ginput_lld_mouse.c
+
+# Required include directories
+GFXINC += $(GFXLIB)/drivers/ginput/touch/STMPE811
diff --git a/drivers/ginput/touch/STMPE811/ginput_lld_mouse.c b/drivers/ginput/touch/STMPE811/ginput_lld_mouse.c
new file mode 100644
index 00000000..b83f0cf4
--- /dev/null
+++ b/drivers/ginput/touch/STMPE811/ginput_lld_mouse.c
@@ -0,0 +1,138 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012, 2013
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file drivers/ginput/touch/STMPE811/ginput_lld_mouse.c
+ * @brief GINPUT Touch low level driver source for the STMPE811.
+ *
+ * @defgroup Mouse Mouse
+ * @ingroup GINPUT
+ * @{
+ */
+
+#include "ch.h"
+#include "hal.h"
+#include "gfx.h"
+
+#if (GFX_USE_GINPUT && GINPUT_NEED_MOUSE) /*|| defined(__DOXYGEN__)*/
+
+#include "ginput/lld/mouse.h"
+
+//#include "ginput_lld_mouse_board_example.h"
+#include "ginput_lld_mouse_board_embest_lcd.h"
+
+static uint16_t sampleBuf[7];
+static coord_t lastx, lasty;
+
+/**
+ * @brief 7-point median filtering code for touch samples
+ *
+ * @note This is an internally used routine only.
+ *
+ * @notapi
+ */
+static void filter(void) {
+ uint16_t temp;
+ int i,j;
+
+ for(i = 0; i < 4; i++) {
+ for(j = i; j < 7; j++) {
+ if(sampleBuf[i] > sampleBuf[j]) {
+ /* Swap the values */
+ temp = sampleBuf[i];
+ sampleBuf[i] = sampleBuf[j];
+ sampleBuf[j] = temp;
+ }
+ }
+ }
+}
+
+/**
+ * @brief Initialise the mouse/touch.
+ *
+ * @notapi
+ */
+void ginput_lld_mouse_init(void) {
+ init_board();
+}
+
+/**
+ * @brief Read the mouse/touch position.
+ *
+ * @param[in] pt A pointer to the structure to fill
+ *
+ * @note For drivers that don't support returning a position
+ * when the touch is up (most touch devices), it should
+ * return the previous position with the new Z value.
+ * The z value is the pressure for those touch devices
+ * that support it (-100 to 100 where > 0 is touched)
+ * or, 0 or 100 for those drivers that don't.
+ *
+ * @notapi
+ */
+void ginput_lld_mouse_get_reading(MouseReading *pt) {
+ uint16_t i;
+
+ // If touch-off return the previous results
+ if (!getpin_pressed()) {
+ pt->x = lastx;
+ pt->y = lasty;
+ pt->z = 0;
+ pt->buttons = 0;
+ return;
+ }
+
+ // Read the port to get the touch settings
+ aquire_bus();
+
+ /* Get the X value
+ * Discard the first conversion - very noisy and keep the ADC on hereafter
+ * till we are done with the sampling. Note that PENIRQ is disabled while reading.
+ * Finally switch on PENIRQ once again - perform a dummy read.
+ * Once we have the readings, find the medium using our filter function
+ */
+ read_value(0xD1);
+ for(i = 0; i < 7; i++)
+ sampleBuf[i] = read_value(0xD1);
+ read_value(0xD0);
+ filter();
+ lastx = (coord_t)sampleBuf[3];
+
+ /* Get the Y value using the same process as above */
+ read_value(0x91);
+ for(i = 0; i < 7; i++)
+ sampleBuf[i] = read_value(0x91);
+ read_value(0x90);
+ filter();
+ lasty = (coord_t)sampleBuf[3];
+
+ // Release the bus
+ release_bus();
+
+ // Return the results
+ pt->x = lastx;
+ pt->y = lasty;
+ pt->z = 100;
+ pt->buttons = GINPUT_TOUCH_PRESSED;
+}
+
+#endif /* GFX_USE_GINPUT && GINPUT_NEED_MOUSE */
+/** @} */
+
diff --git a/drivers/ginput/touch/STMPE811/ginput_lld_mouse_board_embest_lcd.h b/drivers/ginput/touch/STMPE811/ginput_lld_mouse_board_embest_lcd.h
new file mode 100644
index 00000000..8dd28a90
--- /dev/null
+++ b/drivers/ginput/touch/STMPE811/ginput_lld_mouse_board_embest_lcd.h
@@ -0,0 +1,92 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012, 2013
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file drivers/ginput/touch/STMPE811/ginput_lld_mouse_board_example.h
+ * @brief GINPUT Touch low level driver source for the STMPE811 on the example board.
+ *
+ * @defgroup Mouse Mouse
+ * @ingroup GINPUT
+ * @{
+ */
+
+#ifndef _GINPUT_LLD_MOUSE_BOARD_H
+#define _GINPUT_LLD_MOUSE_BOARD_H
+
+static const I2CConfig i2ccfg2 = {
+ OPMODE_I2C,
+ 400000,
+ FAST_DUTY_CYCLE_2,
+};
+
+/**
+ * @brief Initialise the board for the touch.
+ *
+ * @notapi
+ */
+static inline void init_board(void) {
+ palSetPadMode(GPIOC, 13, PAL_MODE_INPUT);
+
+ i2cStart(&I2CD2, &i2ccfg2);
+}
+
+/**
+ * @brief Check whether the surface is currently touched
+ * @return TRUE if the surface is currently touched
+ *
+ * @notapi
+ */
+static inline bool_t getpin_pressed(void) {
+ return (!(palReadPad(GPIOC, 13)));
+}
+
+/**
+ * @brief Aquire the bus ready for readings
+ *
+ * @notapi
+ */
+static inline void aquire_bus(void) {
+ i2cAcquireBus(&I2CD2);
+}
+
+/**
+ * @brief Release the bus after readings
+ *
+ * @notapi
+ */
+static inline void release_bus(void) {
+ i2cReleaseBus(&I2CD2);
+}
+
+/**
+ * @brief Read a value from touch controller
+ * @return The value read from the controller
+ *
+ * params[in] port The controller port to read.
+ *
+ * @notapi
+ */
+static inline uint16_t read_value(uint16_t port) {
+ #error "STMPE811: Implement this driver first!"
+}
+
+#endif /* _GINPUT_LLD_MOUSE_BOARD_H */
+/** @} */
+
diff --git a/drivers/ginput/touch/STMPE811/ginput_lld_mouse_board_example.h b/drivers/ginput/touch/STMPE811/ginput_lld_mouse_board_example.h
new file mode 100644
index 00000000..fbedcb60
--- /dev/null
+++ b/drivers/ginput/touch/STMPE811/ginput_lld_mouse_board_example.h
@@ -0,0 +1,88 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012, 2013
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file drivers/ginput/touch/STMPE811/ginput_lld_mouse_board_example.h
+ * @brief GINPUT Touch low level driver source for the STMPE811 on the example board.
+ *
+ * @defgroup Mouse Mouse
+ * @ingroup GINPUT
+ * @{
+ */
+
+#ifndef _GINPUT_LLD_MOUSE_BOARD_H
+#define _GINPUT_LLD_MOUSE_BOARD_H
+
+/**
+ * @brief Initialise the board for the touch.
+ *
+ * @notapi
+ */
+static inline void init_board(void) {
+ /* Code here */
+ #error "ginputSTMPE811: You must supply a definition for init_board for your board"
+}
+
+/**
+ * @brief Check whether the surface is currently touched
+ * @return TRUE if the surface is currently touched
+ *
+ * @notapi
+ */
+static inline bool_t getpin_pressed(void) {
+ /* Code here */
+ #error "ginputSTMPE811: You must supply a definition for getpin_pressed for your board"
+}
+
+/**
+ * @brief Aquire the bus ready for readings
+ *
+ * @notapi
+ */
+static inline void aquire_bus(void) {
+ /* Code here */
+ #error "ginputSTMPE811: You must supply a definition for aquire_bus for your board"
+}
+
+/**
+ * @brief Release the bus after readings
+ *
+ * @notapi
+ */
+static inline void release_bus(void) {
+ /* Code here */
+ #error "ginputSTMPE811: You must supply a definition for release_bus for your board"
+}
+
+/**
+ * @brief Read a value from touch controller
+ * @return The value read from the controller
+ *
+ * params[in] port The controller port to read.
+ *
+ * @notapi
+ */
+static inline uint16_t read_value(uint16_t port) {
+ /* Code here */
+ #error "ginputSTMPE811: You must supply a definition for read_value for your board"
+}
+
+#endif /* _GINPUT_LLD_MOUSE_BOARD_H */
+/** @} */
diff --git a/drivers/ginput/touch/STMPE811/ginput_lld_mouse_config.h b/drivers/ginput/touch/STMPE811/ginput_lld_mouse_config.h
new file mode 100644
index 00000000..76224198
--- /dev/null
+++ b/drivers/ginput/touch/STMPE811/ginput_lld_mouse_config.h
@@ -0,0 +1,45 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012, 2013
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+/**
+ * @file drivers/ginput/touch/STMPE811/ginput_lld_mouse_config.h
+ * @brief GINPUT LLD header file for mouse/touch driver.
+ *
+ * @defgroup Mouse Mouse
+ * @ingroup GINPUT
+ *
+ * @{
+ */
+
+#ifndef _LLD_GINPUT_MOUSE_CONFIG_H
+#define _LLD_GINPUT_MOUSE_CONFIG_H
+
+#define GINPUT_MOUSE_EVENT_TYPE GEVENT_TOUCH
+#define GINPUT_MOUSE_NEED_CALIBRATION TRUE
+#define GINPUT_MOUSE_LLD_CALIBRATION_LOADSAVE FALSE
+#define GINPUT_MOUSE_MAX_CALIBRATION_ERROR 5
+#define GINPUT_MOUSE_READ_CYCLES 4
+#define GINPUT_MOUSE_POLL_PERIOD 25
+#define GINPUT_MOUSE_MAX_CLICK_JITTER 10
+#define GINPUT_MOUSE_MAX_MOVE_JITTER 2
+#define GINPUT_MOUSE_CLICK_TIME 500
+
+#endif /* _LLD_GINPUT_MOUSE_CONFIG_H */
+/** @} */
+
diff --git a/drivers/ginput/touch/STMPE811/readme.txt b/drivers/ginput/touch/STMPE811/readme.txt
new file mode 100644
index 00000000..1d7a8b4f
--- /dev/null
+++ b/drivers/ginput/touch/STMPE811/readme.txt
@@ -0,0 +1,9 @@
+To use this driver:
+
+1. Add in your halconf.h:
+ a) #define GFX_USE_GINPUT TRUE
+ b) #define GINPUT_NEED_MOUSE TRUE
+
+2. To your makefile add the following lines:
+ include $(GFXLIB)/drivers/ginput/touch/STMPE811/ginput_lld.mk
+