aboutsummaryrefslogtreecommitdiffstats
path: root/drivers
diff options
context:
space:
mode:
authorAbhishek Kumar <abhishek@kumar>2013-04-30 17:47:25 +0700
committerAbhishek Kumar <abhishek@kumar>2013-04-30 17:47:25 +0700
commit048a05790235acb338a35ffc7663cbcddc26457a (patch)
tree508966c32fbe34a6734b3255407b8bcb8fc78da8 /drivers
parentb2252bb7bede275461700db9c56b702a93a33982 (diff)
downloaduGFX-048a05790235acb338a35ffc7663cbcddc26457a.tar.gz
uGFX-048a05790235acb338a35ffc7663cbcddc26457a.tar.bz2
uGFX-048a05790235acb338a35ffc7663cbcddc26457a.zip
Renamed HVGA_X81 to ILI9481
Diffstat (limited to 'drivers')
-rw-r--r--drivers/gdisp/HVGA_X81/gdisp_lld.mk5
-rw-r--r--drivers/gdisp/ILI9481/gdisp_lld.c (renamed from drivers/gdisp/HVGA_X81/gdisp_lld.c)2
-rw-r--r--drivers/gdisp/ILI9481/gdisp_lld.mk5
-rw-r--r--drivers/gdisp/ILI9481/gdisp_lld_board_example.h (renamed from drivers/gdisp/HVGA_X81/gdisp_lld_board_example.h)18
-rw-r--r--drivers/gdisp/ILI9481/gdisp_lld_board_example_fsmc.h (renamed from drivers/gdisp/HVGA_X81/gdisp_lld_board_example_fsmc.h)2
-rw-r--r--drivers/gdisp/ILI9481/gdisp_lld_board_firebullstm32f103.h (renamed from drivers/gdisp/HVGA_X81/gdisp_lld_board_firebullstm32f103.h)2
-rw-r--r--drivers/gdisp/ILI9481/gdisp_lld_config.h (renamed from drivers/gdisp/HVGA_X81/gdisp_lld_config.h)4
-rw-r--r--drivers/gdisp/ILI9481/readme.txt (renamed from drivers/gdisp/HVGA_X81/readme.txt)2
8 files changed, 20 insertions, 20 deletions
diff --git a/drivers/gdisp/HVGA_X81/gdisp_lld.mk b/drivers/gdisp/HVGA_X81/gdisp_lld.mk
deleted file mode 100644
index a097e0c5..00000000
--- a/drivers/gdisp/HVGA_X81/gdisp_lld.mk
+++ /dev/null
@@ -1,5 +0,0 @@
-# List the required driver.
-GFXSRC += $(GFXLIB)/drivers/gdisp/HVGA_X81/gdisp_lld.c
-
-# Required include directories
-GFXINC += $(GFXLIB)/drivers/gdisp/HVGA_X81
diff --git a/drivers/gdisp/HVGA_X81/gdisp_lld.c b/drivers/gdisp/ILI9481/gdisp_lld.c
index e0cedad1..2ea8c6e7 100644
--- a/drivers/gdisp/HVGA_X81/gdisp_lld.c
+++ b/drivers/gdisp/ILI9481/gdisp_lld.c
@@ -19,7 +19,7 @@
*/
/**
- * @file drivers/gdisp/HVGA_X81/gdisp_lld.c
+ * @file drivers/gdisp/ILI9481/gdisp_lld.c
* @brief GDISP Graphics Driver subsystem low level driver source for
* the ILI9481 and compatible HVGA display
*
diff --git a/drivers/gdisp/ILI9481/gdisp_lld.mk b/drivers/gdisp/ILI9481/gdisp_lld.mk
new file mode 100644
index 00000000..b0b3f533
--- /dev/null
+++ b/drivers/gdisp/ILI9481/gdisp_lld.mk
@@ -0,0 +1,5 @@
+# List the required driver.
+GFXSRC += $(GFXLIB)/drivers/gdisp/ILI9481/gdisp_lld.c
+
+# Required include directories
+GFXINC += $(GFXLIB)/drivers/gdisp/ILI9481
diff --git a/drivers/gdisp/HVGA_X81/gdisp_lld_board_example.h b/drivers/gdisp/ILI9481/gdisp_lld_board_example.h
index 2c81c906..de459641 100644
--- a/drivers/gdisp/HVGA_X81/gdisp_lld_board_example.h
+++ b/drivers/gdisp/ILI9481/gdisp_lld_board_example.h
@@ -19,7 +19,7 @@
*/
/**
- * @file drivers/gdisp/HVGA_X81/gdisp_lld_board_example.h
+ * @file drivers/gdisp/ILI9481/gdisp_lld_board_example.h
* @brief GDISP Graphics Driver subsystem low level driver source for
* the ILI9481 and compatible HVGA display
*
@@ -37,7 +37,7 @@
*/
static inline void init_board(void) {
/* Code here */
-#error "HVGA_X81: You must supply a definition for init_board for your board"
+#error "ILI9481: You must supply a definition for init_board for your board"
}
/**
@@ -49,7 +49,7 @@ static inline void init_board(void) {
*/
static inline void setpin_reset(bool_t state) {
/* Code here */
-#error "HVGA_X81: You must supply a definition for setpin_reset for your board"
+#error "ILI9481: You must supply a definition for setpin_reset for your board"
}
/**
@@ -61,7 +61,7 @@ static inline void setpin_reset(bool_t state) {
*/
static inline void set_backlight(uint8_t percent) {
/* Code here */
-#error "HVGA_X81: You must supply a definition for set_backlight for your board"
+#error "ILI9481: You must supply a definition for set_backlight for your board"
}
/**
@@ -70,7 +70,7 @@ static inline void set_backlight(uint8_t percent) {
* @notapi
*/
static inline void acquire_bus(void) {
-#error "HVGA_X81: You must supply a definition for acquire_bus for your board"
+#error "ILI9481: You must supply a definition for acquire_bus for your board"
}
/**
@@ -79,7 +79,7 @@ static inline void acquire_bus(void) {
* @notapi
*/
static inline void release_bus(void) {
-#error "HVGA_X81: You must supply a definition for release_bus for your board"
+#error "ILI9481: You must supply a definition for release_bus for your board"
}
/**
@@ -91,7 +91,7 @@ static inline void release_bus(void) {
*/
static inline void write_index(uint16_t index) {
/* Code here */
-#error "HVGA_X81: You must supply a definition for write_index for your board"
+#error "ILI9481: You must supply a definition for write_index for your board"
}
/**
@@ -103,7 +103,7 @@ static inline void write_index(uint16_t index) {
*/
static inline void write_data(uint16_t data) {
/* Code here */
-#error "HVGA_X81: You must supply a definition for write_data for your board"
+#error "ILI9481: You must supply a definition for write_data for your board"
}
#if GDISP_HARDWARE_READPIXEL || GDISP_HARDWARE_SCROLL || defined(__DOXYGEN__)
@@ -118,7 +118,7 @@ static inline void write_data(uint16_t data) {
*/
static inline uint16_t read_data(void) {
/* Code here */
-#error "HVGA_X81: You must supply a definition for read_data for your board"
+#error "ILI9481: You must supply a definition for read_data for your board"
}
#endif
diff --git a/drivers/gdisp/HVGA_X81/gdisp_lld_board_example_fsmc.h b/drivers/gdisp/ILI9481/gdisp_lld_board_example_fsmc.h
index 8367b53c..3fc3f632 100644
--- a/drivers/gdisp/HVGA_X81/gdisp_lld_board_example_fsmc.h
+++ b/drivers/gdisp/ILI9481/gdisp_lld_board_example_fsmc.h
@@ -19,7 +19,7 @@
*/
/**
- * @file drivers/gdisp/HVGA_X81/gdisp_lld_board_example_fsmc.h
+ * @file drivers/gdisp/ILI9481/gdisp_lld_board_example_fsmc.h
* @brief GDISP Graphics Driver subsystem low level driver source for
* the ILI9481 and compatible HVGA display
*
diff --git a/drivers/gdisp/HVGA_X81/gdisp_lld_board_firebullstm32f103.h b/drivers/gdisp/ILI9481/gdisp_lld_board_firebullstm32f103.h
index 176e8452..ce7af96f 100644
--- a/drivers/gdisp/HVGA_X81/gdisp_lld_board_firebullstm32f103.h
+++ b/drivers/gdisp/ILI9481/gdisp_lld_board_firebullstm32f103.h
@@ -19,7 +19,7 @@
*/
/**
- * @file drivers/gdisp/HVGA_X81/gdisp_lld_board_firebullstm32f103.h
+ * @file drivers/gdisp/ILI9481/gdisp_lld_board_firebullstm32f103.h
* @brief GDISP Graphics Driver subsystem low level driver source for
* the ILI9481 and compatible HVGA display
*
diff --git a/drivers/gdisp/HVGA_X81/gdisp_lld_config.h b/drivers/gdisp/ILI9481/gdisp_lld_config.h
index a9dd8659..c1fc7a2d 100644
--- a/drivers/gdisp/HVGA_X81/gdisp_lld_config.h
+++ b/drivers/gdisp/ILI9481/gdisp_lld_config.h
@@ -19,7 +19,7 @@
*/
/**
- * @file drivers/gdisp/SSD1289/gdisp_lld_config.h
+ * @file drivers/gdisp/ILI9481/gdisp_lld_config.h
* @brief GDISP Graphics Driver subsystem low level driver source for
* the ILI9481 and compatible HVGA display
*
@@ -36,7 +36,7 @@
/* Driver hardware support. */
/*===========================================================================*/
-#define GDISP_DRIVER_NAME "HVGA_X81"
+#define GDISP_DRIVER_NAME "ILI9481"
#define GDISP_HARDWARE_CLEARS TRUE
#define GDISP_HARDWARE_FILLS TRUE
diff --git a/drivers/gdisp/HVGA_X81/readme.txt b/drivers/gdisp/ILI9481/readme.txt
index b4236b88..dc66e27b 100644
--- a/drivers/gdisp/HVGA_X81/readme.txt
+++ b/drivers/gdisp/ILI9481/readme.txt
@@ -12,4 +12,4 @@ To use this driver:
BOARD_FIREBULL_STM32_F103 - GPIO interface: requires GDISP_CMD_PORT and GDISP_DATA_PORT to be defined
2. To your makefile add the following lines:
- include $(GFXLIB)/drivers/gdisp/HVGA_X81/gdisp_lld.mk
+ include $(GFXLIB)/drivers/gdisp/ILI9481/gdisp_lld.mk