aboutsummaryrefslogtreecommitdiffstats
path: root/drivers
diff options
context:
space:
mode:
authorJoel Bodenmann <joel@unormal.org>2013-03-29 19:26:56 +0100
committerJoel Bodenmann <joel@unormal.org>2013-03-29 19:26:56 +0100
commit6ed641c91d1f94137bbb85074e66cc3214558e75 (patch)
tree2c4e98d0914efbd09eb6829de4d3cbd6ee9a1d44 /drivers
parent4440c2c8874c7c94f05b3a04fea52aaa15240721 (diff)
downloaduGFX-6ed641c91d1f94137bbb85074e66cc3214558e75.tar.gz
uGFX-6ed641c91d1f94137bbb85074e66cc3214558e75.tar.bz2
uGFX-6ed641c91d1f94137bbb85074e66cc3214558e75.zip
STMPE811 cleanup & readme
Diffstat (limited to 'drivers')
-rw-r--r--drivers/ginput/touch/STMPE811/ginput_lld_mouse_config.h6
-rw-r--r--drivers/ginput/touch/STMPE811/readme.txt29
2 files changed, 24 insertions, 11 deletions
diff --git a/drivers/ginput/touch/STMPE811/ginput_lld_mouse_config.h b/drivers/ginput/touch/STMPE811/ginput_lld_mouse_config.h
index ca1612b6..be19c5e0 100644
--- a/drivers/ginput/touch/STMPE811/ginput_lld_mouse_config.h
+++ b/drivers/ginput/touch/STMPE811/ginput_lld_mouse_config.h
@@ -39,8 +39,10 @@
#define GINPUT_MOUSE_MAX_CLICK_JITTER 10
#define GINPUT_MOUSE_MAX_MOVE_JITTER 2
#define GINPUT_MOUSE_CLICK_TIME 500
-#define STMP811_SLOWER_RESPONSE FALSE
-#define STMP811_NO_GPIO_IRQPIN FALSE
+
+/* default values - over write these in your boad files */
+#define STMP811_SLOWER_RESPONSE FALSE
+#define STMP811_NO_GPIO_IRQPIN FALSE
#endif /* _LLD_GINPUT_MOUSE_CONFIG_H */
/** @} */
diff --git a/drivers/ginput/touch/STMPE811/readme.txt b/drivers/ginput/touch/STMPE811/readme.txt
index 1d7a8b4f..065840d8 100644
--- a/drivers/ginput/touch/STMPE811/readme.txt
+++ b/drivers/ginput/touch/STMPE811/readme.txt
@@ -1,9 +1,20 @@
-To use this driver:
-
-1. Add in your halconf.h:
- a) #define GFX_USE_GINPUT TRUE
- b) #define GINPUT_NEED_MOUSE TRUE
-
-2. To your makefile add the following lines:
- include $(GFXLIB)/drivers/ginput/touch/STMPE811/ginput_lld.mk
-
+The STMPE811 driver comes with two different #defines to perfectly fit
+your application:
+
+
+STMPE811_NO_GPIO_IRQPIN
+This Macro is meant to be set in your board file. When you set this macro to
+TRUE, the GINPUT module will not use the IRQ lane which might be connected
+to a GPIO pin to recognize interrupts by the STMPE811 controller. This
+costs a few more I2C calls.
+When the interrupt IRQ pin is connected to a GPIO of your MCU, set this
+macro to FALSE.
+
+
+STMP811_SLOW_CPU
+If you have a slow CPU and you need to take care of your resources, you can
+set this macro TRUE. This will save some IRQs and therefore a few I2C calls.
+The disadvantage is a little higher response time.
+If you don't want to draw continious lines on your display, it's recommended
+to set this to TRUE anyways.
+