aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorAndrew Hannam <andrewh@inmarket.com.au>2013-01-16 20:41:18 -0800
committerAndrew Hannam <andrewh@inmarket.com.au>2013-01-16 20:41:18 -0800
commit7cce52d2f6b874895e3cdd557c4523eeeae942bf (patch)
tree5fe956e67796778248d32d7f4ddaa5dfb08b54c6 /include
parent8b5c073ea6f8491ce4176fb2996f74b3222f8188 (diff)
parent1a05e4a89ad7351e81da0e4dd152a7375a457884 (diff)
downloaduGFX-7cce52d2f6b874895e3cdd557c4523eeeae942bf.tar.gz
uGFX-7cce52d2f6b874895e3cdd557c4523eeeae942bf.tar.bz2
uGFX-7cce52d2f6b874895e3cdd557c4523eeeae942bf.zip
Merge pull request #14 from Tectu/master
Merge Tectu Changes
Diffstat (limited to 'include')
-rw-r--r--include/gdisp/lld/emulation.c26
-rw-r--r--include/gfx.h11
-rw-r--r--include/tdisp/lld/tdisp_lld.h56
-rw-r--r--include/tdisp/options.h87
-rw-r--r--include/tdisp/tdisp.h146
5 files changed, 315 insertions, 11 deletions
diff --git a/include/gdisp/lld/emulation.c b/include/gdisp/lld/emulation.c
index 04afd630..a514458c 100644
--- a/include/gdisp/lld/emulation.c
+++ b/include/gdisp/lld/emulation.c
@@ -18,20 +18,23 @@
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
-/*
- Emulation routines included into gdisp_lld.c
-*/
-
-/*
- Even though this is a software emulation of a low level driver
- most validation doesn't need to happen here as eventually
- we call a real low level driver routine and if validation is
- required - it will do it.
-*/
+/**
+ * @file include/gdisp/lld/emulation.c
+ * @brief GDISP emulation routines for stuff the driver dosen't support
+ *
+ * @addtogroup GDISP
+ *
+ * @details Even though this is a software emulation of a low level driver
+ * most validation doesn't need to happen here as eventually
+ * we call a real low level driver routine and if validation is
+ * required - it will do it.
+ *
+ * @{
+ */
#ifndef GDISP_EMULATION_C
#define GDISP_EMULATION_C
-#if GFX_USE_GDISP || defined(__DOXYGEN__)
+#if GFX_USE_GDISP /*|| defined(__DOXYGEN__) */
#ifndef GDISP_LLD_NO_STRUCT
static struct GDISPDriver {
@@ -765,4 +768,5 @@ void *GDISP_LLD(query)(unsigned what) {
#endif /* GFX_USE_GDISP */
#endif /* GDISP_EMULATION_C */
+/** @} */
diff --git a/include/gfx.h b/include/gfx.h
index 9dfe681a..c4c670f8 100644
--- a/include/gfx.h
+++ b/include/gfx.h
@@ -46,6 +46,15 @@
#define GFX_USE_GDISP FALSE
#endif
/**
+ * @brief GFX Text Display Basic API
+ * @details Defaults to FALSE
+ * @note Also add the specific hardware driver to your makefile.
+ * Eg. include $(GFXLIB)/drivers/tdisp/HD44780/tdisp_lld.mk
+ */
+ #ifndef GFX_USE_TDISP
+ #define GFX_USE_TDISP FALSE
+ #endif
+ /**
* @brief GFX Graphics Windowing API
* @details Defaults to FALSE
* @details Extends the GDISP API to add the concept of graphic windows.
@@ -94,6 +103,7 @@
#include "gdisp/options.h"
#include "gwin/options.h"
#include "ginput/options.h"
+#include "tdisp/options.h"
/**
* Inter-dependancy safety checks on the sub-systems.
@@ -109,6 +119,7 @@
#include "gdisp/gdisp.h"
#include "gwin/gwin.h"
#include "ginput/ginput.h"
+#include "tdisp/tdisp.h"
#endif /* _GFX_H */
/** @} */
diff --git a/include/tdisp/lld/tdisp_lld.h b/include/tdisp/lld/tdisp_lld.h
new file mode 100644
index 00000000..891b7b98
--- /dev/null
+++ b/include/tdisp/lld/tdisp_lld.h
@@ -0,0 +1,56 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file include/tdisp/lld/tdisp_lld.h
+ * @brief TDISP driver subsystem low level driver header.
+ *
+ * @addtogroup TDISP
+ * @{
+ */
+
+#ifndef _TDISP_LLD_H
+#define _TDISP_LLD_H
+
+#if GFX_USE_TDISP || defined(__DOXYGEN__)
+
+#include "tdisp_lld_config.h"
+
+#ifdef __cplusplus
+extern "C" {
+#endif
+
+extern void tdisp_lld_write_cmd(uint8_t data);
+extern void tdisp_lld_write_data(uint8_t data);
+extern bool_t tdisp_lld_init(void);
+extern void tdisp_lld_set_cursor(coord_t col, coord_t row);
+extern void tdisp_lld_create_char(uint8_t address, char *charmap);
+extern void tdisp_lld_clear(void);
+extern void tdisp_lld_home(void);
+
+#ifdef __cplusplus
+}
+#endif
+
+#endif /* GFX_USE_TDISP */
+
+#endif /* _TDISP_LLD_H */
+/** @} */
+
diff --git a/include/tdisp/options.h b/include/tdisp/options.h
new file mode 100644
index 00000000..69d24b64
--- /dev/null
+++ b/include/tdisp/options.h
@@ -0,0 +1,87 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file include/tdisp/options.h
+ * @brief TDISP sub-system options header file.
+ *
+ * @addtogroup TDISP
+ * @{
+ */
+
+#ifndef _TDISP_OPTIONS_H
+#define _TDISP_OPTIONS_H
+
+#if GFX_USE_TDISP
+/**
+ * @name TDISP configuration
+ * @{
+ */
+
+ /**
+ * @brief How many rows of characters the TDISP provides
+ */
+ #ifndef TDISP_ROWS
+ #define TDISP_ROWS 2
+ #endif
+
+ /**
+ * @brief How many columns of characters the TDISP provides
+ */
+ #ifndef TDISP_COLUMNS
+ #define TDISP_COLUMNS 16
+ #endif
+
+/** @} */
+
+/**
+ * @name TDISP interface configuration
+ * @note Only one of these interfaces can be selected at a time!
+ * @{
+ */
+ /**
+ * @brief Use the 4-bit paralle interface
+ */
+ #ifndef TDISP_NEED_4BIT_MODE
+ #define TDISP_NEED_4BIT_MODE FALSE
+ #endif
+
+ /**
+ * @brief Use the 8-bit parallel interface
+ */
+ #ifndef TDISP_NEED_8BIT_MODE
+ #define TDISP_NEED_8BIT_MODE FALSE
+ #endif
+
+ #if (!TDISP_NEED_4BIT_MODE && !TDISP_NEED_8BIT_MODE)
+ #error "Either TDISP_NEED_4BIT_MODE or TDISP_NEED_8BIT_MODE needs to be set to TRUE in your gfxconf.h!"
+ #endif
+
+ #if (TDISP_NEED_4BIT_MODE && TDISP_NEED_8BIT_MODE)
+ #error "Only TDISP_NEED_4BIT_MODE or TDISP_NEED_8BIT_MODE can be set to TRUE, not both at one!"
+ #endif
+
+/** @} */
+
+#endif /* GFX_USE_TDISP */
+
+#endif /* _TDISP_OPTIONS_H */
+/** @} */
+
diff --git a/include/tdisp/tdisp.h b/include/tdisp/tdisp.h
new file mode 100644
index 00000000..c9a8f842
--- /dev/null
+++ b/include/tdisp/tdisp.h
@@ -0,0 +1,146 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file include/tdisp/tdisp.h
+ * @brief TDISP Graphic Driver subsystem header file.
+ *
+ * @addtogroup TDISP
+ *
+ * @details The TDISP module provides high level abstraction to interface pixel oriented graphic displays.
+ * Due the TDISP module is completely encapsulated from the other modules, it's very fast and lightweight.
+ *
+ * @pre GFX_USE_TDISP must be set to TRUE in gfxconf.h
+ *
+ * @{
+ */
+
+#ifndef _TDISP_H
+#define _TDISP_H
+
+#include "gfx.h"
+
+#if GFX_USE_TDISP || defined(__DOXYGEN__)
+
+/* Include the low level driver information */
+#include "tdisp/lld/tdisp_lld.h"
+
+/**
+ * @name TDISP display attributes
+ * @{
+ */
+#define TDISP_ON 0x01
+#define TDISP_OFF 0x02
+#define TDISP_CURSOR_ON 0x03
+#define TDISP_CURSOR_OFF 0x04
+#define TDISP_CURSOR_BLINK_ON 0x05
+#define TDISP_CURSOR_BLINK_OFF 0x06
+/** @} */
+
+/**
+ * @brief TDISP driver initialisation
+ * @note This function is not implicitly invoked by @p halInit().
+ * It must be called manually.
+ *
+ * @return TRUE if success, FALSE otherwise
+ *
+ * @init
+ */
+bool_t tdispInit(void);
+
+/**
+ * @brief Control different display properties
+ * @note Multiple attributes can be passed using the OR operator.
+ * @note Example: tdispSetAttributes(TDISP_DISPLAY_ON | TDISP_CURSOR_BLINK)
+ *
+ * @param[in] attributes The attributes
+ */
+void tdispSetAttributes(uint8_t attributes);
+
+/**
+ * @brief Clears the display
+ */
+void tdispClear(void);
+
+/**
+ * @brief Sets the cursor to it's home position ( 0/0 )
+ */
+void tdispHome(void);
+
+/**
+ * @brief Set cursor to a certain position
+ *
+ * @param[in] col The column
+ * @param[in] row The row
+ */
+void tdispSetCursor(coord_t col, coord_t row);
+
+/**
+ * @brief Store a custom character in RAM
+ *
+ * @note This usually must be done after each power-up since most
+ * LCDs lose their RAM content.
+ *
+ * @param[in] address On which address to store the character (from 0 up to max)
+ * @param[in] charmap The character to be stored.
+ */
+void tdispCreateChar(uint8_t address, char *charmap);
+
+/**
+ * @brief Draws a single character at the current cursor position
+ *
+ * @param[in] c The character to be drawn
+ */
+void tdispDrawChar(char c);
+
+/**
+ * @brief Draws a string at the current cursor position
+ *
+ * @param[in] s The string to be drawn
+ */
+void tdispDrawString(char *s);
+
+/**
+ * @brief Draws a single character at a given position
+ * @note This function manipulates the cursor position and it will not be
+ * reset to it's original state
+ *
+ * @param[in] col The column
+ * @param[in] row The row
+ * @param[in] c The character to be drawn
+ */
+void tdispDrawCharLocation(coord_t col, coord_t row, char c);
+
+/**
+ * @brief Draws a string at a given position
+ * @note This function manipulates the cursor position and it will not be
+ * reset to it's original state
+ *
+ * @param[in] col The column
+ * @param[in] row The row
+ * @param[in] s The string to be drawn
+ */
+void tdispDrawStringLocation(coord_t col, coord_t row, char *s);
+
+#endif /* GFX_USE_TDISP */
+
+#endif /* _TDISP_H */
+/** @} */
+