aboutsummaryrefslogtreecommitdiffstats
path: root/readme1.txt
diff options
context:
space:
mode:
authorTectu <joel@unormal.org>2012-08-13 04:12:42 +0200
committerTectu <joel@unormal.org>2012-08-13 04:12:42 +0200
commite27d04d002a40f3b514eeeb60d374df6a8a1280c (patch)
tree7c20e6edd42cd4f20eda183a16ce66c5e8c7105e /readme1.txt
parent54229cbdaaf585b5adf9b085229a22c9824c112c (diff)
downloaduGFX-e27d04d002a40f3b514eeeb60d374df6a8a1280c.tar.gz
uGFX-e27d04d002a40f3b514eeeb60d374df6a8a1280c.tar.bz2
uGFX-e27d04d002a40f3b514eeeb60d374df6a8a1280c.zip
restructure
Diffstat (limited to 'readme1.txt')
-rw-r--r--readme1.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/readme1.txt b/readme1.txt
new file mode 100644
index 00000000..907c7eb4
--- /dev/null
+++ b/readme1.txt
@@ -0,0 +1,28 @@
+To include any of these functions/drivers in your project...
+
+ 1/ Specify the path to the LCDLIB. If none defined, default is $(CHIBIOS)/ext/lcd
+
+ 2/ In your project Makefile (amongst similiar lines but after the hal line) add the line...
+ include $(LCDLIB)/lcd.mk
+
+ 3/ In your project Makefile add the makefiles for any specific drivers you want e.g
+ include $(LCDLIB)/halext/drivers/touchpad/touchpadXPT2046/touchpad_lld.mk
+ include $(LCDLIB)/halext/drivers/gdispNokia6610/gdisp_lld.mk
+
+ 4/ In your project halconf.h turn on the support you want eg.
+ /**
+ * @brief Enables the Touchpad subsystem.
+ */
+ #if !defined(HAL_USE_TOUCHPAD) || defined(__DOXYGEN__)
+ #define HAL_USE_TOUCHPAD TRUE
+ #endif
+ /**
+ * @brief Enables the GDISP subsystem.
+ */
+ #if !defined(HAL_USE_GDISP) || defined(__DOXYGEN__)
+ #define HAL_USE_GDISP TRUE
+ /* Any driver specific defines required go here. The below line is an example. */
+ #define GDISP_NEED_MULTITHREAD TRUE
+ #endif
+ 5/ Do a make clean.
+