aboutsummaryrefslogtreecommitdiffstats
path: root/src/gos
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2015-01-21 17:26:24 +1000
committerinmarket <andrewh@inmarket.com.au>2015-01-21 17:26:24 +1000
commitfa8167b94d13e94a6cb953e7f549a89f155f77c6 (patch)
tree8c33f78c45ca72ac2653327607f1d7caed668c5e /src/gos
parent34939386d7390b0876973a1969f336b814313a22 (diff)
downloaduGFX-fa8167b94d13e94a6cb953e7f549a89f155f77c6.tar.gz
uGFX-fa8167b94d13e94a6cb953e7f549a89f155f77c6.tar.bz2
uGFX-fa8167b94d13e94a6cb953e7f549a89f155f77c6.zip
Big file rename to reduce problems with brain-dead IDE's that don't handle project file hierarchies well.
Naming is more consistent with the new scheme. May affect some third party drivers (header file renames).
Diffstat (limited to 'src/gos')
-rw-r--r--src/gos/gos.h (renamed from src/gos/sys_defs.h)2
-rw-r--r--src/gos/gos.mk (renamed from src/gos/sys_make.mk)0
-rw-r--r--src/gos/gos_options.h (renamed from src/gos/sys_options.h)2
-rw-r--r--src/gos/gos_rawrtos.c7
-rw-r--r--src/gos/gos_rules.h (renamed from src/gos/sys_rules.h)2
-rw-r--r--src/gos/gos_win32.c4
6 files changed, 10 insertions, 7 deletions
diff --git a/src/gos/sys_defs.h b/src/gos/gos.h
index 7e1348bb..f1def55a 100644
--- a/src/gos/sys_defs.h
+++ b/src/gos/gos.h
@@ -6,7 +6,7 @@
*/
/**
- * @file src/gos/sys_defs.h
+ * @file src/gos/gos.h
* @brief GOS - Operating System Support header file
*
* @addtogroup GOS
diff --git a/src/gos/sys_make.mk b/src/gos/gos.mk
index a7b3dec6..a7b3dec6 100644
--- a/src/gos/sys_make.mk
+++ b/src/gos/gos.mk
diff --git a/src/gos/sys_options.h b/src/gos/gos_options.h
index 45e398dd..611acfb7 100644
--- a/src/gos/sys_options.h
+++ b/src/gos/gos_options.h
@@ -6,7 +6,7 @@
*/
/**
- * @file src/gos/sys_options.h
+ * @file src/gos/gos_options.h
* @brief GOS - Operating System options header file.
*
* @addtogroup GOS
diff --git a/src/gos/gos_rawrtos.c b/src/gos/gos_rawrtos.c
index cd684208..c47c85bf 100644
--- a/src/gos/gos_rawrtos.c
+++ b/src/gos/gos_rawrtos.c
@@ -1,3 +1,10 @@
+/*
+ * This file is subject to the terms of the GFX License. If a copy of
+ * the license was not distributed with this file, you can obtain one at:
+ *
+ * http://ugfx.org/license.html
+ */
+
#include "gfx.h"
#if GFX_USE_OS_RAWRTOS
diff --git a/src/gos/sys_rules.h b/src/gos/gos_rules.h
index 6d6c7845..0a86f86e 100644
--- a/src/gos/sys_rules.h
+++ b/src/gos/gos_rules.h
@@ -6,7 +6,7 @@
*/
/**
- * @file src/gos/sys_rules.h
+ * @file src/gos/gos_rules.h
* @brief GOS safety rules header file.
*
* @addtogroup GOS
diff --git a/src/gos/gos_win32.c b/src/gos/gos_win32.c
index 0ae9e618..a7e0943b 100644
--- a/src/gos/gos_win32.c
+++ b/src/gos/gos_win32.c
@@ -5,10 +5,6 @@
* http://ugfx.org/license.html
*/
-/**
- * @file src/gos/gos_win32.c
- * @brief GOS Win32 Operating System support.
- */
#include "gfx.h"
#if GFX_USE_OS_WIN32