aboutsummaryrefslogtreecommitdiffstats
path: root/src/gwin
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2015-01-21 17:26:24 +1000
committerinmarket <andrewh@inmarket.com.au>2015-01-21 17:26:24 +1000
commitfa8167b94d13e94a6cb953e7f549a89f155f77c6 (patch)
tree8c33f78c45ca72ac2653327607f1d7caed668c5e /src/gwin
parent34939386d7390b0876973a1969f336b814313a22 (diff)
downloaduGFX-fa8167b94d13e94a6cb953e7f549a89f155f77c6.tar.gz
uGFX-fa8167b94d13e94a6cb953e7f549a89f155f77c6.tar.bz2
uGFX-fa8167b94d13e94a6cb953e7f549a89f155f77c6.zip
Big file rename to reduce problems with brain-dead IDE's that don't handle project file hierarchies well.
Naming is more consistent with the new scheme. May affect some third party drivers (header file renames).
Diffstat (limited to 'src/gwin')
-rw-r--r--src/gwin/gwin.c (renamed from src/gwin/gwin_gwin.c)0
-rw-r--r--src/gwin/gwin.h (renamed from src/gwin/sys_defs.h)2
-rw-r--r--src/gwin/gwin.mk (renamed from src/gwin/sys_make.mk)2
-rw-r--r--src/gwin/gwin_console.h2
-rw-r--r--src/gwin/gwin_container.h2
-rw-r--r--src/gwin/gwin_gl3d.h2
-rw-r--r--src/gwin/gwin_graph.h2
-rw-r--r--src/gwin/gwin_image.h2
-rw-r--r--src/gwin/gwin_options.h (renamed from src/gwin/sys_options.h)2
-rw-r--r--src/gwin/gwin_rules.h (renamed from src/gwin/sys_rules.h)2
-rw-r--r--src/gwin/gwin_widget.h2
11 files changed, 10 insertions, 10 deletions
diff --git a/src/gwin/gwin_gwin.c b/src/gwin/gwin.c
index eb51b89a..eb51b89a 100644
--- a/src/gwin/gwin_gwin.c
+++ b/src/gwin/gwin.c
diff --git a/src/gwin/sys_defs.h b/src/gwin/gwin.h
index afab138c..81bf38e5 100644
--- a/src/gwin/sys_defs.h
+++ b/src/gwin/gwin.h
@@ -6,7 +6,7 @@
*/
/**
- * @file src/gwin/sys_defs.h
+ * @file src/gwin/gwin.h
*
* @defgroup Window Window
* @ingroup Windows
diff --git a/src/gwin/sys_make.mk b/src/gwin/gwin.mk
index c619466e..23993346 100644
--- a/src/gwin/sys_make.mk
+++ b/src/gwin/gwin.mk
@@ -1,4 +1,4 @@
-GFXSRC += $(GFXLIB)/src/gwin/gwin_gwin.c \
+GFXSRC += $(GFXLIB)/src/gwin/gwin.c \
$(GFXLIB)/src/gwin/gwin_widget.c \
$(GFXLIB)/src/gwin/gwin_wm.c \
$(GFXLIB)/src/gwin/gwin_console.c \
diff --git a/src/gwin/gwin_console.h b/src/gwin/gwin_console.h
index 77e623eb..a21642aa 100644
--- a/src/gwin/gwin_console.h
+++ b/src/gwin/gwin_console.h
@@ -24,7 +24,7 @@
#ifndef _GWIN_CONSOLE_H
#define _GWIN_CONSOLE_H
-/* This file is included within "src/gwin/sys_defs.h" */
+/* This file is included within "src/gwin/gwin.h" */
// A console window. Supports wrapped text writing and a cursor.
typedef struct GConsoleObject {
diff --git a/src/gwin/gwin_container.h b/src/gwin/gwin_container.h
index 19562a7d..c40683db 100644
--- a/src/gwin/gwin_container.h
+++ b/src/gwin/gwin_container.h
@@ -21,7 +21,7 @@
#ifndef _GCONTAINER_H
#define _GCONTAINER_H
-/* This file is included within "src/gwin/sys_defs.h" */
+/* This file is included within "src/gwin/gwin.h" */
// Forward definition
struct GContainerObject;
diff --git a/src/gwin/gwin_gl3d.h b/src/gwin/gwin_gl3d.h
index 644f45bf..84ead5d9 100644
--- a/src/gwin/gwin_gl3d.h
+++ b/src/gwin/gwin_gl3d.h
@@ -22,7 +22,7 @@
#ifndef _GWIN_GL3D_H
#define _GWIN_GL3D_H
-/* This file is included within "src/gwin/sys_defs.h" */
+/* This file is included within "src/gwin/gwin.h" */
// A gl3d window
diff --git a/src/gwin/gwin_graph.h b/src/gwin/gwin_graph.h
index eea80679..8355f494 100644
--- a/src/gwin/gwin_graph.h
+++ b/src/gwin/gwin_graph.h
@@ -22,7 +22,7 @@
#ifndef _GWIN_GRAPH_H
#define _GWIN_GRAPH_H
-/* This file is included within "src/gwin/sys_defs.h" */
+/* This file is included within "src/gwin/gwin.h" */
typedef enum GGraphPointType_e {
GGRAPH_POINT_NONE, GGRAPH_POINT_DOT, GGRAPH_POINT_SQUARE, GGRAPH_POINT_CIRCLE
diff --git a/src/gwin/gwin_image.h b/src/gwin/gwin_image.h
index 2e0a3218..5def4037 100644
--- a/src/gwin/gwin_image.h
+++ b/src/gwin/gwin_image.h
@@ -27,7 +27,7 @@
#ifndef _GWIN_IMAGE_H
#define _GWIN_IMAGE_H
-// This file is included within "src/gwin/sys_defs.h"
+// This file is included within "src/gwin/gwin.h"
// An image window
typedef struct GImageObject {
diff --git a/src/gwin/sys_options.h b/src/gwin/gwin_options.h
index df8f497e..9252e67a 100644
--- a/src/gwin/sys_options.h
+++ b/src/gwin/gwin_options.h
@@ -6,7 +6,7 @@
*/
/**
- * @file src/gwin/sys_options.h
+ * @file src/gwin/gwin_options.h
* @brief GWIN sub-system options header file.
*
* @addtogroup GWIN
diff --git a/src/gwin/sys_rules.h b/src/gwin/gwin_rules.h
index 39864901..8d8ef2cc 100644
--- a/src/gwin/sys_rules.h
+++ b/src/gwin/gwin_rules.h
@@ -6,7 +6,7 @@
*/
/**
- * @file src/gwin/sys_rules.h
+ * @file src/gwin/gwin_rules.h
* @brief GWIN safety rules header file.
*
* @addtogroup GWIN
diff --git a/src/gwin/gwin_widget.h b/src/gwin/gwin_widget.h
index c6bc6d4c..63d73e77 100644
--- a/src/gwin/gwin_widget.h
+++ b/src/gwin/gwin_widget.h
@@ -23,7 +23,7 @@
#ifndef _GWIDGET_H
#define _GWIDGET_H
-/* This file is included within "src/gwin/sys_defs.h" */
+/* This file is included within "src/gwin/gwin.h" */
// Forward definition
struct GWidgetObject;