aboutsummaryrefslogtreecommitdiffstats
path: root/src
diff options
context:
space:
mode:
authorAndrew Hannam <andrewh@inmarket.com.au>2013-01-17 15:08:34 +1000
committerAndrew Hannam <andrewh@inmarket.com.au>2013-01-17 15:08:34 +1000
commit1fc03db5861c232792042844c15153a7e1bcc724 (patch)
tree499b549f34e5effbfdd3e5ccf3b97b03c732b11e /src
parent7cce52d2f6b874895e3cdd557c4523eeeae942bf (diff)
downloaduGFX-1fc03db5861c232792042844c15153a7e1bcc724.tar.gz
uGFX-1fc03db5861c232792042844c15153a7e1bcc724.tar.bz2
uGFX-1fc03db5861c232792042844c15153a7e1bcc724.zip
New Subsystems GADC, GAUDIN, GAUDOUT, GMISC
Subsystem definitions and API (not fully implemented yet)
Diffstat (limited to 'src')
-rw-r--r--src/gadc/gadc.c38
-rw-r--r--src/gadc/gadc.mk1
-rw-r--r--src/gaudin/gaudin.c38
-rw-r--r--src/gaudin/gaudin.mk1
-rw-r--r--src/gaudout/gaudout.c38
-rw-r--r--src/gaudout/gaudout.mk1
-rw-r--r--src/gmisc/arrayops.c37
-rw-r--r--src/gmisc/gmisc.mk1
8 files changed, 155 insertions, 0 deletions
diff --git a/src/gadc/gadc.c b/src/gadc/gadc.c
new file mode 100644
index 00000000..5533bb49
--- /dev/null
+++ b/src/gadc/gadc.c
@@ -0,0 +1,38 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file src/gadc/gadc.c
+ * @brief GADC sub-system code.
+ *
+ * @addtogroup GADC
+ * @{
+ */
+#include "ch.h"
+#include "hal.h"
+#include "gfx.h"
+
+#if GFX_USE_GADC || defined(__DOXYGEN__)
+
+ #error "GADC: Not implemented yet"
+
+#endif /* GFX_USE_GADC */
+/** @} */
+
diff --git a/src/gadc/gadc.mk b/src/gadc/gadc.mk
new file mode 100644
index 00000000..cfe04177
--- /dev/null
+++ b/src/gadc/gadc.mk
@@ -0,0 +1 @@
+GFXSRC += $(GFXLIB)/src/gadc/gadc.c
diff --git a/src/gaudin/gaudin.c b/src/gaudin/gaudin.c
new file mode 100644
index 00000000..120d7d81
--- /dev/null
+++ b/src/gaudin/gaudin.c
@@ -0,0 +1,38 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file src/gaudin/gaudin.c
+ * @brief GAUDIN sub-system code.
+ *
+ * @addtogroup GAUDIN
+ * @{
+ */
+#include "ch.h"
+#include "hal.h"
+#include "gfx.h"
+
+#if GFX_USE_GAUDIN || defined(__DOXYGEN__)
+
+ #error "GAUDIN: Not implemented yet"
+
+#endif /* GFX_USE_GAUDIN */
+/** @} */
+
diff --git a/src/gaudin/gaudin.mk b/src/gaudin/gaudin.mk
new file mode 100644
index 00000000..f134d264
--- /dev/null
+++ b/src/gaudin/gaudin.mk
@@ -0,0 +1 @@
+GFXSRC += $(GFXLIB)/src/gaudin/gaudin.c
diff --git a/src/gaudout/gaudout.c b/src/gaudout/gaudout.c
new file mode 100644
index 00000000..af8499dc
--- /dev/null
+++ b/src/gaudout/gaudout.c
@@ -0,0 +1,38 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file src/gaudout/gaudout.c
+ * @brief GAUDOUT sub-system code.
+ *
+ * @addtogroup GAUDOUT
+ * @{
+ */
+#include "ch.h"
+#include "hal.h"
+#include "gfx.h"
+
+#if GFX_USE_GAUDOUT || defined(__DOXYGEN__)
+
+ #error "GAUDOUT: Not implemented yet"
+
+#endif /* GFX_USE_GAUDOUT */
+/** @} */
+
diff --git a/src/gaudout/gaudout.mk b/src/gaudout/gaudout.mk
new file mode 100644
index 00000000..004306bc
--- /dev/null
+++ b/src/gaudout/gaudout.mk
@@ -0,0 +1 @@
+GFXSRC += $(GFXLIB)/src/gaudout/gaudout.c
diff --git a/src/gmisc/arrayops.c b/src/gmisc/arrayops.c
new file mode 100644
index 00000000..a27ddbdb
--- /dev/null
+++ b/src/gmisc/arrayops.c
@@ -0,0 +1,37 @@
+/*
+ ChibiOS/GFX - Copyright (C) 2012
+ Joel Bodenmann aka Tectu <joel@unormal.org>
+
+ This file is part of ChibiOS/GFX.
+
+ ChibiOS/GFX is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS/GFX is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file src/gmisc/arrayops.c
+ * @brief GMISC Array Operations code.
+ *
+ * @addtogroup GMISC
+ * @{
+ */
+#include "ch.h"
+#include "hal.h"
+#include "gfx.h"
+
+#if (GFX_USE_GMISC && GMISC_NEED_ARRAYOPS) || defined(__DOXYGEN__)
+
+ #error "GMISC (Array Ops): Not implemented yet"
+
+#endif /* GFX_USE_GMISC && GMISC_NEED_ARRAYOPS */
+/** @} */
diff --git a/src/gmisc/gmisc.mk b/src/gmisc/gmisc.mk
new file mode 100644
index 00000000..7e4caea8
--- /dev/null
+++ b/src/gmisc/gmisc.mk
@@ -0,0 +1 @@
+GFXSRC += $(GFXLIB)/src/gmisc/arrayops.c