aboutsummaryrefslogtreecommitdiffstats
path: root/src
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2015-04-07 23:21:19 +1000
committerinmarket <andrewh@inmarket.com.au>2015-04-07 23:21:19 +1000
commit82cb03947c60477e54f46dd7ee8a9b685ad71d64 (patch)
tree4f00b78d4b57b7915397bb114b5743253ee81d24 /src
parentbeacfaa9946014ca05e12eb740d1d33a1f5f996f (diff)
downloaduGFX-82cb03947c60477e54f46dd7ee8a9b685ad71d64.tar.gz
uGFX-82cb03947c60477e54f46dd7ee8a9b685ad71d64.tar.bz2
uGFX-82cb03947c60477e54f46dd7ee8a9b685ad71d64.zip
Add Arduino as a full GOS supported operating system (even though it is really just a special bare bones platform)
Diffstat (limited to 'src')
-rw-r--r--src/gos/gos.h2
-rw-r--r--src/gos/gos.mk3
-rw-r--r--src/gos/gos_options.h7
-rw-r--r--src/gos/gos_rules.h4
4 files changed, 13 insertions, 3 deletions
diff --git a/src/gos/gos.h b/src/gos/gos.h
index f1def55a..82ad9d1c 100644
--- a/src/gos/gos.h
+++ b/src/gos/gos.h
@@ -462,6 +462,8 @@
#include "src/gos/gos_raw32.h"
#elif GFX_USE_OS_ECOS
#include "src/gos/gos_ecos.h"
+#elif GFX_USE_OS_ARDUINO
+ #include "src/gos/gos_arduino.h"
#else
#error "Your operating system is not supported yet"
#endif
diff --git a/src/gos/gos.mk b/src/gos/gos.mk
index a7b3dec6..a825dea4 100644
--- a/src/gos/gos.mk
+++ b/src/gos/gos.mk
@@ -5,5 +5,6 @@ GFXSRC += $(GFXLIB)/src/gos/gos_chibios.c \
$(GFXLIB)/src/gos/gos_osx.c \
$(GFXLIB)/src/gos/gos_raw32.c \
$(GFXLIB)/src/gos/gos_ecos.c \
- $(GFXLIB)/src/gos/gos_rawrtos.c
+ $(GFXLIB)/src/gos/gos_rawrtos.c \
+ $(GFXLIB)/src/gos/gos_arduino.c
diff --git a/src/gos/gos_options.h b/src/gos/gos_options.h
index 611acfb7..2f896508 100644
--- a/src/gos/gos_options.h
+++ b/src/gos/gos_options.h
@@ -69,6 +69,13 @@
#ifndef GFX_USE_OS_ECOS
#define GFX_USE_OS_ECOS FALSE
#endif
+ /**
+ * @brief Use Arduino
+ * @details Defaults to FALSE
+ */
+ #ifndef GFX_USE_OS_ARDUINO
+ #define GFX_USE_OS_ARDUINO FALSE
+ #endif
/**
* @}
*
diff --git a/src/gos/gos_rules.h b/src/gos/gos_rules.h
index 0a86f86e..6eea98c9 100644
--- a/src/gos/gos_rules.h
+++ b/src/gos/gos_rules.h
@@ -16,7 +16,7 @@
#ifndef _GOS_RULES_H
#define _GOS_RULES_H
-#if !GFX_USE_OS_CHIBIOS && !GFX_USE_OS_WIN32 && !GFX_USE_OS_LINUX && !GFX_USE_OS_OSX && !GFX_USE_OS_RAW32 && !GFX_USE_OS_FREERTOS && !GFX_USE_OS_ECOS && !GFX_USE_OS_RAWRTOS
+#if !GFX_USE_OS_CHIBIOS && !GFX_USE_OS_WIN32 && !GFX_USE_OS_LINUX && !GFX_USE_OS_OSX && !GFX_USE_OS_RAW32 && !GFX_USE_OS_FREERTOS && !GFX_USE_OS_ECOS && !GFX_USE_OS_RAWRTOS && !GFX_USE_OS_ARDUINO
#if GFX_DISPLAY_RULE_WARNINGS
#warning "GOS: No Operating System has been defined. ChibiOS (GFX_USE_OS_CHIBIOS) has been turned on for you."
#endif
@@ -24,7 +24,7 @@
#define GFX_USE_OS_CHIBIOS TRUE
#endif
-#if GFX_USE_OS_CHIBIOS + GFX_USE_OS_WIN32 + GFX_USE_OS_LINUX + GFX_USE_OS_OSX + GFX_USE_OS_RAW32 + GFX_USE_OS_FREERTOS + GFX_USE_OS_ECOS + GFX_USE_OS_RAWRTOS != 1 * TRUE
+#if GFX_USE_OS_CHIBIOS + GFX_USE_OS_WIN32 + GFX_USE_OS_LINUX + GFX_USE_OS_OSX + GFX_USE_OS_RAW32 + GFX_USE_OS_FREERTOS + GFX_USE_OS_ECOS + GFX_USE_OS_RAWRTOS + GFX_USE_OS_ARDUINO != 1 * TRUE
#error "GOS: More than one operation system has been defined as TRUE."
#endif