aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gmake_scripts/cpu_raspberrypi.mk
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-10-06 17:05:16 +1000
committerinmarket <andrewh@inmarket.com.au>2014-10-06 17:05:16 +1000
commit5a3f22617b02ec366461be21765e636e6bdd0222 (patch)
tree853945ab638d80f7d027bd08231f18ea94b4b4e9 /tools/gmake_scripts/cpu_raspberrypi.mk
parent50dfad6f038ed5d20a357f634a70b23c570b26ed (diff)
downloaduGFX-5a3f22617b02ec366461be21765e636e6bdd0222.tar.gz
uGFX-5a3f22617b02ec366461be21765e636e6bdd0222.tar.bz2
uGFX-5a3f22617b02ec366461be21765e636e6bdd0222.zip
Add support for FreeRTOS into make system
Diffstat (limited to 'tools/gmake_scripts/cpu_raspberrypi.mk')
-rw-r--r--tools/gmake_scripts/cpu_raspberrypi.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/tools/gmake_scripts/cpu_raspberrypi.mk b/tools/gmake_scripts/cpu_raspberrypi.mk
new file mode 100644
index 00000000..b31c35e9
--- /dev/null
+++ b/tools/gmake_scripts/cpu_raspberrypi.mk
@@ -0,0 +1,18 @@
+#
+# This file is subject to the terms of the GFX License. If a copy of
+# the license was not distributed with this file, you can obtain one at:
+#
+# http://ugfx.org/license.html
+#
+
+#
+# See readme.txt for the make API
+#
+
+# Requirements:
+#
+# NONE
+#
+
+SRCFLAGS += -march=armv6zk -mcpu=arm1176jzf-s -mtune=arm1176jzf-s -mfpu=vfp -mfloat-abi=hard
+LDFLAGS += -march=armv6zk -mcpu=arm1176jzf-s -mtune=arm1176jzf-s -mfpu=vfp -mfloat-abi=hard