aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gmake_scripts/cpu_stm32m1.mk
diff options
context:
space:
mode:
authorJoel Bodenmann <joel@unormal.org>2015-02-16 19:10:29 +0100
committerJoel Bodenmann <joel@unormal.org>2015-02-16 19:10:29 +0100
commit7e773a2a4c5e4bd54b8a9a486c2afd6e9f10dae0 (patch)
tree20d0cfe39b15cb1bf8653d0e929e15ad1e76eac4 /tools/gmake_scripts/cpu_stm32m1.mk
parent7c7459f1d2a786ae24d895e239f683b17ed6f4b3 (diff)
downloaduGFX-7e773a2a4c5e4bd54b8a9a486c2afd6e9f10dae0.tar.gz
uGFX-7e773a2a4c5e4bd54b8a9a486c2afd6e9f10dae0.tar.bz2
uGFX-7e773a2a4c5e4bd54b8a9a486c2afd6e9f10dae0.zip
Adding STM32F1 script
Diffstat (limited to 'tools/gmake_scripts/cpu_stm32m1.mk')
-rw-r--r--tools/gmake_scripts/cpu_stm32m1.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/tools/gmake_scripts/cpu_stm32m1.mk b/tools/gmake_scripts/cpu_stm32m1.mk
new file mode 100644
index 00000000..9c8246e6
--- /dev/null
+++ b/tools/gmake_scripts/cpu_stm32m1.mk
@@ -0,0 +1,20 @@
+#
+# This file is subject to the terms of the GFX License. If a copy of
+# the license was not distributed with this file, you can obtain one at:
+#
+# http://ugfx.org/license.html
+#
+
+#
+# See readme.txt for the make API
+#
+
+# Requirements:
+#
+# NONE
+#
+
+SRCFLAGS += -mcpu=cortex-m1 -falign-functions=16
+LDFLAGS += -mcpu=cortex-m1
+DEFS += CORTEX_USE_FPU=FALSE
+