aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gmake_scripts/cpu_stm32m4.mk
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-10-06 15:50:19 +1000
committerinmarket <andrewh@inmarket.com.au>2014-10-06 15:50:43 +1000
commit63fd8ab89b9c4cdddcfd91aacbf12871aeff556e (patch)
treec36a92ee7d769ec7de92ad804078912a054cc951 /tools/gmake_scripts/cpu_stm32m4.mk
parentbbc7b6e039d179c92fe53a6ad522131e64412432 (diff)
downloaduGFX-63fd8ab89b9c4cdddcfd91aacbf12871aeff556e.tar.gz
uGFX-63fd8ab89b9c4cdddcfd91aacbf12871aeff556e.tar.bz2
uGFX-63fd8ab89b9c4cdddcfd91aacbf12871aeff556e.zip
Update support for ChibiOS v3 to the current repository.
Update Make system to match. Add ability to make to a library rather than a program Stop ignoring objcode invalid format errors Multiple make tidy ups
Diffstat (limited to 'tools/gmake_scripts/cpu_stm32m4.mk')
-rw-r--r--tools/gmake_scripts/cpu_stm32m4.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/tools/gmake_scripts/cpu_stm32m4.mk b/tools/gmake_scripts/cpu_stm32m4.mk
new file mode 100644
index 00000000..9e105a36
--- /dev/null
+++ b/tools/gmake_scripts/cpu_stm32m4.mk
@@ -0,0 +1,19 @@
+#
+# This file is subject to the terms of the GFX License. If a copy of
+# the license was not distributed with this file, you can obtain one at:
+#
+# http://ugfx.org/license.html
+#
+
+#
+# See readme.txt for the make API
+#
+
+# Requirements:
+#
+# NONE
+#
+
+SRCFLAGS += -mcpu=cortex-m4 -mfloat-abi=hard -mfpu=fpv4-sp-d16 -fsingle-precision-constant -falign-functions=16
+LDFLAGS += -mcpu=cortex-m4 -mfloat-abi=hard -mfpu=fpv4-sp-d16
+LIBS += m