aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gmake_scripts/library_ugfx.mk
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-09-28 01:42:30 +1000
committerinmarket <andrewh@inmarket.com.au>2014-09-28 01:42:30 +1000
commitdaf9f65b9fb9822bc3bc80d63b66a612e085802a (patch)
tree554493727b03b8dc0277a9f7d5b53e339188a1fd /tools/gmake_scripts/library_ugfx.mk
parent2776d00e82b85365efa38d0067b658fd2818ca41 (diff)
downloaduGFX-daf9f65b9fb9822bc3bc80d63b66a612e085802a.tar.gz
uGFX-daf9f65b9fb9822bc3bc80d63b66a612e085802a.tar.bz2
uGFX-daf9f65b9fb9822bc3bc80d63b66a612e085802a.zip
New makefile structure. Also OSX board defintion
Diffstat (limited to 'tools/gmake_scripts/library_ugfx.mk')
-rw-r--r--tools/gmake_scripts/library_ugfx.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/tools/gmake_scripts/library_ugfx.mk b/tools/gmake_scripts/library_ugfx.mk
new file mode 100644
index 00000000..7dbf9d99
--- /dev/null
+++ b/tools/gmake_scripts/library_ugfx.mk
@@ -0,0 +1,20 @@
+# See readme.txt for the make API
+
+# Requirements:
+#
+# GFXLIB: The location of the uGFX code eg GFXLIB=../ugfx
+#
+
+# Optional:
+#
+# GFXBOARD: The uGFX Board to include eg GFXBOARD=Win32
+# GFXDRIVERS: The uGFX Drivers to include - separate multiple drivers with spaces eg GFXDRIVERS=multiple/uGFXnet
+# GFXDEMO: Compile a uGFX standard demo? If blank you need to include your own project files. eg GFXDEMO=modules/gwin/widgets
+#
+
+
+include $(GFXLIB)/gfx.mk
+SRC += $(GFXSRC)
+DEFS += $(GFXDEFS)
+INCPATH += $(GFXINC)
+LIBS += $(GFXLIBS)