aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gmake_scripts/os_chibios.mk
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-10-01 00:44:40 +1000
committerinmarket <andrewh@inmarket.com.au>2014-10-01 00:44:40 +1000
commit68a784d67e7ff1ce1c922819e5e8f1d6865c69da (patch)
treeb666d38078b7e2094e43b52fe9ef51dba201ff4c /tools/gmake_scripts/os_chibios.mk
parent8cc07f2d4c513ed7bd9d0d9a825102555038c715 (diff)
downloaduGFX-68a784d67e7ff1ce1c922819e5e8f1d6865c69da.tar.gz
uGFX-68a784d67e7ff1ce1c922819e5e8f1d6865c69da.tar.bz2
uGFX-68a784d67e7ff1ce1c922819e5e8f1d6865c69da.zip
First ARM build to use the new makefile plus makefile updates
Diffstat (limited to 'tools/gmake_scripts/os_chibios.mk')
-rw-r--r--tools/gmake_scripts/os_chibios.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/tools/gmake_scripts/os_chibios.mk b/tools/gmake_scripts/os_chibios.mk
new file mode 100644
index 00000000..8165c269
--- /dev/null
+++ b/tools/gmake_scripts/os_chibios.mk
@@ -0,0 +1,30 @@
+# See readme.txt for the make API
+
+# Requirements:
+#
+# CHIBIOS: The location of the ChibiOS code eg CHIBIOS=../chibios
+# CHIBIOS_BOARD The name of the ChibiOS board eg CHIBIOS_BOARD=OLIMEX_SAM7_EX256
+# CHIBIOS_PLATFORM The name of the ChibiOS platform eg CHIBIOS_PLATFORM=AT91SAM7
+# CHIBIOS_PORT The name of the ChibiOS port eg CHIBIOS_PORT=GCC/ARM/AT91SAM7
+#
+
+# Optional:
+#
+# CHIBIOS_LDSCRIPT The name of the loader script eg CHIBIOS_LDSCRIPT=$(PORTLD)/AT91SAM7X256.ld
+#
+
+include $(CHIBIOS)/boards/$(CHIBIOS_BOARD)/board.mk
+include $(CHIBIOS)/os/hal/platforms/$(CHIBIOS_PLATFORM)/platform.mk
+include $(CHIBIOS)/os/hal/hal.mk
+include $(CHIBIOS)/os/ports/$(CHIBIOS_PORT)/port.mk
+include $(CHIBIOS)/os/kernel/kernel.mk
+LDSCRIPT= $(CHIBIOS_LDSCRIPT)
+INCPATH += $(PORTINC) $(KERNINC) $(TESTINC) \
+ $(HALINC) $(PLATFORMINC) $(BOARDINC)
+SRC += $(PORTSRC) \
+ $(KERNSRC) \
+ $(TESTSRC) \
+ $(HALSRC) \
+ $(PLATFORMSRC) \
+ $(BOARDSRC) \
+ $(PORTASM)