aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gmake_scripts/os_chibios.mk
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-10-01 00:44:40 +1000
committerinmarket <andrewh@inmarket.com.au>2014-10-01 00:45:02 +1000
commitf90ea57bff091832c7b52b3825057ac20ded1f01 (patch)
tree83d8e0e8b9917584e7f216470cd0fb8efa1a975e /tools/gmake_scripts/os_chibios.mk
parentb1b00b1cc9780db403bba2f21837fef20b9d8e8c (diff)
downloaduGFX-f90ea57bff091832c7b52b3825057ac20ded1f01.tar.gz
uGFX-f90ea57bff091832c7b52b3825057ac20ded1f01.tar.bz2
uGFX-f90ea57bff091832c7b52b3825057ac20ded1f01.zip
First ARM build to use the new makefile plus makefile updates
Diffstat (limited to 'tools/gmake_scripts/os_chibios.mk')
-rw-r--r--tools/gmake_scripts/os_chibios.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/tools/gmake_scripts/os_chibios.mk b/tools/gmake_scripts/os_chibios.mk
new file mode 100644
index 00000000..8165c269
--- /dev/null
+++ b/tools/gmake_scripts/os_chibios.mk
@@ -0,0 +1,30 @@
+# See readme.txt for the make API
+
+# Requirements:
+#
+# CHIBIOS: The location of the ChibiOS code eg CHIBIOS=../chibios
+# CHIBIOS_BOARD The name of the ChibiOS board eg CHIBIOS_BOARD=OLIMEX_SAM7_EX256
+# CHIBIOS_PLATFORM The name of the ChibiOS platform eg CHIBIOS_PLATFORM=AT91SAM7
+# CHIBIOS_PORT The name of the ChibiOS port eg CHIBIOS_PORT=GCC/ARM/AT91SAM7
+#
+
+# Optional:
+#
+# CHIBIOS_LDSCRIPT The name of the loader script eg CHIBIOS_LDSCRIPT=$(PORTLD)/AT91SAM7X256.ld
+#
+
+include $(CHIBIOS)/boards/$(CHIBIOS_BOARD)/board.mk
+include $(CHIBIOS)/os/hal/platforms/$(CHIBIOS_PLATFORM)/platform.mk
+include $(CHIBIOS)/os/hal/hal.mk
+include $(CHIBIOS)/os/ports/$(CHIBIOS_PORT)/port.mk
+include $(CHIBIOS)/os/kernel/kernel.mk
+LDSCRIPT= $(CHIBIOS_LDSCRIPT)
+INCPATH += $(PORTINC) $(KERNINC) $(TESTINC) \
+ $(HALINC) $(PLATFORMINC) $(BOARDINC)
+SRC += $(PORTSRC) \
+ $(KERNSRC) \
+ $(TESTSRC) \
+ $(HALSRC) \
+ $(PLATFORMSRC) \
+ $(BOARDSRC) \
+ $(PORTASM)