aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gmake_scripts/os_osx.mk
diff options
context:
space:
mode:
authorinmarket <andrewh@inmarket.com.au>2014-10-01 00:44:40 +1000
committerinmarket <andrewh@inmarket.com.au>2014-10-01 00:44:40 +1000
commit68a784d67e7ff1ce1c922819e5e8f1d6865c69da (patch)
treeb666d38078b7e2094e43b52fe9ef51dba201ff4c /tools/gmake_scripts/os_osx.mk
parent8cc07f2d4c513ed7bd9d0d9a825102555038c715 (diff)
downloaduGFX-68a784d67e7ff1ce1c922819e5e8f1d6865c69da.tar.gz
uGFX-68a784d67e7ff1ce1c922819e5e8f1d6865c69da.tar.bz2
uGFX-68a784d67e7ff1ce1c922819e5e8f1d6865c69da.zip
First ARM build to use the new makefile plus makefile updates
Diffstat (limited to 'tools/gmake_scripts/os_osx.mk')
-rw-r--r--tools/gmake_scripts/os_osx.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/tools/gmake_scripts/os_osx.mk b/tools/gmake_scripts/os_osx.mk
new file mode 100644
index 00000000..8b008f4b
--- /dev/null
+++ b/tools/gmake_scripts/os_osx.mk
@@ -0,0 +1,10 @@
+# See readme.txt for the make API
+
+# Requirements:
+#
+# OSX_SDK The location of the SDK eg. OSX_SDK = /Developer/SDKs/MacOSX10.7.sdk
+# OSX_ARCH The architecture flags eg. OSX_ARCH = -mmacosx-version-min=10.3 -arch i386
+#
+
+SRCFLAGS += -isysroot $(OSX_SDK) $(OSX_ARCH)
+LDFLAGS += -pthread -Wl,-syslibroot,$(OSX_SDK) $(OSX_ARCH)