aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorJoel Bodenmann <joel@seriouslyembedded.com>2015-07-10 11:56:31 +0200
committerJoel Bodenmann <joel@seriouslyembedded.com>2015-07-10 11:56:31 +0200
commit150d62141c1139192991aff84a1521e3eb1cbd09 (patch)
tree7343d7b35bfd0c387aa5326e72dbe48924b4b988 /tools
parent36906d8877e33ae85a0e9422fa19c486a6e8625e (diff)
parentdbeb320fd3bf884a6c88f5183e66a91790bc98a6 (diff)
downloaduGFX-150d62141c1139192991aff84a1521e3eb1cbd09.tar.gz
uGFX-150d62141c1139192991aff84a1521e3eb1cbd09.tar.bz2
uGFX-150d62141c1139192991aff84a1521e3eb1cbd09.zip
Merge branch 'STM32F7_Discovery' of https://bitbucket.org/Tectu/ugfx into STM32F7_Discovery
Diffstat (limited to 'tools')
-rw-r--r--tools/gmake_scripts/cpu_stm32m7.mk24
-rw-r--r--tools/gmake_scripts/os_raw32.mk13
2 files changed, 37 insertions, 0 deletions
diff --git a/tools/gmake_scripts/cpu_stm32m7.mk b/tools/gmake_scripts/cpu_stm32m7.mk
new file mode 100644
index 00000000..0a59e24f
--- /dev/null
+++ b/tools/gmake_scripts/cpu_stm32m7.mk
@@ -0,0 +1,24 @@
+#
+# This file is subject to the terms of the GFX License. If a copy of
+# the license was not distributed with this file, you can obtain one at:
+#
+# http://ugfx.org/license.html
+#
+
+#
+# See readme.txt for the make API
+#
+
+# Requirements:
+#
+# NONE
+#
+
+#SRCFLAGS += -mcpu=cortex-m4 -mfloat-abi=hard -mfpu=fpv4-sp-d16 -fsingle-precision-constant -falign-functions=16
+#LDFLAGS += -mcpu=cortex-m4 -mfloat-abi=hard -mfpu=fpv4-sp-d16 -fsingle-precision-constant -falign-functions=16
+#DEFS += CORTEX_USE_FPU=TRUE
+#LIBS += m
+SRCFLAGS += -mcpu=cortex-m7 -falign-functions=16
+LDFLAGS += -mcpu=cortex-m7
+DEFS += CORTEX_USE_FPU=FALSE
+
diff --git a/tools/gmake_scripts/os_raw32.mk b/tools/gmake_scripts/os_raw32.mk
new file mode 100644
index 00000000..1c96c8ec
--- /dev/null
+++ b/tools/gmake_scripts/os_raw32.mk
@@ -0,0 +1,13 @@
+#
+# This file is subject to the terms of the GFX License. If a copy of
+# the license was not distributed with this file, you can obtain one at:
+#
+# http://ugfx.org/license.html
+#
+
+# See readme.txt for the make API
+
+# Requirements:
+#
+# NONE
+#