aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorThomas Sterren <thomas.sterren@simulton.com>2018-03-06 09:38:37 +0100
committerThomas Sterren <thomas.sterren@simulton.com>2018-03-06 09:38:37 +0100
commit65d00b16b9fbb46ecd69a383dc4adde5c5c03790 (patch)
tree30920f0457522be32ce2b332afe0d2916d93cf66 /tools
parent992850bcb1992ff052d5ac2379e4675a34861723 (diff)
parentf265924396167729e8d9fb36a0383263f36c1270 (diff)
downloaduGFX-65d00b16b9fbb46ecd69a383dc4adde5c5c03790.tar.gz
uGFX-65d00b16b9fbb46ecd69a383dc4adde5c5c03790.tar.bz2
uGFX-65d00b16b9fbb46ecd69a383dc4adde5c5c03790.zip
Merge branch 'master' of https://git.ugfx.io/uGFX/uGFX
Diffstat (limited to 'tools')
-rw-r--r--tools/gmake_scripts/cpu_stm32m1.mk2
-rw-r--r--tools/gmake_scripts/cpu_stm32m3.mk2
-rw-r--r--tools/gmake_scripts/cpu_stm32m4.mk4
-rw-r--r--tools/gmake_scripts/cpu_stm32m7.mk2
4 files changed, 5 insertions, 5 deletions
diff --git a/tools/gmake_scripts/cpu_stm32m1.mk b/tools/gmake_scripts/cpu_stm32m1.mk
index 9c8246e6..777ae4f2 100644
--- a/tools/gmake_scripts/cpu_stm32m1.mk
+++ b/tools/gmake_scripts/cpu_stm32m1.mk
@@ -16,5 +16,5 @@
SRCFLAGS += -mcpu=cortex-m1 -falign-functions=16
LDFLAGS += -mcpu=cortex-m1
-DEFS += CORTEX_USE_FPU=FALSE
+DEFS += CORTEX_USE_FPU=GFXOFF
diff --git a/tools/gmake_scripts/cpu_stm32m3.mk b/tools/gmake_scripts/cpu_stm32m3.mk
index 87030aee..b430d7fd 100644
--- a/tools/gmake_scripts/cpu_stm32m3.mk
+++ b/tools/gmake_scripts/cpu_stm32m3.mk
@@ -16,5 +16,5 @@
SRCFLAGS += -mcpu=cortex-m3 -falign-functions=16
LDFLAGS += -mcpu=cortex-m3
-DEFS += CORTEX_USE_FPU=FALSE
+DEFS += CORTEX_USE_FPU=GFXOFF
diff --git a/tools/gmake_scripts/cpu_stm32m4.mk b/tools/gmake_scripts/cpu_stm32m4.mk
index 1e205eb6..db1efd07 100644
--- a/tools/gmake_scripts/cpu_stm32m4.mk
+++ b/tools/gmake_scripts/cpu_stm32m4.mk
@@ -16,9 +16,9 @@
SRCFLAGS += -mcpu=cortex-m4 -falign-functions=16 -mfloat-abi=hard -mfpu=fpv4-sp-d16 -fsingle-precision-constant
LDFLAGS += -mcpu=cortex-m4 -falign-functions=16 -mfloat-abi=hard -mfpu=fpv4-sp-d16 -fsingle-precision-constant
-DEFS += CORTEX_USE_FPU=TRUE USE_FPU=hard
+DEFS += CORTEX_USE_FPU=GFXON USE_FPU=hard
LIBS += m
#SRCFLAGS += -mcpu=cortex-m4 -falign-functions=16
#LDFLAGS += -mcpu=cortex-m4
-#DEFS += CORTEX_USE_FPU=FALSE
+#DEFS += CORTEX_USE_FPU=GFXOFF
diff --git a/tools/gmake_scripts/cpu_stm32m7.mk b/tools/gmake_scripts/cpu_stm32m7.mk
index 78e1cc4e..c2d17b72 100644
--- a/tools/gmake_scripts/cpu_stm32m7.mk
+++ b/tools/gmake_scripts/cpu_stm32m7.mk
@@ -15,5 +15,5 @@
#
SRCFLAGS += -mcpu=cortex-m7 -falign-functions=16 -mfloat-abi=hard -mfpu=fpv4-sp-d16 -fsingle-precision-constant
LDFLAGS += -mcpu=cortex-m7 -falign-functions=16 -mfloat-abi=hard -mfpu=fpv4-sp-d16 -fsingle-precision-constant
-DEFS += CORTEX_USE_FPU=TRUE USE_FPU=hard
+DEFS += CORTEX_USE_FPU=GFXON USE_FPU=hard
LIBS += m \ No newline at end of file