aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--demos/console/main.c2
-rw-r--r--docs/configure.txt4
-rw-r--r--docs/usage.txt4
-rw-r--r--drivers/gdisp/Nokia6610/gdisp_lld.c4
-rw-r--r--drivers/gdisp/Nokia6610/gdisp_lld_config.h4
-rw-r--r--drivers/gdisp/Nokia6610/readme.txt2
-rw-r--r--drivers/gdisp/S6D1121/gdisp_lld.c4
-rw-r--r--drivers/gdisp/S6D1121/gdisp_lld_config.h4
-rw-r--r--drivers/gdisp/S6D1121/readme.txt2
-rw-r--r--drivers/gdisp/SSD1289/gdisp_lld.c4
-rw-r--r--drivers/gdisp/SSD1289/gdisp_lld_config.h4
-rw-r--r--drivers/gdisp/SSD1289/readme.txt2
-rw-r--r--drivers/gdisp/SSD1963/gdisp_lld.c4
-rw-r--r--drivers/gdisp/SSD1963/gdisp_lld_config.h4
-rw-r--r--drivers/gdisp/SSD1963/readme.txt2
-rw-r--r--drivers/gdisp/TestStub/gdisp_lld.c4
-rw-r--r--drivers/gdisp/TestStub/gdisp_lld_config.h4
-rw-r--r--drivers/gdisp/TestStub/readme.txt2
-rw-r--r--drivers/gdisp/VMT/gdisp_lld.c4
-rw-r--r--drivers/gdisp/VMT/gdisp_lld_config.h4
-rw-r--r--drivers/gdisp/VMT/gdisp_lld_driver1.c4
-rw-r--r--drivers/gdisp/VMT/gdisp_lld_driver2.c4
-rw-r--r--drivers/gdisp/VMT/readme.txt2
-rw-r--r--drivers/touchpad/ADS7843/readme.txt2
-rw-r--r--drivers/touchpad/ADS7843/touchpad_lld.c4
-rw-r--r--drivers/touchpad/ADS7843/touchpad_lld_config.h4
-rw-r--r--drivers/touchpad/XPT2046/readme.txt2
-rw-r--r--drivers/touchpad/XPT2046/touchpad_lld.c4
-rw-r--r--drivers/touchpad/XPT2046/touchpad_lld_config.h4
-rw-r--r--include/console.h8
-rw-r--r--include/gdisp.h4
-rw-r--r--include/gdisp_emulation.c4
-rw-r--r--include/gdisp_fonts.h2
-rw-r--r--include/gdisp_lld.h4
-rw-r--r--include/gdisp_lld_msgs.h4
-rw-r--r--include/touchpad.h4
-rw-r--r--include/touchpad_lld.h4
-rw-r--r--src/console.c2
-rw-r--r--src/gdisp.c4
-rw-r--r--src/gdisp_fonts.c4
-rw-r--r--src/touchpad.c4
-rw-r--r--templates/gdispXXXXX/gdisp_lld.c4
-rw-r--r--templates/gdispXXXXX/gdisp_lld_config.h4
-rw-r--r--templates/gdispXXXXX/readme.txt2
-rw-r--r--templates/touchpadXXXXX/touchpad_lld.c4
-rw-r--r--templates/touchpadXXXXX/touchpad_lld_config.h4
46 files changed, 82 insertions, 82 deletions
diff --git a/demos/console/main.c b/demos/console/main.c
index 2a0f2c77..b0e0fb7f 100644
--- a/demos/console/main.c
+++ b/demos/console/main.c
@@ -28,7 +28,7 @@
/*
* Please add the following to your halconf.h
*
- * #define GDISP_NEED_CONSOLE TRUE
+ * #define GFX_USE_CONSOLE TRUE
* #define GDISP_NEED_SCROLL TRUE
*/
diff --git a/docs/configure.txt b/docs/configure.txt
index 15380e16..17540062 100644
--- a/docs/configure.txt
+++ b/docs/configure.txt
@@ -3,7 +3,7 @@ There are serval macros available to configure the behaviour of the GFX-Library.
HAL macros:
#define HAL_USE_GFX // enables the GDISP sub system. This is essentially needed to use the display
- #define HAL_USE_TOUCHPAD // enables the TouchPad sub system. This is essentially needed to use the touchpad
+ #define GFX_USE_TOUCHPAD // enables the TouchPad sub system. This is essentially needed to use the touchpad
@@ -27,7 +27,7 @@ GDISP macors:
#define GDISP_NEED_SCROLL // is scrolling is needed (pixel shift)
#define GDISP_NEED_QUERY // to make certain queries to the LCD controller
- #define GDISP_NEED_CONSOLE // for the console abstraction
+ #define GFX_USE_CONSOLE // for the console abstraction
TouchPad macros:
diff --git a/docs/usage.txt b/docs/usage.txt
index 968a1280..a68c618a 100644
--- a/docs/usage.txt
+++ b/docs/usage.txt
@@ -14,8 +14,8 @@ To include any of these functions/drivers in your project...
5/ In your project halconf.h turn on the support you want. Please take a look to
docs/configure.txt for a list and description of all available macros. For example:
- #define HAL_USE_GDISP TRUE
- #define HAL_USE_TOUCHPAD TRUE
+ #define GFX_USE_GDISP TRUE
+ #define GFX_USE_TOUCHPAD TRUE
#define GDISP_USE_GPIO TRUE
#define GDISP_GDISP_SCREEN_WIDTH 240
diff --git a/drivers/gdisp/Nokia6610/gdisp_lld.c b/drivers/gdisp/Nokia6610/gdisp_lld.c
index 16bab6a4..75e4cecd 100644
--- a/drivers/gdisp/Nokia6610/gdisp_lld.c
+++ b/drivers/gdisp/Nokia6610/gdisp_lld.c
@@ -30,7 +30,7 @@
#include "hal.h"
#include "gdisp.h"
-#if HAL_USE_GDISP || defined(__DOXYGEN__)
+#if GFX_USE_GDISP || defined(__DOXYGEN__)
/* Include the emulation code for things we don't support */
#include "gdisp_emulation.c"
@@ -589,5 +589,5 @@ void GDISP_LLD(drawpixel)(coord_t x, coord_t y, color_t color) {
}
#endif
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
/** @} */
diff --git a/drivers/gdisp/Nokia6610/gdisp_lld_config.h b/drivers/gdisp/Nokia6610/gdisp_lld_config.h
index e94c94ad..23ae3cde 100644
--- a/drivers/gdisp/Nokia6610/gdisp_lld_config.h
+++ b/drivers/gdisp/Nokia6610/gdisp_lld_config.h
@@ -29,7 +29,7 @@
#ifndef _GDISP_LLD_CONFIG_H
#define _GDISP_LLD_CONFIG_H
-#if HAL_USE_GDISP
+#if GFX_USE_GDISP
/*===========================================================================*/
/* Driver hardware support. */
@@ -52,7 +52,7 @@
#define GDISP_PACKED_PIXELS FALSE
#define GDISP_PACKED_LINES FALSE
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
#endif /* _GDISP_LLD_CONFIG_H */
/** @} */
diff --git a/drivers/gdisp/Nokia6610/readme.txt b/drivers/gdisp/Nokia6610/readme.txt
index 8aa5ee6c..cd3722fb 100644
--- a/drivers/gdisp/Nokia6610/readme.txt
+++ b/drivers/gdisp/Nokia6610/readme.txt
@@ -1,7 +1,7 @@
To use this driver:
1. Add in your halconf.h:
- a) #define HAL_USE_GDISP TRUE
+ a) #define GFX_USE_GDISP TRUE
b) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
c) One (only) of:
#define GDISP_USE_GE8 /* The Epson controller */
diff --git a/drivers/gdisp/S6D1121/gdisp_lld.c b/drivers/gdisp/S6D1121/gdisp_lld.c
index 0972f260..bf2e60f5 100644
--- a/drivers/gdisp/S6D1121/gdisp_lld.c
+++ b/drivers/gdisp/S6D1121/gdisp_lld.c
@@ -30,7 +30,7 @@
#include "hal.h"
#include "gdisp.h"
-#if HAL_USE_GDISP || defined(__DOXYGEN__)
+#if GFX_USE_GDISP || defined(__DOXYGEN__)
/* Include the emulation code for things we don't support */
#include "gdisp_emulation.c"
@@ -499,5 +499,5 @@ void GDISP_LLD(drawpixel)(coord_t x, coord_t y, color_t color) {
}
#endif
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
/** @} */
diff --git a/drivers/gdisp/S6D1121/gdisp_lld_config.h b/drivers/gdisp/S6D1121/gdisp_lld_config.h
index 4f8047bd..8135871e 100644
--- a/drivers/gdisp/S6D1121/gdisp_lld_config.h
+++ b/drivers/gdisp/S6D1121/gdisp_lld_config.h
@@ -29,7 +29,7 @@
#ifndef _GDISP_LLD_CONFIG_H
#define _GDISP_LLD_CONFIG_H
-#if HAL_USE_GDISP
+#if GFX_USE_GDISP
/*===========================================================================*/
/* Driver hardware support. */
@@ -47,7 +47,7 @@
#define GDISP_PIXELFORMAT GDISP_PIXELFORMAT_RGB565
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
#endif /* _GDISP_LLD_CONFIG_H */
/** @} */
diff --git a/drivers/gdisp/S6D1121/readme.txt b/drivers/gdisp/S6D1121/readme.txt
index e60a0e29..1ca9a6f0 100644
--- a/drivers/gdisp/S6D1121/readme.txt
+++ b/drivers/gdisp/S6D1121/readme.txt
@@ -1,7 +1,7 @@
To use this driver:
1. Add in your halconf.h:
- a) #define HAL_USE_GDISP TRUE
+ a) #define GFX_USE_GDISP TRUE
b) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
c) One (only) of:
#define GDISP_USE_GPIO
diff --git a/drivers/gdisp/SSD1289/gdisp_lld.c b/drivers/gdisp/SSD1289/gdisp_lld.c
index 75ed2506..8de583fb 100644
--- a/drivers/gdisp/SSD1289/gdisp_lld.c
+++ b/drivers/gdisp/SSD1289/gdisp_lld.c
@@ -30,7 +30,7 @@
#include "hal.h"
#include "gdisp.h"
-#if HAL_USE_GDISP || defined(__DOXYGEN__)
+#if GFX_USE_GDISP || defined(__DOXYGEN__)
/* Include the emulation code for things we don't support */
#include "gdisp_emulation.c"
@@ -460,5 +460,5 @@ void GDISP_LLD(drawpixel)(coord_t x, coord_t y, color_t color) {
}
#endif
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
/** @} */
diff --git a/drivers/gdisp/SSD1289/gdisp_lld_config.h b/drivers/gdisp/SSD1289/gdisp_lld_config.h
index 9ae204bb..bc49c764 100644
--- a/drivers/gdisp/SSD1289/gdisp_lld_config.h
+++ b/drivers/gdisp/SSD1289/gdisp_lld_config.h
@@ -29,7 +29,7 @@
#ifndef _GDISP_LLD_CONFIG_H
#define _GDISP_LLD_CONFIG_H
-#if HAL_USE_GDISP
+#if GFX_USE_GDISP
/*===========================================================================*/
/* Driver hardware support. */
@@ -47,7 +47,7 @@
#define GDISP_PIXELFORMAT GDISP_PIXELFORMAT_RGB565
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
#endif /* _GDISP_LLD_CONFIG_H */
/** @} */
diff --git a/drivers/gdisp/SSD1289/readme.txt b/drivers/gdisp/SSD1289/readme.txt
index bbe49d7d..5bde39f8 100644
--- a/drivers/gdisp/SSD1289/readme.txt
+++ b/drivers/gdisp/SSD1289/readme.txt
@@ -1,7 +1,7 @@
To use this driver:
1. Add in your halconf.h:
- a) #define HAL_USE_GDISP TRUE
+ a) #define GFX_USE_GDISP TRUE
b) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
diff --git a/drivers/gdisp/SSD1963/gdisp_lld.c b/drivers/gdisp/SSD1963/gdisp_lld.c
index a1fae8a1..e54e889d 100644
--- a/drivers/gdisp/SSD1963/gdisp_lld.c
+++ b/drivers/gdisp/SSD1963/gdisp_lld.c
@@ -30,7 +30,7 @@
#include "hal.h"
#include "gdisp.h"
-#if HAL_USE_GDISP || defined(__DOXYGEN__)
+#if GFX_USE_GDISP || defined(__DOXYGEN__)
/* Include the emulation code for things we don't support */
#include "gdisp_emulation.c"
@@ -602,5 +602,5 @@ void GDISP_LLD(drawpixel)(coord_t x, coord_t y, color_t color) {
}
#endif
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
/** @} */
diff --git a/drivers/gdisp/SSD1963/gdisp_lld_config.h b/drivers/gdisp/SSD1963/gdisp_lld_config.h
index 9a68342b..18d21687 100644
--- a/drivers/gdisp/SSD1963/gdisp_lld_config.h
+++ b/drivers/gdisp/SSD1963/gdisp_lld_config.h
@@ -29,7 +29,7 @@
#ifndef _GDISP_LLD_CONFIG_H
#define _GDISP_LLD_CONFIG_H
-#if HAL_USE_GDISP || defined(__DOXYGEN__)
+#if GFX_USE_GDISP || defined(__DOXYGEN__)
/*===========================================================================*/
/* Driver hardware support. */
@@ -46,7 +46,7 @@
#define GDISP_PIXELFORMAT GDISP_PIXELFORMAT_RGB565
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
#endif /* _GDISP_LLD_CONFIG_H */
/** @} */
diff --git a/drivers/gdisp/SSD1963/readme.txt b/drivers/gdisp/SSD1963/readme.txt
index 7bc7262b..567faf58 100644
--- a/drivers/gdisp/SSD1963/readme.txt
+++ b/drivers/gdisp/SSD1963/readme.txt
@@ -1,7 +1,7 @@
To use this driver:
1. Add in your halconf.h:
- a) #define HAL_USE_GDISP TRUE
+ a) #define GFX_USE_GDISP TRUE
b) Any optional high level driver defines (see gdisp.h) eg: #define GDISP_NEED_MULTITHREAD TRUE
c) One (only) of:
#define GDISP_USE_GPIO
diff --git a/drivers/gdisp/TestStub/gdisp_lld.c b/drivers/gdisp/TestStub/gdisp_lld.c
index 5a8a1b19..d3b74585 100644
--- a/drivers/gdisp/TestStub/gdisp_lld.c
+++ b/drivers/gdisp/TestStub/gdisp_lld.c
@@ -30,7 +30,7 @@
#include "hal.h"
#include "gdisp.h"
-#if HAL_USE_GDISP || defined(__DOXYGEN__)
+#if GFX_USE_GDISP || defined(__DOXYGEN__)
/* Include the emulation code for things we don't support */
#include "gdisp_emulation.c"
@@ -122,5 +122,5 @@ void GDISP_LLD(drawpixel)(coord_t x, coord_t y, color_t color) {
}
#endif
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
/** @} */
diff --git a/drivers/gdisp/TestStub/gdisp_lld_config.h b/drivers/gdisp/TestStub/gdisp_lld_config.h
index 63b74118..45c2b6bd 100644
--- a/drivers/gdisp/TestStub/gdisp_lld_config.h
+++ b/drivers/gdisp/TestStub/gdisp_lld_config.h
@@ -29,7 +29,7 @@
#ifndef _GDISP_LLD_CONFIG_H
#define _GDISP_LLD_CONFIG_H
-#if HAL_USE_GDISP
+#if GFX_USE_GDISP
/*===========================================================================*/
/* Driver hardware support. */
@@ -45,7 +45,7 @@
#define GDISP_PACKED_PIXELS FALSE
#define GDISP_PACKED_LINES FALSE
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
#endif /* _GDISP_LLD_CONFIG_H */
/** @} */
diff --git a/drivers/gdisp/TestStub/readme.txt b/drivers/gdisp/TestStub/readme.txt
index b51ffe1f..11145290 100644
--- a/drivers/gdisp/TestStub/readme.txt
+++ b/drivers/gdisp/TestStub/readme.txt
@@ -8,7 +8,7 @@ Do not use this driver as a template for new drivers. Use the
To use this driver:
1. Add in your halconf.h:
- a) #define HAL_USE_GDISP TRUE
+ a) #define GFX_USE_GDISP TRUE
b) Any optional high level driver defines (see gdisp.h)
you want to compile test eg: GDISP_NEED_MULTITHREAD
diff --git a/drivers/gdisp/VMT/gdisp_lld.c b/drivers/gdisp/VMT/gdisp_lld.c
index a986b5e5..f776dedd 100644
--- a/drivers/gdisp/VMT/gdisp_lld.c
+++ b/drivers/gdisp/VMT/gdisp_lld.c
@@ -30,7 +30,7 @@
#include "hal.h"
#include "gdisp.h"
-#if HAL_USE_GDISP || defined(__DOXYGEN__)
+#if GFX_USE_GDISP || defined(__DOXYGEN__)
#define GDISP_LLD_NO_STRUCT
@@ -277,5 +277,5 @@ bool_t gdisp_lld_init_VMT(void) {
return FALSE;
}
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
/** @} */
diff --git a/drivers/gdisp/VMT/gdisp_lld_config.h b/drivers/gdisp/VMT/gdisp_lld_config.h
index 8a1c99d8..1d44fca3 100644
--- a/drivers/gdisp/VMT/gdisp_lld_config.h
+++ b/drivers/gdisp/VMT/gdisp_lld_config.h
@@ -29,7 +29,7 @@
#ifndef _GDISP_LLD_CONFIG_H
#define _GDISP_LLD_CONFIG_H
-#if HAL_USE_GDISP
+#if GFX_USE_GDISP
/*===========================================================================*/
/* Driver hardware support. */
@@ -64,7 +64,7 @@
#define GDISP_PACKED_PIXELS FALSE
#define GDISP_PACKED_LINES FALSE
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
#endif /* _GDISP_LLD_CONFIG_H */
/** @} */
diff --git a/drivers/gdisp/VMT/gdisp_lld_driver1.c b/drivers/gdisp/VMT/gdisp_lld_driver1.c
index a07689ea..28fc7992 100644
--- a/drivers/gdisp/VMT/gdisp_lld_driver1.c
+++ b/drivers/gdisp/VMT/gdisp_lld_driver1.c
@@ -29,7 +29,7 @@
#include "ch.h"
#include "hal.h"
-#if HAL_USE_GDISP || defined(__DOXYGEN__)
+#if GFX_USE_GDISP || defined(__DOXYGEN__)
#define CONFIGFILE() <../GDISP_VMT_NAME1()/gdisp_lld_config.h>
#define DRIVERFILE() <../GDISP_VMT_NAME1()/gdisp_lld.c>
@@ -47,5 +47,5 @@
/* Add the low level driver */
#include DRIVERFILE()
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
/** @} */
diff --git a/drivers/gdisp/VMT/gdisp_lld_driver2.c b/drivers/gdisp/VMT/gdisp_lld_driver2.c
index 4fe316fa..9f6bce23 100644
--- a/drivers/gdisp/VMT/gdisp_lld_driver2.c
+++ b/drivers/gdisp/VMT/gdisp_lld_driver2.c
@@ -29,7 +29,7 @@
#include "ch.h"
#include "hal.h"
-#if HAL_USE_GDISP || defined(__DOXYGEN__)
+#if GFX_USE_GDISP || defined(__DOXYGEN__)
#define CONFIGFILE() <../GDISP_VMT_NAME2()/gdisp_lld_config.h>
#define DRIVERFILE() <../GDISP_VMT_NAME2()/gdisp_lld.c>
@@ -47,5 +47,5 @@
/* Add the low level driver */
#include DRIVERFILE()
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
/** @} */
diff --git a/drivers/gdisp/VMT/readme.txt b/drivers/gdisp/VMT/readme.txt
index d06a62e2..d6b71e0e 100644
--- a/drivers/gdisp/VMT/readme.txt
+++ b/drivers/gdisp/VMT/readme.txt
@@ -5,7 +5,7 @@ to initialise first (init returns TRUE).
To use this driver:
1. Add in your halconf.h:
- a) #define HAL_USE_GDISP TRUE
+ a) #define GFX_USE_GDISP TRUE
b) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
c) Define these:
#define GDISP_VMT_NAME1(x) x##YourDriver1
diff --git a/drivers/touchpad/ADS7843/readme.txt b/drivers/touchpad/ADS7843/readme.txt
index 4eb8058f..90eadc32 100644
--- a/drivers/touchpad/ADS7843/readme.txt
+++ b/drivers/touchpad/ADS7843/readme.txt
@@ -1,7 +1,7 @@
To use this driver:
1. Add in your halconf.h:
- a) #define HAL_USE_TOUCHPAD TRUE
+ a) #define GFX_USE_TOUCHPAD TRUE
2. To your makefile add the following lines:
include $(GFXLIB)/drivers/touchpadADS7843/touchpad_lld.mk
diff --git a/drivers/touchpad/ADS7843/touchpad_lld.c b/drivers/touchpad/ADS7843/touchpad_lld.c
index eeaf11b5..4640ca8d 100644
--- a/drivers/touchpad/ADS7843/touchpad_lld.c
+++ b/drivers/touchpad/ADS7843/touchpad_lld.c
@@ -30,7 +30,7 @@
#include "hal.h"
#include "touchpad.h"
-#if HAL_USE_TOUCHPAD || defined(__DOXYGEN__)
+#if GFX_USE_TOUCHPAD || defined(__DOXYGEN__)
/*===========================================================================*/
/* Driver local definitions. */
@@ -234,6 +234,6 @@ uint16_t tp_lld_read_y(void) {
}
#endif
-#endif /* HAL_USE_TOUCHPAD */
+#endif /* GFX_USE_TOUCHPAD */
/** @} */
diff --git a/drivers/touchpad/ADS7843/touchpad_lld_config.h b/drivers/touchpad/ADS7843/touchpad_lld_config.h
index 65037b8d..fa1e11eb 100644
--- a/drivers/touchpad/ADS7843/touchpad_lld_config.h
+++ b/drivers/touchpad/ADS7843/touchpad_lld_config.h
@@ -29,7 +29,7 @@
#ifndef _TOUCHPAD_LLD_CONFIG_H
#define _TOUCHPAD_LLD_CONFIG_H
-#if HAL_USE_TOUCHPAD || defined(__DOXYGEN__)
+#if GFX_USE_TOUCHPAD || defined(__DOXYGEN__)
/*===========================================================================*/
/* Driver hardware support. */
@@ -38,7 +38,7 @@
#define TOUCHPAD_HAS_IRQ TRUE
#define TOUCHPAD_HAS_PRESSURE FALSE
-#endif /* HAL_USE_TOUCHPAD */
+#endif /* GFX_USE_TOUCHPAD */
#endif /* _TOUCHPAD_LLD_CONFIG_H */
/** @} */
diff --git a/drivers/touchpad/XPT2046/readme.txt b/drivers/touchpad/XPT2046/readme.txt
index f59dc893..baccebe8 100644
--- a/drivers/touchpad/XPT2046/readme.txt
+++ b/drivers/touchpad/XPT2046/readme.txt
@@ -1,7 +1,7 @@
To use this driver:
1. Add in your halconf.h:
- a) #define HAL_USE_TOUCHPAD TRUE
+ a) #define GFX_USE_TOUCHPAD TRUE
2. To your makefile add the following lines:
include $(GFXLIB)/drivers/touchpad/XPT2046/touchpad_lld.mk
diff --git a/drivers/touchpad/XPT2046/touchpad_lld.c b/drivers/touchpad/XPT2046/touchpad_lld.c
index eeaf11b5..4640ca8d 100644
--- a/drivers/touchpad/XPT2046/touchpad_lld.c
+++ b/drivers/touchpad/XPT2046/touchpad_lld.c
@@ -30,7 +30,7 @@
#include "hal.h"
#include "touchpad.h"
-#if HAL_USE_TOUCHPAD || defined(__DOXYGEN__)
+#if GFX_USE_TOUCHPAD || defined(__DOXYGEN__)
/*===========================================================================*/
/* Driver local definitions. */
@@ -234,6 +234,6 @@ uint16_t tp_lld_read_y(void) {
}
#endif
-#endif /* HAL_USE_TOUCHPAD */
+#endif /* GFX_USE_TOUCHPAD */
/** @} */
diff --git a/drivers/touchpad/XPT2046/touchpad_lld_config.h b/drivers/touchpad/XPT2046/touchpad_lld_config.h
index 28038ff0..801f5d18 100644
--- a/drivers/touchpad/XPT2046/touchpad_lld_config.h
+++ b/drivers/touchpad/XPT2046/touchpad_lld_config.h
@@ -29,7 +29,7 @@
#ifndef _TOUCHPAD_LLD_CONFIG_H
#define _TOUCHPAD_LLD_CONFIG_H
-#if HAL_USE_TOUCHPAD || defined(__DOXYGEN__)
+#if GFX_USE_TOUCHPAD || defined(__DOXYGEN__)
/*===========================================================================*/
/* Driver hardware support. */
@@ -38,7 +38,7 @@
#define TOUCHPAD_HAS_IRQ TRUE
#define TOUCHPAD_HAS_PRESSURE TRUE
-#endif /* HAL_USE_TOUCHPAD */
+#endif /* GFX_USE_TOUCHPAD */
#endif /* _TOUCHPAD_LLD_CONFIG_H */
/** @} */
diff --git a/include/console.h b/include/console.h
index 1874c57d..9891ea56 100644
--- a/include/console.h
+++ b/include/console.h
@@ -21,11 +21,11 @@
#ifndef CONSOLE_H
#define CONSOLE_H
-#ifndef GDISP_NEED_CONSOLE
- #define GDISP_NEED_CONSOLE FALSE
+#ifndef GFX_USE_CONSOLE
+ #define GFX_USE_CONSOLE FALSE
#endif
-#if GDISP_NEED_CONSOLE
+#if GFX_USE_CONSOLE
#include "gdisp.h"
@@ -78,7 +78,7 @@ msg_t gfxConsoleWrite(GConsole *console, const uint8_t *bp, size_t n);
}
#endif
-#endif /* GDISP_NEED_CONSOLE */
+#endif /* GFX_USE_CONSOLE */
#endif /* CONSOLE_H */
diff --git a/include/gdisp.h b/include/gdisp.h
index bb73677c..7b07bc2e 100644
--- a/include/gdisp.h
+++ b/include/gdisp.h
@@ -27,7 +27,7 @@
#ifndef _GDISP_H
#define _GDISP_H
-#if HAL_USE_GDISP || defined(__DOXYGEN__)
+#if GFX_USE_GDISP || defined(__DOXYGEN__)
/*===========================================================================*/
/* Driver constants. */
@@ -286,7 +286,7 @@ void gdispDrawBox(coord_t x, coord_t y, coord_t cx, coord_t cy, color_t color);
}
#endif
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
#endif /* _GDISP_H */
/** @} */
diff --git a/include/gdisp_emulation.c b/include/gdisp_emulation.c
index c81bd305..34596b61 100644
--- a/include/gdisp_emulation.c
+++ b/include/gdisp_emulation.c
@@ -31,7 +31,7 @@
#ifndef GDISP_EMULATION_C
#define GDISP_EMULATION_C
-#if HAL_USE_GDISP || defined(__DOXYGEN__)
+#if GFX_USE_GDISP || defined(__DOXYGEN__)
#ifndef GDISP_LLD_NO_STRUCT
static struct GDISPDriver {
@@ -683,5 +683,5 @@ void *GDISP_LLD(query)(unsigned what) {
}
#endif
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
#endif /* GDISP_EMULATION_C */
diff --git a/include/gdisp_fonts.h b/include/gdisp_fonts.h
index 89359f18..a63e8909 100644
--- a/include/gdisp_fonts.h
+++ b/include/gdisp_fonts.h
@@ -30,7 +30,7 @@
#ifndef _GDISP_FONTS_H
#define _GDISP_FONTS_H
-/* Don't test against HAL_USE_GDISP as we may want to use this in other non-GDISP utilities. */
+/* Don't test against GFX_USE_GDISP as we may want to use this in other non-GDISP utilities. */
/**
* @brief The maximum height of a font.
diff --git a/include/gdisp_lld.h b/include/gdisp_lld.h
index 376181fc..6dd826d9 100644
--- a/include/gdisp_lld.h
+++ b/include/gdisp_lld.h
@@ -28,7 +28,7 @@
#ifndef _GDISP_LLD_H
#define _GDISP_LLD_H
-#if HAL_USE_GDISP || defined(__DOXYGEN__)
+#if GFX_USE_GDISP || defined(__DOXYGEN__)
/*===========================================================================*/
/* Low level driver configuration needs */
@@ -644,7 +644,7 @@ extern "C" {
}
#endif
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
#endif /* _GDISP_LLD_H */
/** @} */
diff --git a/include/gdisp_lld_msgs.h b/include/gdisp_lld_msgs.h
index d45f45e4..a5cb885b 100644
--- a/include/gdisp_lld_msgs.h
+++ b/include/gdisp_lld_msgs.h
@@ -29,7 +29,7 @@
#define _GDISP_LLD_MSGS_H
/* This file describes the message API for gdisp_lld */
-#if HAL_USE_GDISP && GDISP_NEED_MSGAPI
+#if GFX_USE_GDISP && GDISP_NEED_MSGAPI
typedef enum gdisp_msgaction {
GDISP_LLD_MSG_NOP,
@@ -188,6 +188,6 @@ typedef union gdisp_lld_msg {
} query;
} gdisp_lld_msg_t;
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
#endif /* _GDISP_LLD_MSGS_H */
/** @} */
diff --git a/include/touchpad.h b/include/touchpad.h
index 2fcb0c16..1db5ac98 100644
--- a/include/touchpad.h
+++ b/include/touchpad.h
@@ -28,7 +28,7 @@
#ifndef _TOUCHPAD_H
#define _TOUCHPAD_H
-#if HAL_USE_TOUCHPAD || defined(__DOXYGEN__)
+#if GFX_USE_TOUCHPAD || defined(__DOXYGEN__)
/**
* @brief specifies how many conversions are made for a readout.
@@ -87,7 +87,7 @@ void tpCalibrate(void);
}
#endif
-#endif /* HAL_USE_TOUCHPAD */
+#endif /* GFX_USE_TOUCHPAD */
#endif /* _TOUCHPAD_H */
/** @} */
diff --git a/include/touchpad_lld.h b/include/touchpad_lld.h
index d207eb6c..c73591c7 100644
--- a/include/touchpad_lld.h
+++ b/include/touchpad_lld.h
@@ -29,7 +29,7 @@
#ifndef _TOUCHPAD_LLD_H
#define _TOUCHPAD_LLD_H
-#if HAL_USE_TOUCHPAD || defined(__DOXYGEN__)
+#if GFX_USE_TOUCHPAD || defined(__DOXYGEN__)
/*===========================================================================*/
/* Include the low level driver configuration information */
@@ -144,7 +144,7 @@ extern "C" {
}
#endif
-#endif /* HAL_USE_TOUCHPAD */
+#endif /* GFX_USE_TOUCHPAD */
#endif /* _TOUCHPAD_LLD_H */
/** @} */
diff --git a/src/console.c b/src/console.c
index d1ccdc17..064b6a05 100644
--- a/src/console.c
+++ b/src/console.c
@@ -22,7 +22,7 @@
#include "hal.h"
#include "console.h"
-#if GDISP_NEED_CONSOLE
+#if GFX_USE_CONSOLE
/*
* Interface implementation. The interface is write only
diff --git a/src/gdisp.c b/src/gdisp.c
index e8fb699e..364df1cd 100644
--- a/src/gdisp.c
+++ b/src/gdisp.c
@@ -33,7 +33,7 @@
#ifndef _GDISP_C
#define _GDISP_C
-#if HAL_USE_GDISP || defined(__DOXYGEN__)
+#if GFX_USE_GDISP || defined(__DOXYGEN__)
#ifdef GDISP_NEED_TEXT
#include "gdisp_fonts.h"
@@ -1118,7 +1118,7 @@ void gdispDrawBox(coord_t x, coord_t y, coord_t cx, coord_t cy, color_t color) {
}
#endif
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
#endif /* _GDISP_C */
/** @} */
diff --git a/src/gdisp_fonts.c b/src/gdisp_fonts.c
index 394223fa..a58c538d 100644
--- a/src/gdisp_fonts.c
+++ b/src/gdisp_fonts.c
@@ -24,7 +24,7 @@
#include "hal.h"
#include "gdisp.h"
-#if HAL_USE_GDISP || defined(__DOXYGEN__)
+#if GFX_USE_GDISP || defined(__DOXYGEN__)
#if GDISP_NEED_TEXT
@@ -652,4 +652,4 @@
#endif /* GDISP_NEED_TEXT */
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
diff --git a/src/touchpad.c b/src/touchpad.c
index dc1aaf74..0718e484 100644
--- a/src/touchpad.c
+++ b/src/touchpad.c
@@ -30,7 +30,7 @@
#include "gdisp.h"
#include "touchpad.h"
-#if HAL_USE_TOUCHPAD || defined(__DOXYGEN__)
+#if GFX_USE_TOUCHPAD || defined(__DOXYGEN__)
#if TOUCHPAD_STORE_CALIBRATION
extern void lld_tpWriteCalibration(struct cal_t cal);
@@ -265,6 +265,6 @@ void tpCalibrate(void) {
}
#endif
-#endif /* HAL_USE_TOUCHPAD */
+#endif /* GFX_USE_TOUCHPAD */
/** @} */
diff --git a/templates/gdispXXXXX/gdisp_lld.c b/templates/gdispXXXXX/gdisp_lld.c
index da835d86..5aa10f2d 100644
--- a/templates/gdispXXXXX/gdisp_lld.c
+++ b/templates/gdispXXXXX/gdisp_lld.c
@@ -30,7 +30,7 @@
#include "hal.h"
#include "gdisp.h"
-#if HAL_USE_GDISP || defined(__DOXYGEN__)
+#if GFX_USE_GDISP || defined(__DOXYGEN__)
/* Include the emulation code for things we don't support */
#include "gdisp_emulation.c"
@@ -554,5 +554,5 @@ void *GDISP_LLD(query)(unsigned what) {
}
#endif
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
/** @} */
diff --git a/templates/gdispXXXXX/gdisp_lld_config.h b/templates/gdispXXXXX/gdisp_lld_config.h
index 698238c8..331d94ce 100644
--- a/templates/gdispXXXXX/gdisp_lld_config.h
+++ b/templates/gdispXXXXX/gdisp_lld_config.h
@@ -29,7 +29,7 @@
#ifndef _GDISP_LLD_CONFIG_H
#define _GDISP_LLD_CONFIG_H
-#if HAL_USE_GDISP || defined(__DOXYGEN__)
+#if GFX_USE_GDISP || defined(__DOXYGEN__)
/*===========================================================================*/
/* Driver hardware support. */
@@ -63,7 +63,7 @@
#define GDISP_PACKED_PIXELS FALSE
#define GDISP_PACKED_LINES FALSE
-#endif /* HAL_USE_GDISP */
+#endif /* GFX_USE_GDISP */
#endif /* _GDISP_LLD_CONFIG_H */
/** @} */
diff --git a/templates/gdispXXXXX/readme.txt b/templates/gdispXXXXX/readme.txt
index 14d02bba..f173764d 100644
--- a/templates/gdispXXXXX/readme.txt
+++ b/templates/gdispXXXXX/readme.txt
@@ -14,7 +14,7 @@ To use this driver template
To use this driver:
1. Add in your halconf.h:
- a) #define HAL_USE_GDISP TRUE
+ a) #define GFX_USE_GDISP TRUE
b) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
c) One (only) of:
#define GDISP_USE_GPIO
diff --git a/templates/touchpadXXXXX/touchpad_lld.c b/templates/touchpadXXXXX/touchpad_lld.c
index 9a1e8dad..2fec6ade 100644
--- a/templates/touchpadXXXXX/touchpad_lld.c
+++ b/templates/touchpadXXXXX/touchpad_lld.c
@@ -30,7 +30,7 @@
#include "hal.h"
#include "touchpad.h"
-#if HAL_USE_TOUCHPAD || defined(__DOXYGEN__)
+#if GFX_USE_TOUCHPAD || defined(__DOXYGEN__)
/*===========================================================================*/
/* Driver local definitions. */
@@ -140,6 +140,6 @@ uint16_t tp_lld_read_y(void) {
}
#endif
-#endif /* HAL_USE_TOUCHPAD */
+#endif /* GFX_USE_TOUCHPAD */
/** @} */
diff --git a/templates/touchpadXXXXX/touchpad_lld_config.h b/templates/touchpadXXXXX/touchpad_lld_config.h
index fba82782..356ec726 100644
--- a/templates/touchpadXXXXX/touchpad_lld_config.h
+++ b/templates/touchpadXXXXX/touchpad_lld_config.h
@@ -29,7 +29,7 @@
#ifndef _TOUCHPAD_LLD_CONFIG_H
#define _TOUCHPAD_LLD_CONFIG_H
-#if HAL_USE_TOUCHPAD || defined(__DOXYGEN__)
+#if GFX_USE_TOUCHPAD || defined(__DOXYGEN__)
/*===========================================================================*/
/* Driver hardware support. */
@@ -38,7 +38,7 @@
#define TOUCHPAD_HAS_IRQ TRUE
#define TOUCHPAD_HAS_PRESSURE TRUE
-#endif /* HAL_USE_TOUCHPAD */
+#endif /* GFX_USE_TOUCHPAD */
#endif /* _TOUCHPAD_LLD_CONFIG_H */
/** @} */