aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/gfx.h9
-rw-r--r--releases.txt1
2 files changed, 10 insertions, 0 deletions
diff --git a/include/gfx.h b/include/gfx.h
index b6107de6..c4c670f8 100644
--- a/include/gfx.h
+++ b/include/gfx.h
@@ -46,6 +46,15 @@
#define GFX_USE_GDISP FALSE
#endif
/**
+ * @brief GFX Text Display Basic API
+ * @details Defaults to FALSE
+ * @note Also add the specific hardware driver to your makefile.
+ * Eg. include $(GFXLIB)/drivers/tdisp/HD44780/tdisp_lld.mk
+ */
+ #ifndef GFX_USE_TDISP
+ #define GFX_USE_TDISP FALSE
+ #endif
+ /**
* @brief GFX Graphics Windowing API
* @details Defaults to FALSE
* @details Extends the GDISP API to add the concept of graphic windows.
diff --git a/releases.txt b/releases.txt
index 467ffeb1..7ed1a17a 100644
--- a/releases.txt
+++ b/releases.txt
@@ -24,6 +24,7 @@ DEPRECATE: touchscreen deprecated - replaced with ginput functionality
FEATURE: Numerous documentation improvements
FEATURE: Added a number of module demo and test programs
DEPRECATE: Remove of XPT2046 since full compatibility with ADS7843
+FEATURE: Introduced TDISP module
*** changes after 1.3 ***