aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base/Embest-STM32-DMSTF4BB/example_chibios_3.x/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'boards/base/Embest-STM32-DMSTF4BB/example_chibios_3.x/Makefile')
-rw-r--r--boards/base/Embest-STM32-DMSTF4BB/example_chibios_3.x/Makefile60
1 files changed, 60 insertions, 0 deletions
diff --git a/boards/base/Embest-STM32-DMSTF4BB/example_chibios_3.x/Makefile b/boards/base/Embest-STM32-DMSTF4BB/example_chibios_3.x/Makefile
new file mode 100644
index 00000000..16611673
--- /dev/null
+++ b/boards/base/Embest-STM32-DMSTF4BB/example_chibios_3.x/Makefile
@@ -0,0 +1,60 @@
+# Possible Targets: all clean Debug cleanDebug Release cleanRelease
+
+##############################################################################################
+# Settings
+#
+
+# General settings
+ # See $(GFXLIB)/tools/gmake_scripts/readme.txt for the list of variables
+ OPT_OS = chibios
+ OPT_THUMB = yes
+ OPT_LINK_OPTIMIZE = yes
+ OPT_CPU = stm32m4
+
+# uGFX settings
+ # See $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk for the list of variables
+ GFXLIB = ../../resources/ugfx
+ GFXBOARD = STM32F429i-Discovery
+ GFXDEMO = modules/gdisp/basics
+
+# ChibiOS settings
+ifeq ($(OPT_OS),chibios)
+ # See $(GFXLIB)/tools/gmake_scripts/os_chibios_x.mk for the list of variables
+ CHIBIOS = ../../resources/chibios_3.0.1
+ CHIBIOS_VERSION = 3
+ CHIBIOS_BOARD = ST_STM32F429I_DISCOVERY
+ CHIBIOS_CPUCLASS = ARMCMx
+ CHIBIOS_PLATFORM = STM32
+ CHIBIOS_DEVICE_FAMILY = STM32F4xx
+ CHIBIOS_STARTUP = startup_stm32f4xx
+ CHIBIOS_PORT = v7m
+ CHIBIOS_LDSCRIPT = STM32F429xI.ld
+endif
+
+##############################################################################################
+# Set these for your project
+#
+
+ARCH = arm-none-eabi-
+SRCFLAGS = -ggdb -O0
+CFLAGS =
+CXXFLAGS = -fno-rtti
+ASFLAGS =
+LDFLAGS =
+
+SRC =
+OBJS =
+DEFS =
+LIBS =
+INCPATH =
+LIBPATH =
+LDSCRIPT =
+
+##############################################################################################
+# These should be at the end
+#
+
+include $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk
+include $(GFXLIB)/tools/gmake_scripts/os_$(OPT_OS).mk
+include $(GFXLIB)/tools/gmake_scripts/compiler_gcc.mk
+# *** EOF ***