aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base/Linux-Framebuffer/example/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'boards/base/Linux-Framebuffer/example/Makefile')
-rw-r--r--boards/base/Linux-Framebuffer/example/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/boards/base/Linux-Framebuffer/example/Makefile b/boards/base/Linux-Framebuffer/example/Makefile
index 76b2022a..fb0c1b7a 100644
--- a/boards/base/Linux-Framebuffer/example/Makefile
+++ b/boards/base/Linux-Framebuffer/example/Makefile
@@ -13,6 +13,8 @@
OPT_LINK_OPTIMIZE = yes
OPT_NONSTANDARD_FLAGS = no
OPT_OS = linux
+ # Change this next setting (or add the explicit compiler flags) if you are not compiling for x86 linux
+ OPT_CPU = x86
# uGFX settings
# See $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk for the list of variables
@@ -30,13 +32,13 @@
ARCH =
SRCFLAGS = -ggdb -O0
-SRCFLAGS+= -m32
CFLAGS =
CXXFLAGS =
ASFLAGS =
LDFLAGS =
SRC =
+OBJS =
DEFS =
LIBS =
INCPATH =