aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base/STM32F429i-Discovery/example_chibios_2.x/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'boards/base/STM32F429i-Discovery/example_chibios_2.x/Makefile')
-rw-r--r--boards/base/STM32F429i-Discovery/example_chibios_2.x/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/boards/base/STM32F429i-Discovery/example_chibios_2.x/Makefile b/boards/base/STM32F429i-Discovery/example_chibios_2.x/Makefile
index 2512c62a..755b8cf9 100644
--- a/boards/base/STM32F429i-Discovery/example_chibios_2.x/Makefile
+++ b/boards/base/STM32F429i-Discovery/example_chibios_2.x/Makefile
@@ -19,12 +19,13 @@
# ChibiOS settings
ifeq ($(OPT_OS),chibios)
- # See $(GFXLIB)/tools/gmake_scripts/os_chibios.mk for the list of variables
- CHIBIOS = ../ChibiOS
- CHIBIOS_BOARD = ST_STM32F429I_DISCOVERY
- CHIBIOS_PLATFORM = STM32F4xx
- CHIBIOS_PORT = GCC/ARMCMx/STM32F4xx
- CHIBIOS_LDSCRIPT = STM32F407xG.ld
+ # See $(GFXLIB)/tools/gmake_scripts/os_chibios_2.mk for the list of variables
+ CHIBIOS = ../ChibiOS
+ CHIBIOS_VERSION = 2
+ CHIBIOS_BOARD = ST_STM32F429I_DISCOVERY
+ CHIBIOS_PLATFORM = STM32F4xx
+ CHIBIOS_PORT = GCC/ARMCMx/STM32F4xx
+ CHIBIOS_LDSCRIPT = STM32F429xI.ld
endif
##############################################################################################