aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base/STM32F429i-Discovery/example_chibios_3.x/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'boards/base/STM32F429i-Discovery/example_chibios_3.x/Makefile')
-rw-r--r--boards/base/STM32F429i-Discovery/example_chibios_3.x/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/boards/base/STM32F429i-Discovery/example_chibios_3.x/Makefile b/boards/base/STM32F429i-Discovery/example_chibios_3.x/Makefile
index 217d1d24..16611673 100644
--- a/boards/base/STM32F429i-Discovery/example_chibios_3.x/Makefile
+++ b/boards/base/STM32F429i-Discovery/example_chibios_3.x/Makefile
@@ -13,20 +13,22 @@
# uGFX settings
# See $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk for the list of variables
- GFXLIB = ../uGFX
+ GFXLIB = ../../resources/ugfx
GFXBOARD = STM32F429i-Discovery
GFXDEMO = modules/gdisp/basics
# ChibiOS settings
ifeq ($(OPT_OS),chibios)
- # See $(GFXLIB)/tools/gmake_scripts/os_chibios.mk for the list of variables
- CHIBIOS = ../ChibiOS3
- CHIBIOS_VERSION = 3
- CHIBIOS_BOARD = ST_STM32F429I_DISCOVERY
- CHIBIOS_CPUCLASS = ARMCMx
- CHIBIOS_PLATFORM = STM32/STM32F4xx
- CHIBIOS_PORT = stm32f4xx
- CHIBIOS_LDSCRIPT = STM32F407xG.ld
+ # See $(GFXLIB)/tools/gmake_scripts/os_chibios_x.mk for the list of variables
+ CHIBIOS = ../../resources/chibios_3.0.1
+ CHIBIOS_VERSION = 3
+ CHIBIOS_BOARD = ST_STM32F429I_DISCOVERY
+ CHIBIOS_CPUCLASS = ARMCMx
+ CHIBIOS_PLATFORM = STM32
+ CHIBIOS_DEVICE_FAMILY = STM32F4xx
+ CHIBIOS_STARTUP = startup_stm32f4xx
+ CHIBIOS_PORT = v7m
+ CHIBIOS_LDSCRIPT = STM32F429xI.ld
endif
##############################################################################################