aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base/STM32F429i-Discovery
diff options
context:
space:
mode:
Diffstat (limited to 'boards/base/STM32F429i-Discovery')
-rw-r--r--boards/base/STM32F429i-Discovery/chibios/board.mk2
-rw-r--r--boards/base/STM32F429i-Discovery/chibios/board_STM32LTDC.h2
-rw-r--r--boards/base/STM32F429i-Discovery/chibios/gmouse_lld_STMPE811_board.h14
3 files changed, 9 insertions, 9 deletions
diff --git a/boards/base/STM32F429i-Discovery/chibios/board.mk b/boards/base/STM32F429i-Discovery/chibios/board.mk
index 292cd42e..730bb083 100644
--- a/boards/base/STM32F429i-Discovery/chibios/board.mk
+++ b/boards/base/STM32F429i-Discovery/chibios/board.mk
@@ -2,6 +2,6 @@ GFXINC += $(GFXLIB)/boards/base/STM32F429i-Discovery/chibios
GFXSRC += $(GFXLIB)/boards/base/STM32F429i-Discovery/chibios/stm32f429i_discovery_sdram.c \
$(GFXLIB)/boards/base/STM32F429i-Discovery/chibios/stm32f4xx_fmc.c
-GFXDEFS += -DGFX_USE_OS_CHIBIOS=TRUE
+GFXDEFS += -DGFX_USE_OS_CHIBIOS=GFXON
include $(GFXLIB)/drivers/gdisp/STM32LTDC/driver.mk
include $(GFXLIB)/drivers/ginput/touch/STMPE811/driver.mk
diff --git a/boards/base/STM32F429i-Discovery/chibios/board_STM32LTDC.h b/boards/base/STM32F429i-Discovery/chibios/board_STM32LTDC.h
index a6e41f86..3b8234f5 100644
--- a/boards/base/STM32F429i-Discovery/chibios/board_STM32LTDC.h
+++ b/boards/base/STM32F429i-Discovery/chibios/board_STM32LTDC.h
@@ -23,7 +23,7 @@ static const SPIConfig spi_cfg = {
((1 << 3) & SPI_CR1_BR) | SPI_CR1_SSM | SPI_CR1_SSI | SPI_CR1_MSTR
};
-#define ALLOW_2ND_LAYER TRUE
+#define ALLOW_2ND_LAYER GFXON
static const ltdcConfig driverCfg = {
240, 320,
diff --git a/boards/base/STM32F429i-Discovery/chibios/gmouse_lld_STMPE811_board.h b/boards/base/STM32F429i-Discovery/chibios/gmouse_lld_STMPE811_board.h
index ef3a628f..02abc43d 100644
--- a/boards/base/STM32F429i-Discovery/chibios/gmouse_lld_STMPE811_board.h
+++ b/boards/base/STM32F429i-Discovery/chibios/gmouse_lld_STMPE811_board.h
@@ -20,15 +20,15 @@
#define GMOUSE_STMPE811_BOARD_DATA_SIZE 0
// Options - Leave these commented to make it user configurable in the gfxconf.h
-//#define GMOUSE_STMPE811_READ_PRESSURE FALSE
-//#define GMOUSE_STMPE811_SELF_CALIBRATE FALSE
-//#define GMOUSE_STMPE811_TEST_MODE FALSE
+//#define GMOUSE_STMPE811_READ_PRESSURE GFXOFF
+//#define GMOUSE_STMPE811_SELF_CALIBRATE GFXOFF
+//#define GMOUSE_STMPE811_TEST_MODE GFXOFF
-// Set to FALSE because it does not work properly on this board even though the pin exists.
-#define GMOUSE_STMPE811_GPIO_IRQPIN FALSE
+// Set to GFXOFF because it does not work properly on this board even though the pin exists.
+#define GMOUSE_STMPE811_GPIO_IRQPIN GFXOFF
-// If TRUE this is a really slow CPU and we should always clear the FIFO between reads.
-#define GMOUSE_STMPE811_SLOW_CPU FALSE
+// If GFXON this is a really slow CPU and we should always clear the FIFO between reads.
+#define GMOUSE_STMPE811_SLOW_CPU GFXOFF
// Slave address
#define STMPE811_ADDR 0x41