aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base/Win32/example/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'boards/base/Win32/example/Makefile')
-rw-r--r--boards/base/Win32/example/Makefile67
1 files changed, 26 insertions, 41 deletions
diff --git a/boards/base/Win32/example/Makefile b/boards/base/Win32/example/Makefile
index 502cf1ac..4bf6c603 100644
--- a/boards/base/Win32/example/Makefile
+++ b/boards/base/Win32/example/Makefile
@@ -4,33 +4,39 @@
# Settings
#
-# See $(GFXLIB)/tools/gmake_scripts/readme.txt for the meaning of these variables
-OPT_VERBOSE_COMPILE = no
-OPT_GENERATE_LISTINGS = yes
-OPT_GENERATE_MAP = yes
-OPT_COPY_EXE = no
-OPT_NATIVEOS = win32
-OPT_OS = win32
-
-# See $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk for the meaning of these variables
-GFXLIB = ../uGFX
-GFXBOARD = Win32
-#GFXDRIVERS = multiple/uGFXnet
-GFXDEMO = modules/gdisp/basics
-
-# Win32 - ChibiOS simulator
-ifeq ($(OPT_OS),chibios)
- # Required: Location of the ChibiOS code
- CHIBIOS = ../ChibiOS
+# General settings
+ # See $(GFXLIB)/tools/gmake_scripts/readme.txt for the list of variables
+ OPT_VERBOSE_COMPILE = no
+ OPT_GENERATE_LISTINGS = yes
+ OPT_GENERATE_MAP = yes
+ OPT_COPY_EXE = no
+ OPT_LINK_OPTIMIZE = yes
+ OPT_NONSTANDARD_FLAGS = no
+ # For Win32 this variable can be set to "win32" (native win32 api) or "win32.chibios" (ChibiOS simulator).
+ OPT_OS = win32
+
+# uGFX settings
+ # See $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk for the list of variables
+ GFXLIB = ../uGFX
+ GFXBOARD = Win32
+ #GFXDRIVERS = multiple/uGFXnet
+ GFXDEMO = modules/gdisp/basics
+
+# ChibiOS settings
+ifeq ($(OPT_OS),win32.chibios)
+ # See $(GFXLIB)/tools/gmake_scripts/os_win32.chibios.mk for the list of variables
+ CHIBIOS = ../ChibiOS
endif
+# Win32 settings
+ # See $(GFXLIB)/tools/gmake_scripts/os_win32.mk for the list of variables
##############################################################################################
# Set these for your project
#
ARCH = i686-pc-mingw32-
-SRCFLAGS = -ggdb -O0 -fomit-frame-pointer -Wall -Wextra -Wstrict-prototypes -fverbose-asm
+SRCFLAGS = -ggdb -O0
CFLAGS =
CXXFLAGS =
ASFLAGS =
@@ -43,31 +49,10 @@ INCPATH =
LIBPATH =
##############################################################################################
-# Optional: Win32 - ChibiOS Simulator
-#
-
-ifeq ($(OPT_OS),chibios)
- include $(CHIBIOS)/boards/simulator/board.mk
- include $(CHIBIOS)/os/hal/hal.mk
- include $(CHIBIOS)/os/hal/platforms/Win32/platform.mk
- include $(CHIBIOS)/os/ports/GCC/SIMIA32/port.mk
- include $(CHIBIOS)/os/kernel/kernel.mk
- DEFS += SIMULATOR SHELL_USE_IPRINTF=FALSE
- INCPATH += $(PORTINC) $(KERNINC) $(TESTINC) \
- $(HALINC) $(PLATFORMINC) $(BOARDINC)
- # $(CHIBIOS)/os/various
- SRC += $(PORTSRC) \
- $(KERNSRC) \
- $(TESTSRC) \
- $(HALSRC) \
- $(PLATFORMSRC) \
- $(BOARDSRC)
-endif
-
-##############################################################################################
# These should be at the end
#
include $(GFXLIB)/tools/gmake_scripts/library_ugfx.mk
+include $(GFXLIB)/tools/gmake_scripts/os_$(OPT_OS).mk
include $(GFXLIB)/tools/gmake_scripts/compiler_gcc.mk
# *** EOF ***