aboutsummaryrefslogtreecommitdiffstats
path: root/boards/base
diff options
context:
space:
mode:
Diffstat (limited to 'boards/base')
-rw-r--r--boards/base/eCos-Synthetic-Framebuffer/board.mk5
-rw-r--r--boards/base/eCos-Synthetic-Framebuffer/board_framebuffer.h94
-rw-r--r--boards/base/eCos-Synthetic-Framebuffer/example/Makefile165
-rw-r--r--boards/base/eCos-Synthetic-Framebuffer/example/readme.txt7
-rw-r--r--boards/base/eCos-Synthetic-Framebuffer/readme.txt11
5 files changed, 282 insertions, 0 deletions
diff --git a/boards/base/eCos-Synthetic-Framebuffer/board.mk b/boards/base/eCos-Synthetic-Framebuffer/board.mk
new file mode 100644
index 00000000..d4e9ebe1
--- /dev/null
+++ b/boards/base/eCos-Synthetic-Framebuffer/board.mk
@@ -0,0 +1,5 @@
+GFXINC += $(GFXLIB)/boards/base/eCos-Synthetic-Framebuffer
+GFXSRC +=
+GFXDEFS += -DGFX_USE_OS_ECOS=TRUE
+
+include $(GFXLIB)/drivers/gdisp/framebuffer/driver.mk
diff --git a/boards/base/eCos-Synthetic-Framebuffer/board_framebuffer.h b/boards/base/eCos-Synthetic-Framebuffer/board_framebuffer.h
new file mode 100644
index 00000000..e8e46131
--- /dev/null
+++ b/boards/base/eCos-Synthetic-Framebuffer/board_framebuffer.h
@@ -0,0 +1,94 @@
+/*
+ * This file is subject to the terms of the GFX License. If a copy of
+ * the license was not distributed with this file, you can obtain one at:
+ *
+ * http://ugfx.org/license.html
+ */
+
+/**
+ * Note: this implementation makes a number of design choices...
+ * 1/ We are using the macro definitions for eCos framebuffer driver. If you want to use the
+ * function's instead you could use the g->board variable to store your cyg_fb pointer.
+ * 2/ We assume the initialisation succeeds. It is probably a fatal error if it doesn't.
+ * 3/ We hard-code in this file the pixel format, whether flushing is required and the FRAMEBUF device.
+ * Please adjust them for your hardware.
+ */
+
+// Set this to your frame buffer pixel format.
+#ifndef GDISP_LLD_PIXELFORMAT
+ #define GDISP_LLD_PIXELFORMAT GDISP_PIXELFORMAT_RGB565
+#endif
+
+// Uncomment this if your frame buffer device requires flushing ("Synch" in eCos speak)
+#define GDISP_HARDWARE_FLUSH TRUE
+
+#ifdef GDISP_DRIVER_VMT
+
+ #include <cyg/io/framebuf.h>
+
+ // SET THIS HERE!!!
+ // This must also match the pixel format above
+ #define FRAMEBUF fb0
+
+ static void board_init(GDisplay *g, fbInfo *fbi) {
+ // Initialize the frame buffer device - we assume everything is going to succeed.
+ CYG_FB_ON(FRAMEBUF);
+ #if (CYG_FB_FLAGS0(FRAMEBUF) & CYG_FB_FLAGS0_MUST_BE_ON)
+ CYG_FB_FILL_BLOCK(FRAMEBUF, 0, 0, CYG_FB_WIDTH(FRAMEBUF), CYG_FB_HEIGHT(FRAMEBUF), CYG_FB_MAKE_COLOUR(FRAMEBUF, 0, 0, 0));
+ #endif
+
+ // Set the details of the frame buffer
+ #ifdef CYGHWR_IO_FRAMEBUF_FUNCTIONALITY_VIEWPORT
+ g->g.Width = CYG_FB_VIEWPORT_WIDTH(FRAMEBUF);
+ g->g.Height = CYG_FB_VIEWPORT_HEIGHT(FRAMEBUF);
+ #else
+ g->g.Width = CYG_FB_WIDTH(FRAMEBUF);
+ g->g.Height = CYG_FB_HEIGHT(FRAMEBUF);
+ #endif
+ g->g.Backlight = 100;
+ g->g.Contrast = 50;
+ fbi->linelen = CYG_FB_STRIDE(FRAMEBUF); // bytes per row
+ fbi->pixels = CYG_FB_BASE(FRAMEBUF); // pointer to the memory frame buffer
+ }
+
+ #if GDISP_HARDWARE_FLUSH
+ static void board_flush(GDisplay *g) {
+ (void) g;
+
+ // You might want to replace CYG_FB_UPDATE_NOW with CYG_FB_UPDATE_VERTICAL_RETRACE
+ // if you are not using uGFX's auto flush or timer flush mechanisms and frame synchronisation
+ // is important for your display.
+ CYG_FB_SYNCH(FRAMEBUF, CYG_FB_UPDATE_NOW);
+ }
+ #endif
+
+ #if GDISP_NEED_CONTROL
+ static void board_backlight(GDisplay *g, uint8_t percent) {
+ (void) g;
+ #if (CYG_FB_FLAGS0(FRAMEBUF) & CYG_FB_FLAGS0_BACKLIGHT)
+ cyg_fb_ioctl_backlight backlight;
+ size_t len = sizeof(cyg_fb_ioctl_backlight);
+
+ if (CYG_FB_IOCTL(FRAMEBUF, CYG_FB_IOCTL_BACKLIGHT_GET, &backlight, &len) || !backlight.fbbl_max)
+ return;
+ if (backlight.fbbl_max == 1)
+ backlight.fbbl_current = percent ? 1 : 0;
+ else
+ backlight.fbbl_current = (((uint32_t)percent)*backlight.fbbl_max)/100;
+ CYG_FB_IOCTL(FRAMEBUF, CYG_FB_IOCTL_BACKLIGHT_SET, &backlight, &len);
+ #endif
+ }
+
+ static void board_contrast(GDisplay *g, uint8_t percent) {
+ (void) g;
+ (void) percent;
+ }
+
+ static void board_power(GDisplay *g, powermode_t pwr) {
+ // Not implemented yet.
+ (void) g;
+ (void) pwr;
+ }
+ #endif
+
+#endif /* GDISP_DRIVER_VMT */
diff --git a/boards/base/eCos-Synthetic-Framebuffer/example/Makefile b/boards/base/eCos-Synthetic-Framebuffer/example/Makefile
new file mode 100644
index 00000000..e30e1c92
--- /dev/null
+++ b/boards/base/eCos-Synthetic-Framebuffer/example/Makefile
@@ -0,0 +1,165 @@
+#
+# !!!! Do NOT edit this makefile with an editor which replace tabs by spaces !!!!
+#
+##############################################################################################
+#
+# On command line:
+#
+# make INSTALL_DIR=/path/to/ecos/install all = Create project
+#
+# make clean = Clean project files.
+#
+# To rebuild project do "make clean" and "make all".
+#
+
+##############################################################################################
+# Start of default section
+#
+
+INSTALL_DIR=$$(INSTALL_DIR) # override on make command line
+
+include $(INSTALL_DIR)/include/pkgconf/ecos.mak
+
+CC = $(ECOS_COMMAND_PREFIX)gcc
+AS = $(CC) -x assembler-with-cpp
+CXX = $(CC)
+LD = $(CC)
+CFLAGS = -I$(INSTALL_DIR)/include
+CXXFLAGS = $(CFLAGS) -g
+LDFLAGS = -nostartfiles -L$(INSTALL_DIR)/lib -Ttarget.ld
+
+# List all default C defines here, like -D_DEBUG=1
+DDEFS =
+
+# List all default ASM defines here, like -D_DEBUG=1
+DADEFS =
+
+# List all default directories to look for include files here
+DINCDIR =
+
+# List the default directory to look for the libraries here
+DLIBDIR =
+
+# List all default libraries here
+DLIBS =
+
+#
+# End of default section
+##############################################################################################
+
+##############################################################################################
+# Start of user section
+#
+
+# Define project name here
+PROJECT = ugfx_over_ecos
+
+# Imported source files and paths for uGFX
+GFXLIB = ../ugfx
+
+include ${GFXLIB}/gfx.mk
+include ${GFXLIB}/boards/base/eCos-Synthetic-Framebuffer/board.mk
+
+# Where is our source code - alter these for your project.
+# Either just include the demo makefile or add your own definitions
+include $(GFXLIB)/demos/modules/gdisp/basics/demo.mk
+
+#MYFILES =
+#MYCSRC =
+#MYDEFS =
+
+# List all user C define here, like -D_DEBUG=1
+UDEFS = $(MYDEFS) $(GFXDEFS)
+
+# Define ASM defines here
+UADEFS =
+
+# List C source files here
+SRC = $(GFXSRC) \
+ $(MYCSRC)
+
+# List ASM source files here
+ASRC =
+
+# List all user directories here
+UINCDIR = $(MYFILES) $(GFXINC)
+
+# List the user directory to look for the libraries here
+ULIBDIR =
+
+# List all user libraries here
+ULIBS =
+
+# Define optimisation level here
+OPT = -ggdb -O0 -fomit-frame-pointer
+
+#
+# End of user defines
+##############################################################################################
+
+INCDIR = $(patsubst %,-I%,$(DINCDIR) $(UINCDIR))
+LIBDIR = $(patsubst %,-L%,$(DLIBDIR) $(ULIBDIR))
+DEFS = $(DDEFS) $(UDEFS)
+ADEFS = $(DADEFS) $(UADEFS)
+OBJS = $(ASRC:.s=.o) $(SRC:.c=.o)
+LIBS = $(DLIBS) $(ULIBS)
+
+ASFLAGS = -Wa,-amhls=$(<:.s=.lst) $(ADEFS)
+CPFLAGS = $(OPT) -Wall -Wextra -Wstrict-prototypes -fverbose-asm $(DEFS)
+
+ifeq ($(HOST_OSX),yes)
+ ifeq ($(OSX_SDK),)
+ OSX_SDK = /Developer/SDKs/MacOSX10.7.sdk
+ endif
+ ifeq ($(OSX_ARCH),)
+ OSX_ARCH = -mmacosx-version-min=10.3 -arch i386
+ endif
+
+ CPFLAGS += -isysroot $(OSX_SDK) $(OSX_ARCH)
+ LDFLAGS = -Wl -Map=$(PROJECT).map,-syslibroot,$(OSX_SDK),$(LIBDIR)
+ LIBS += $(OSX_ARCH)
+else
+ # Linux, or other
+ CPFLAGS += -m32 -Wa,-alms=$(<:.c=.lst) -I$(INSTALL_DIR)/include
+ LDFLAGS = -g -nostdlib -m32 -Wl,-Map=$(PROJECT).map,--cref,--no-warn-mismatch $(LIBDIR) -nostartfiles -L$(INSTALL_DIR)/lib -Ttarget.ld
+endif
+
+# Generate dependency information
+CPFLAGS += -MD -MP -MF .dep/$(@F).d
+
+#
+# makefile rules
+#
+
+all: $(OBJS) $(PROJECT)
+
+%.o : %.c
+ $(CC) -c $(CPFLAGS) -I . $(INCDIR) $< -o $@
+
+%.o : %.s
+ $(AS) -c $(ASFLAGS) $< -o $@
+
+$(PROJECT): $(OBJS)
+ $(CC) $(OBJS) $(LDFLAGS) $(LIBS) -o $@
+
+gcov:
+ -mkdir gcov
+ $(COV) -u $(subst /,\,$(SRC))
+ -mv *.gcov ./gcov
+
+clean:
+ -rm -f $(OBJS)
+ -rm -f $(PROJECT)
+ -rm -f $(PROJECT).map
+ -rm -f $(SRC:.c=.c.bak)
+ -rm -f $(SRC:.c=.lst)
+ -rm -f $(ASRC:.s=.s.bak)
+ -rm -f $(ASRC:.s=.lst)
+ -rm -fR .dep
+
+#
+# Include the dependency files, should be the last of the makefile
+#
+-include $(shell mkdir .dep 2>/dev/null) $(wildcard .dep/*)
+
+# *** EOF ***
diff --git a/boards/base/eCos-Synthetic-Framebuffer/example/readme.txt b/boards/base/eCos-Synthetic-Framebuffer/example/readme.txt
new file mode 100644
index 00000000..ca841f5b
--- /dev/null
+++ b/boards/base/eCos-Synthetic-Framebuffer/example/readme.txt
@@ -0,0 +1,7 @@
+Copy these files into your own project directory and alter them to suite.
+
+Notes:
+
+1/ Look at the MYFILES definition and the MYCSRC definition.
+2/ To run please install eCos synthetic framebuffer according to the documentation.
+3/ Call application ./ugfx_over_ecos -io \ No newline at end of file
diff --git a/boards/base/eCos-Synthetic-Framebuffer/readme.txt b/boards/base/eCos-Synthetic-Framebuffer/readme.txt
new file mode 100644
index 00000000..6bb1c32b
--- /dev/null
+++ b/boards/base/eCos-Synthetic-Framebuffer/readme.txt
@@ -0,0 +1,11 @@
+This directory contains the interface for eCos using a synthetic framebuffer display.
+
+
+
+On this board uGFX currently supports:
+
+ - GDISP via the framebuffer driver
+
+
+
+There is an example Makefile and project in the examples directory.