aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/gdisp/Fb24bpp
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/gdisp/Fb24bpp')
-rw-r--r--drivers/gdisp/Fb24bpp/board_fb24bpp_template.h2
-rw-r--r--drivers/gdisp/Fb24bpp/gdisp_lld_config.h6
-rw-r--r--drivers/gdisp/Fb24bpp/readme.txt2
3 files changed, 5 insertions, 5 deletions
diff --git a/drivers/gdisp/Fb24bpp/board_fb24bpp_template.h b/drivers/gdisp/Fb24bpp/board_fb24bpp_template.h
index a8c669c9..ec129abe 100644
--- a/drivers/gdisp/Fb24bpp/board_fb24bpp_template.h
+++ b/drivers/gdisp/Fb24bpp/board_fb24bpp_template.h
@@ -11,7 +11,7 @@
#endif
// Uncomment this if your frame buffer device requires flushing
-//#define GDISP_HARDWARE_FLUSH TRUE
+//#define GDISP_HARDWARE_FLUSH GFXON
#ifdef GDISP_DRIVER_VMT
diff --git a/drivers/gdisp/Fb24bpp/gdisp_lld_config.h b/drivers/gdisp/Fb24bpp/gdisp_lld_config.h
index 40798ea9..f6eed742 100644
--- a/drivers/gdisp/Fb24bpp/gdisp_lld_config.h
+++ b/drivers/gdisp/Fb24bpp/gdisp_lld_config.h
@@ -14,9 +14,9 @@
/* Driver hardware support. */
/*===========================================================================*/
-#define GDISP_HARDWARE_DRAWPIXEL TRUE
-#define GDISP_HARDWARE_PIXELREAD TRUE
-#define GDISP_HARDWARE_CONTROL TRUE
+#define GDISP_HARDWARE_DRAWPIXEL GFXON
+#define GDISP_HARDWARE_PIXELREAD GFXON
+#define GDISP_HARDWARE_CONTROL GFXON
// Any other support comes from the board file
#include "board_fb24bpp.h"
diff --git a/drivers/gdisp/Fb24bpp/readme.txt b/drivers/gdisp/Fb24bpp/readme.txt
index 83e7f56b..9c738444 100644
--- a/drivers/gdisp/Fb24bpp/readme.txt
+++ b/drivers/gdisp/Fb24bpp/readme.txt
@@ -1,7 +1,7 @@
To use this driver:
1. Add in your gfxconf.h:
- a) #define GFX_USE_GDISP TRUE
+ a) #define GFX_USE_GDISP GFXON
2. To your makefile add the following lines:
include $(GFXLIB)/gfx.mk