aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/gdisp/gdispNokia6610/readme.txt
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/gdisp/gdispNokia6610/readme.txt')
-rw-r--r--drivers/gdisp/gdispNokia6610/readme.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/drivers/gdisp/gdispNokia6610/readme.txt b/drivers/gdisp/gdispNokia6610/readme.txt
new file mode 100644
index 00000000..facb400f
--- /dev/null
+++ b/drivers/gdisp/gdispNokia6610/readme.txt
@@ -0,0 +1,17 @@
+To use this driver:
+
+1. Add in your halconf.h:
+ a) #define HAL_USE_GDISP TRUE
+ b) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
+ c) One (only) of:
+ #define LCD_USE_GE8 /* The Epson controller */
+ #define LCD_USE_GE12 /* The Philips controller */
+ d) If you are not using a known board then create a gdisp_lld_board.h file
+ and ensure it is on your include path.
+ Use the gdisp_lld_board_example.h file as a basis.
+ Currently known boards are:
+ Olimex SAM7-EX256
+
+2. To your makefile add the following lines:
+ include $(CHIBIOS)/os/halext/halext.mk
+ include $(CHIBIOS)/os/halext/drivers/gdispXXXXX/gdisp_lld.mk