aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/ginput/touch
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/ginput/touch')
-rw-r--r--drivers/ginput/touch/ADS7843/driver.mk1
-rw-r--r--drivers/ginput/touch/ADS7843/gmouse_lld_ADS7843.c2
-rw-r--r--drivers/ginput/touch/FT5x06/driver.mk1
-rw-r--r--drivers/ginput/touch/FT5x06/gmouse_lld_FT5x06.c4
-rw-r--r--drivers/ginput/touch/MAX11802/driver.mk1
-rw-r--r--drivers/ginput/touch/MAX11802/gmouse_lld_MAX11802.c4
-rw-r--r--drivers/ginput/touch/MCU/driver.mk1
-rw-r--r--drivers/ginput/touch/MCU/gmouse_lld_MCU.c2
-rw-r--r--drivers/ginput/touch/STMPE610/driver.mk1
-rw-r--r--drivers/ginput/touch/STMPE610/gmouse_lld_STMPE610.c4
-rw-r--r--drivers/ginput/touch/STMPE811/driver.mk1
-rw-r--r--drivers/ginput/touch/STMPE811/gmouse_lld_STMPE811.c4
12 files changed, 10 insertions, 16 deletions
diff --git a/drivers/ginput/touch/ADS7843/driver.mk b/drivers/ginput/touch/ADS7843/driver.mk
index 1a0eaf8e..7d2e4681 100644
--- a/drivers/ginput/touch/ADS7843/driver.mk
+++ b/drivers/ginput/touch/ADS7843/driver.mk
@@ -1,2 +1 @@
-# List the required driver.
GFXSRC += $(GFXLIB)/drivers/ginput/touch/ADS7843/gmouse_lld_ADS7843.c
diff --git a/drivers/ginput/touch/ADS7843/gmouse_lld_ADS7843.c b/drivers/ginput/touch/ADS7843/gmouse_lld_ADS7843.c
index e9492f55..d5412ad2 100644
--- a/drivers/ginput/touch/ADS7843/gmouse_lld_ADS7843.c
+++ b/drivers/ginput/touch/ADS7843/gmouse_lld_ADS7843.c
@@ -10,7 +10,7 @@
#if (GFX_USE_GINPUT && GINPUT_NEED_MOUSE)
#define GMOUSE_DRIVER_VMT GMOUSEVMT_ADS7843
-#include "src/ginput/ginput_driver_mouse.h"
+#include "../../../../src/ginput/ginput_driver_mouse.h"
// Get the hardware interface
#include "gmouse_lld_ADS7843_board.h"
diff --git a/drivers/ginput/touch/FT5x06/driver.mk b/drivers/ginput/touch/FT5x06/driver.mk
index 741464e8..fc227e8b 100644
--- a/drivers/ginput/touch/FT5x06/driver.mk
+++ b/drivers/ginput/touch/FT5x06/driver.mk
@@ -1,2 +1 @@
-# List the required driver.
GFXSRC += $(GFXLIB)/drivers/ginput/touch/FT5x06/gmouse_lld_FT5x06.c
diff --git a/drivers/ginput/touch/FT5x06/gmouse_lld_FT5x06.c b/drivers/ginput/touch/FT5x06/gmouse_lld_FT5x06.c
index da7c46ed..dbd5981c 100644
--- a/drivers/ginput/touch/FT5x06/gmouse_lld_FT5x06.c
+++ b/drivers/ginput/touch/FT5x06/gmouse_lld_FT5x06.c
@@ -10,13 +10,13 @@
#if GFX_USE_GINPUT && GINPUT_NEED_MOUSE
#define GMOUSE_DRIVER_VMT GMOUSEVMT_FT5x06
-#include "src/ginput/ginput_driver_mouse.h"
+#include "../../../../src/ginput/ginput_driver_mouse.h"
// Get the hardware interface
#include "gmouse_lld_FT5x06_board.h"
// Hardware definitions
-#include "drivers/ginput/touch/FT5x06/ft5x06.h"
+#include "ft5x06.h"
static bool_t MouseInit(GMouse* m, unsigned driverinstance) {
if (!init_board(m, driverinstance))
diff --git a/drivers/ginput/touch/MAX11802/driver.mk b/drivers/ginput/touch/MAX11802/driver.mk
index 246e48b3..0df8cf06 100644
--- a/drivers/ginput/touch/MAX11802/driver.mk
+++ b/drivers/ginput/touch/MAX11802/driver.mk
@@ -1,2 +1 @@
-# List the required driver.
GFXSRC += $(GFXLIB)/drivers/ginput/touch/MAX11802/gmouse_lld_MAX11802.c
diff --git a/drivers/ginput/touch/MAX11802/gmouse_lld_MAX11802.c b/drivers/ginput/touch/MAX11802/gmouse_lld_MAX11802.c
index 713b9aad..8976cceb 100644
--- a/drivers/ginput/touch/MAX11802/gmouse_lld_MAX11802.c
+++ b/drivers/ginput/touch/MAX11802/gmouse_lld_MAX11802.c
@@ -10,10 +10,10 @@
#if GFX_USE_GINPUT && GINPUT_NEED_MOUSE
#define GMOUSE_DRIVER_VMT GMOUSEVMT_MAX11802
-#include "src/ginput/ginput_driver_mouse.h"
+#include "../../../../src/ginput/ginput_driver_mouse.h"
// Hardware definitions
-#include "drivers/ginput/touch/MAX11802/max11802.h"
+#include "max11802.h"
// Get the hardware interface
#include "gmouse_lld_MAX11802_board.h"
diff --git a/drivers/ginput/touch/MCU/driver.mk b/drivers/ginput/touch/MCU/driver.mk
index c8c792b2..dfd96b6f 100644
--- a/drivers/ginput/touch/MCU/driver.mk
+++ b/drivers/ginput/touch/MCU/driver.mk
@@ -1,2 +1 @@
-# List the required driver.
GFXSRC += $(GFXLIB)/drivers/ginput/touch/MCU/gmouse_lld_MCU.c
diff --git a/drivers/ginput/touch/MCU/gmouse_lld_MCU.c b/drivers/ginput/touch/MCU/gmouse_lld_MCU.c
index a69ae72e..8204e28c 100644
--- a/drivers/ginput/touch/MCU/gmouse_lld_MCU.c
+++ b/drivers/ginput/touch/MCU/gmouse_lld_MCU.c
@@ -10,7 +10,7 @@
#if GFX_USE_GINPUT && GINPUT_NEED_MOUSE
#define GMOUSE_DRIVER_VMT GMOUSEVMT_MCU
-#include "src/ginput/ginput_driver_mouse.h"
+#include "../../../../src/ginput/ginput_driver_mouse.h"
// Get the hardware interface
#include "gmouse_lld_MCU_board.h"
diff --git a/drivers/ginput/touch/STMPE610/driver.mk b/drivers/ginput/touch/STMPE610/driver.mk
index 364a01ff..d8fa97d6 100644
--- a/drivers/ginput/touch/STMPE610/driver.mk
+++ b/drivers/ginput/touch/STMPE610/driver.mk
@@ -1,2 +1 @@
-# List the required driver.
GFXSRC += $(GFXLIB)/drivers/ginput/touch/STMPE610/gmouse_lld_STMPE610.c
diff --git a/drivers/ginput/touch/STMPE610/gmouse_lld_STMPE610.c b/drivers/ginput/touch/STMPE610/gmouse_lld_STMPE610.c
index acfa202e..2eb8f429 100644
--- a/drivers/ginput/touch/STMPE610/gmouse_lld_STMPE610.c
+++ b/drivers/ginput/touch/STMPE610/gmouse_lld_STMPE610.c
@@ -10,10 +10,10 @@
#if GFX_USE_GINPUT && GINPUT_NEED_MOUSE
#define GMOUSE_DRIVER_VMT GMOUSEVMT_STMPE610
-#include "src/ginput/ginput_driver_mouse.h"
+#include "../../../../src/ginput/ginput_driver_mouse.h"
// Hardware definitions
-#include "drivers/ginput/touch/STMPE610/stmpe610.h"
+#include "stmpe610.h"
// Get the hardware interface
#include "gmouse_lld_STMPE610_board.h"
diff --git a/drivers/ginput/touch/STMPE811/driver.mk b/drivers/ginput/touch/STMPE811/driver.mk
index cf12507b..12ce9243 100644
--- a/drivers/ginput/touch/STMPE811/driver.mk
+++ b/drivers/ginput/touch/STMPE811/driver.mk
@@ -1,2 +1 @@
-# List the required driver.
GFXSRC += $(GFXLIB)/drivers/ginput/touch/STMPE811/gmouse_lld_STMPE811.c
diff --git a/drivers/ginput/touch/STMPE811/gmouse_lld_STMPE811.c b/drivers/ginput/touch/STMPE811/gmouse_lld_STMPE811.c
index 444888af..8cb1b70e 100644
--- a/drivers/ginput/touch/STMPE811/gmouse_lld_STMPE811.c
+++ b/drivers/ginput/touch/STMPE811/gmouse_lld_STMPE811.c
@@ -10,10 +10,10 @@
#if GFX_USE_GINPUT && GINPUT_NEED_MOUSE
#define GMOUSE_DRIVER_VMT GMOUSEVMT_STMPE811
-#include "src/ginput/ginput_driver_mouse.h"
+#include "../../../../src/ginput/ginput_driver_mouse.h"
// Hardware definitions
-#include "drivers/ginput/touch/STMPE811/stmpe811.h"
+#include "stmpe811.h"
// Get the hardware interface
#include "gmouse_lld_STMPE811_board.h"