aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/multiple/uGFXnet/readme.txt
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/multiple/uGFXnet/readme.txt')
-rw-r--r--drivers/multiple/uGFXnet/readme.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/drivers/multiple/uGFXnet/readme.txt b/drivers/multiple/uGFXnet/readme.txt
new file mode 100644
index 00000000..e1f7d0a2
--- /dev/null
+++ b/drivers/multiple/uGFXnet/readme.txt
@@ -0,0 +1,19 @@
+To use this driver:
+
+This driver is special in that it implements both the gdisp low level driver
+and a touchscreen driver.
+
+1. Add in your gfxconf.h:
+ a) #define GFX_USE_GDISP TRUE
+ b) Optionally #define GFX_USE_GINPUT TRUE
+ #define GINPUT_USE_MOUSE TRUE
+ c) Any optional high level driver defines (see gdisp.h) eg: GDISP_NEED_MULTITHREAD
+ d) Optionally the following (with appropriate values):
+ #define GDISP_SCREEN_WIDTH 640
+ #define GDISP_SCREEN_HEIGHT 480
+
+2. To your makefile add the following lines:
+ include $(GFXLIB)/gfx.mk
+ include $(GFXLIB)/drivers/multiple/uGFXnet/gdisp_lld.mk
+
+3. Make sure you have networking libraries included.