aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/touchpad
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/touchpad')
-rw-r--r--drivers/touchpad/ADS7843/readme.txt8
-rw-r--r--drivers/touchpad/ADS7843/touchpad_lld.c241
-rw-r--r--drivers/touchpad/ADS7843/touchpad_lld.mk6
-rw-r--r--drivers/touchpad/ADS7843/touchpad_lld_config.h45
-rw-r--r--drivers/touchpad/XPT2046/readme.txt8
-rw-r--r--drivers/touchpad/XPT2046/touchpad_lld.c241
-rw-r--r--drivers/touchpad/XPT2046/touchpad_lld.mk6
-rw-r--r--drivers/touchpad/XPT2046/touchpad_lld_config.h45
8 files changed, 0 insertions, 600 deletions
diff --git a/drivers/touchpad/ADS7843/readme.txt b/drivers/touchpad/ADS7843/readme.txt
deleted file mode 100644
index 90eadc32..00000000
--- a/drivers/touchpad/ADS7843/readme.txt
+++ /dev/null
@@ -1,8 +0,0 @@
-To use this driver:
-
-1. Add in your halconf.h:
- a) #define GFX_USE_TOUCHPAD TRUE
-
-2. To your makefile add the following lines:
- include $(GFXLIB)/drivers/touchpadADS7843/touchpad_lld.mk
-
diff --git a/drivers/touchpad/ADS7843/touchpad_lld.c b/drivers/touchpad/ADS7843/touchpad_lld.c
deleted file mode 100644
index 8b30f4f3..00000000
--- a/drivers/touchpad/ADS7843/touchpad_lld.c
+++ /dev/null
@@ -1,241 +0,0 @@
-/*
- ChibiOS/GFX - Copyright (C) 2012
- Joel Bodenmann aka Tectu <joel@unormal.org>
-
- This file is part of ChibiOS/GFX.
-
- ChibiOS/GFX is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 3 of the License, or
- (at your option) any later version.
-
- ChibiOS/GFX is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program. If not, see <http://www.gnu.org/licenses/>.
-*/
-
-/**
- * @file drivers/touchpad/ADS7843/touchpad_lld.c
- * @brief Touchpad Driver subsystem low level driver source.
- *
- * @addtogroup TOUCHPAD
- * @{
- */
-
-#include "ch.h"
-#include "hal.h"
-#include "touchpad.h"
-
-#if GFX_USE_TOUCHPAD /*|| defined(__DOXYGEN__)*/
-
-/*===========================================================================*/
-/* Driver local definitions. */
-/*===========================================================================*/
-
-/*===========================================================================*/
-/* Driver exported variables. */
-/*===========================================================================*/
-
-/*===========================================================================*/
-/* Driver local variables. */
-/*===========================================================================*/
-#if !defined(__DOXYGEN__)
- /* Local copy of the current touchpad driver */
- static const TOUCHPADDriver *tpDriver;
-
- static uint16_t sampleBuf[7];
-#endif
-
-/*===========================================================================*/
-/* Driver local functions. */
-/*===========================================================================*/
-
-/*===========================================================================*/
-/* Driver interrupt handlers. */
-/*===========================================================================*/
-
-/*===========================================================================*/
-/* Driver exported functions. */
-/*===========================================================================*/
-
-/* ---- Required Routines ---- */
-
-/**
- * @brief Low level Touchpad driver initialization.
- *
- * @param[in] tp The touchpad driver
- *
- * @notapi
- */
-void tp_lld_init(const TOUCHPADDriver *tp) {
- tpDriver = tp;
-
- if(tpDriver->direct_init)
- spiStart(tpDriver->spip, tpDriver->spicfg);
-}
-
-
-/**
- * @brief Reads a conversion from the touchpad
- *
- * @param[in] cmd The command bits to send to the touchpad
- *
- * @return The read value 12-bit right-justified
- *
- * @note This function only reads data, it is assumed that the pins are
- * configured properly and the bus has been acquired beforehand
- *
- * @notapi
- */
-uint16_t tp_lld_read_value(uint8_t cmd) {
- static uint8_t txbuf[3] = {0};
- static uint8_t rxbuf[3] = {0};
- uint16_t ret;
-
- txbuf[0] = cmd;
-
- spiExchange(tpDriver->spip, 3, txbuf, rxbuf);
-
- ret = (rxbuf[1] << 5) | (rxbuf[2] >> 3);
-
- return ret;
-}
-
-/**
- * @brief 7-point median filtering code for touchpad samples
- *
- * @note This is an internally used routine only.
- *
- * @notapi
- */
-static void tp_lld_filter(void) {
- uint16_t temp;
- int i,j;
-
- for(i = 0; i < 4; i++) {
- for(j=i; j < 7; j++) {
- if(sampleBuf[i] > sampleBuf[j]) {
- /* Swap the values */
- temp = sampleBuf[i];
- sampleBuf[i] = sampleBuf[j];
- sampleBuf[j] = temp;
- }
- }
- }
-}
-
-/**
- * @brief Reads out the X direction.
- *
- * @note The samples are median filtered for greater noise reduction
- *
- * @notapi
- */
-uint16_t tp_lld_read_x(void) {
- int i;
-
-#if defined(SPI_USE_MUTUAL_EXCLUSION)
- spiAcquireBus(tpDriver->spip);
-#endif
-
- TOUCHPAD_SPI_PROLOGUE();
- palClearPad(tpDriver->spicfg->ssport, tpDriver->spicfg->sspad);
-
- /* Discard the first conversion - very noisy and keep the ADC on hereafter
- * till we are done with the sampling. Note that PENIRQ is disabled.
- */
- tp_lld_read_value(0xD1);
-
- for(i = 0; i < 7; i++) {
- sampleBuf[i]=tp_lld_read_value(0xD1);
- }
-
- /* Switch on PENIRQ once again - perform a dummy read */
- tp_lld_read_value(0xD0);
-
- palSetPad(tpDriver->spicfg->ssport, tpDriver->spicfg->sspad);
- TOUCHPAD_SPI_EPILOGUE();
-
-#if defined(SPI_USE_MUTUAL_EXCLUSION)
- spiReleaseBus(tpDriver->spip);
-#endif
-
- /* Find the median - use selection sort */
- tp_lld_filter();
-
- return sampleBuf[3];
-}
-
-/*
- * @brief Reads out the Y direction.
- *
- * @notapi
- */
-uint16_t tp_lld_read_y(void) {
- int i;
-
-#if defined(SPI_USE_MUTUAL_EXCLUSION)
- spiAcquireBus(tpDriver->spip);
-#endif
-
- TOUCHPAD_SPI_PROLOGUE();
- palClearPad(tpDriver->spicfg->ssport, tpDriver->spicfg->sspad);
-
- /* Discard the first conversion - very noisy and keep the ADC on hereafter
- * till we are done with the sampling. Note that PENIRQ is disabled.
- */
- tp_lld_read_value(0x91);
-
- for(i = 0; i < 7; i++) {
- sampleBuf[i] = tp_lld_read_value(0x91);
- }
-
- /* Switch on PENIRQ once again - perform a dummy read */
- tp_lld_read_value(0x90);
-
- palSetPad(tpDriver->spicfg->ssport, tpDriver->spicfg->sspad);
- TOUCHPAD_SPI_EPILOGUE();
-
-#ifdef SPI_USE_MUTUAL_EXCLUSION
- spiReleaseBus(tpDriver->spip);
-#endif
-
- /* Find the median - use selection sort */
- tp_lld_filter();
-
- return sampleBuf[3];
-}
-
-/* ---- Optional Routines ---- */
-#if TOUCHPAD_HAS_IRQ || defined(__DOXYGEN__)
- /*
- * @brief for checking if touchpad is pressed or not.
- *
- * @return 1 if pressed / 0 if not pressed
- *
- * @notapi
- */
- uint8_t tp_lld_irq(void) {
- return (!palReadPad(tpDriver->tpIRQPort, tpDriver->tpIRQPin));
- }
-#endif
-
-#if TOUCHPAD_HAS_PRESSURE || defined(__DOXYGEN__)
- /*
- * @brief Reads out the Z direction / pressure.
- *
- * @notapi
- */
- uint16_t tp_lld_read_z(void) {
- /* ToDo */
- return 42;
- }
-#endif
-
-#endif /* GFX_USE_TOUCHPAD */
-/** @} */
-
diff --git a/drivers/touchpad/ADS7843/touchpad_lld.mk b/drivers/touchpad/ADS7843/touchpad_lld.mk
deleted file mode 100644
index 6aaa44ee..00000000
--- a/drivers/touchpad/ADS7843/touchpad_lld.mk
+++ /dev/null
@@ -1,6 +0,0 @@
-# List the required driver.
-GFXSRC += $(GFXLIB)/drivers/touchpad/ADS7843/touchpad_lld.c
-
-# Required include directories
-GFXINC += $(GFXLIB)/drivers/touchpad/ADS7843
-
diff --git a/drivers/touchpad/ADS7843/touchpad_lld_config.h b/drivers/touchpad/ADS7843/touchpad_lld_config.h
deleted file mode 100644
index 5ed1981c..00000000
--- a/drivers/touchpad/ADS7843/touchpad_lld_config.h
+++ /dev/null
@@ -1,45 +0,0 @@
-/*
- ChibiOS/GFX - Copyright (C) 2012
- Joel Bodenmann aka Tectu <joel@unormal.org>
-
- This file is part of ChibiOS/GFX.
-
- ChibiOS/GFX is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 3 of the License, or
- (at your option) any later version.
-
- ChibiOS/GFX is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program. If not, see <http://www.gnu.org/licenses/>.
-*/
-
-/**
- * @file drivers/touchpad/ADS7843/touchpad_lld_config.h
- * @brief Touchpad Driver subsystem low level driver.
- *
- * @addtogroup TOUCHPAD
- * @{
- */
-
-#ifndef _TOUCHPAD_LLD_CONFIG_H
-#define _TOUCHPAD_LLD_CONFIG_H
-
-#if GFX_USE_TOUCHPAD /*|| defined(__DOXYGEN__)*/
-
-/*===========================================================================*/
-/* Driver hardware support. */
-/*===========================================================================*/
-
-#define TOUCHPAD_HAS_IRQ TRUE
-#define TOUCHPAD_HAS_PRESSURE FALSE
-
-#endif /* GFX_USE_TOUCHPAD */
-
-#endif /* _TOUCHPAD_LLD_CONFIG_H */
-/** @} */
-
diff --git a/drivers/touchpad/XPT2046/readme.txt b/drivers/touchpad/XPT2046/readme.txt
deleted file mode 100644
index baccebe8..00000000
--- a/drivers/touchpad/XPT2046/readme.txt
+++ /dev/null
@@ -1,8 +0,0 @@
-To use this driver:
-
-1. Add in your halconf.h:
- a) #define GFX_USE_TOUCHPAD TRUE
-
-2. To your makefile add the following lines:
- include $(GFXLIB)/drivers/touchpad/XPT2046/touchpad_lld.mk
-
diff --git a/drivers/touchpad/XPT2046/touchpad_lld.c b/drivers/touchpad/XPT2046/touchpad_lld.c
deleted file mode 100644
index 8be23b07..00000000
--- a/drivers/touchpad/XPT2046/touchpad_lld.c
+++ /dev/null
@@ -1,241 +0,0 @@
-/*
- ChibiOS/GFX - Copyright (C) 2012
- Joel Bodenmann aka Tectu <joel@unormal.org>
-
- This file is part of ChibiOS/GFX.
-
- ChibiOS/GFX is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 3 of the License, or
- (at your option) any later version.
-
- ChibiOS/GFX is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program. If not, see <http://www.gnu.org/licenses/>.
-*/
-
-/**
- * @file drivers/touchpad/XPT2046/touchpad_lld.c
- * @brief Touchpad Driver subsystem low level driver source.
- *
- * @addtogroup TOUCHPAD
- * @{
- */
-
-#include "ch.h"
-#include "hal.h"
-#include "touchpad.h"
-
-#if GFX_USE_TOUCHPAD /*|| defined(__DOXYGEN__)*/
-
-/*===========================================================================*/
-/* Driver local definitions. */
-/*===========================================================================*/
-
-/*===========================================================================*/
-/* Driver exported variables. */
-/*===========================================================================*/
-
-/*===========================================================================*/
-/* Driver local variables. */
-/*===========================================================================*/
-#if !defined(__DOXYGEN__)
- /* Local copy of the current touchpad driver */
- static const TOUCHPADDriver *tpDriver;
-
- static uint16_t sampleBuf[7];
-#endif
-
-/*===========================================================================*/
-/* Driver local functions. */
-/*===========================================================================*/
-
-/*===========================================================================*/
-/* Driver interrupt handlers. */
-/*===========================================================================*/
-
-/*===========================================================================*/
-/* Driver exported functions. */
-/*===========================================================================*/
-
-/* ---- Required Routines ---- */
-
-/**
- * @brief Low level Touchpad driver initialization.
- *
- * @param[in] tp The touchpad driver struct
- *
- * @notapi
- */
-void tp_lld_init(const TOUCHPADDriver *tp) {
- tpDriver = tp;
-
- if(tpDriver->direct_init)
- spiStart(tpDriver->spip, tpDriver->spicfg);
-}
-
-
-/**
- * @brief Reads a conversion from the touchpad
- *
- * @param[in] cmd The command bits to send to the touchpad
- *
- * @return The read value 12-bit right-justified
- *
- * @note This function only reads data, it is assumed that the pins are
- * configured properly and the bus has been acquired beforehand
- *
- * @notapi
- */
-uint16_t tp_lld_read_value(uint8_t cmd) {
- static uint8_t txbuf[3] = {0};
- static uint8_t rxbuf[3] = {0};
- uint16_t ret;
-
- txbuf[0] = cmd;
-
- spiExchange(tpDriver->spip, 3, txbuf, rxbuf);
-
- ret = (rxbuf[1] << 5) | (rxbuf[2] >> 3);
-
- return ret;
-}
-
-/**
- * @brief 7-point median filtering code for touchpad samples
- *
- * @note This is an internally used routine only.
- *
- * @notapi
- */
-static void tp_lld_filter(void) {
- uint16_t temp;
- int i,j;
-
- for(i = 0; i < 4; i++) {
- for(j=i; j < 7; j++) {
- if(sampleBuf[i] > sampleBuf[j]) {
- /* Swap the values */
- temp = sampleBuf[i];
- sampleBuf[i] = sampleBuf[j];
- sampleBuf[j] = temp;
- }
- }
- }
-}
-
-/**
- * @brief Reads out the X direction.
- *
- * @note The samples are median filtered for greater noise reduction
- *
- * @notapi
- */
-uint16_t tp_lld_read_x(void) {
- int i;
-
-#if defined(SPI_USE_MUTUAL_EXCLUSION)
- spiAcquireBus(tpDriver->spip);
-#endif
-
- TOUCHPAD_SPI_PROLOGUE();
- palClearPad(tpDriver->spicfg->ssport, tpDriver->spicfg->sspad);
-
- /* Discard the first conversion - very noisy and keep the ADC on hereafter
- * till we are done with the sampling. Note that PENIRQ is disabled.
- */
- tp_lld_read_value(0xD1);
-
- for(i = 0; i < 7; i++) {
- sampleBuf[i]=tp_lld_read_value(0xD1);
- }
-
- /* Switch on PENIRQ once again - perform a dummy read */
- tp_lld_read_value(0xD0);
-
- palSetPad(tpDriver->spicfg->ssport, tpDriver->spicfg->sspad);
- TOUCHPAD_SPI_EPILOGUE();
-
-#if defined(SPI_USE_MUTUAL_EXCLUSION)
- spiReleaseBus(tpDriver->spip);
-#endif
-
- /* Find the median - use selection sort */
- tp_lld_filter();
-
- return sampleBuf[3];
-}
-
-/*
- * @brief Reads out the Y direction.
- *
- * @notapi
- */
-uint16_t tp_lld_read_y(void) {
- int i;
-
-#if defined(SPI_USE_MUTUAL_EXCLUSION)
- spiAcquireBus(tpDriver->spip);
-#endif
-
- TOUCHPAD_SPI_PROLOGUE();
- palClearPad(tpDriver->spicfg->ssport, tpDriver->spicfg->sspad);
-
- /* Discard the first conversion - very noisy and keep the ADC on hereafter
- * till we are done with the sampling. Note that PENIRQ is disabled.
- */
- tp_lld_read_value(0x91);
-
- for(i = 0; i < 7; i++) {
- sampleBuf[i] = tp_lld_read_value(0x91);
- }
-
- /* Switch on PENIRQ once again - perform a dummy read */
- tp_lld_read_value(0x90);
-
- palSetPad(tpDriver->spicfg->ssport, tpDriver->spicfg->sspad);
- TOUCHPAD_SPI_EPILOGUE();
-
-#ifdef SPI_USE_MUTUAL_EXCLUSION
- spiReleaseBus(tpDriver->spip);
-#endif
-
- /* Find the median - use selection sort */
- tp_lld_filter();
-
- return sampleBuf[3];
-}
-
-/* ---- Optional Routines ---- */
-#if TOUCHPAD_HAS_IRQ || defined(__DOXYGEN__)
- /*
- * @brief for checking if touchpad is pressed or not.
- *
- * @return 1 if pressed / 0 if not pressed
- *
- * @notapi
- */
- uint8_t tp_lld_irq(void) {
- return (!palReadPad(tpDriver->tpIRQPort, tpDriver->tpIRQPin));
- }
-#endif
-
-#if TOUCHPAD_HAS_PRESSURE || defined(__DOXYGEN__)
- /*
- * @brief Reads out the Z direction / pressure.
- *
- * @notapi
- */
- uint16_t tp_lld_read_z(void) {
- /* ToDo */
- return 42;
- }
-#endif
-
-#endif /* GFX_USE_TOUCHPAD */
-/** @} */
-
diff --git a/drivers/touchpad/XPT2046/touchpad_lld.mk b/drivers/touchpad/XPT2046/touchpad_lld.mk
deleted file mode 100644
index 8d662a74..00000000
--- a/drivers/touchpad/XPT2046/touchpad_lld.mk
+++ /dev/null
@@ -1,6 +0,0 @@
-# List the required driver.
-GFXSRC += $(GFXLIB)/drivers/touchpad/XPT2046/touchpad_lld.c
-
-# Required include directories
-GFXINC += $(GFXLIB)/drivers/touchpad/XPT2046
-
diff --git a/drivers/touchpad/XPT2046/touchpad_lld_config.h b/drivers/touchpad/XPT2046/touchpad_lld_config.h
deleted file mode 100644
index a503d2b7..00000000
--- a/drivers/touchpad/XPT2046/touchpad_lld_config.h
+++ /dev/null
@@ -1,45 +0,0 @@
-/*
- ChibiOS/GFX - Copyright (C) 2012
- Joel Bodenmann aka Tectu <joel@unormal.org>
-
- This file is part of ChibiOS/GFX.
-
- ChibiOS/GFX is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 3 of the License, or
- (at your option) any later version.
-
- ChibiOS/GFX is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program. If not, see <http://www.gnu.org/licenses/>.
-*/
-
-/**
- * @file drivers/touchpad/XPT2046/touchpad_lld_config.h
- * @brief Touchppad Driver subsystem low level driver.
- *
- * @addtogroup TOUCHPAD
- * @{
- */
-
-#ifndef _TOUCHPAD_LLD_CONFIG_H
-#define _TOUCHPAD_LLD_CONFIG_H
-
-#if GFX_USE_TOUCHPAD /*|| defined(__DOXYGEN__)*/
-
-/*===========================================================================*/
-/* Driver hardware support. */
-/*===========================================================================*/
-
-#define TOUCHPAD_HAS_IRQ TRUE
-#define TOUCHPAD_HAS_PRESSURE TRUE
-
-#endif /* GFX_USE_TOUCHPAD */
-
-#endif /* _TOUCHPAD_LLD_CONFIG_H */
-/** @} */
-