aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gmake_scripts/os_freertos.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tools/gmake_scripts/os_freertos.mk')
-rw-r--r--tools/gmake_scripts/os_freertos.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/tools/gmake_scripts/os_freertos.mk b/tools/gmake_scripts/os_freertos.mk
new file mode 100644
index 00000000..5cbd5be0
--- /dev/null
+++ b/tools/gmake_scripts/os_freertos.mk
@@ -0,0 +1,36 @@
+#
+# This file is subject to the terms of the GFX License. If a copy of
+# the license was not distributed with this file, you can obtain one at:
+#
+# http://ugfx.org/license.html
+#
+
+# See readme.txt for the make API
+
+# Requirements:
+#
+# FREERTOS: The location of the FreeRTOS code eg FREERTOS=../FreeRTOS
+# FREERTOS_BOARD The board name eg FREERTOS_BOARD=RaspberryPi
+#
+
+# Optional:
+#
+# FREERTOS_MODULES A list of directories containing FreeRTOS source (eg drivers, startup etc) - default is ""
+# FREERTOS_LDSCRIPT The loader script - default is ""
+#
+
+PATHLIST += FREERTOS
+
+FREERTOS_MODULES += $(FREERTOS)/Source/portable/GCC/$(FREERTOS_BOARD)
+FREERTOS_MODULES += $(FREERTOS)/Source/portable/MemMang
+FREERTOS_MODULES += $(FREERTOS)/Source
+
+INCPATH += $(FREERTOS)/Source/portable/GCC/$(FREERTOS_BOARD) \
+ $(FREERTOS)/Source/include
+
+SRC += $(foreach sdir,$(FREERTOS_MODULES),$(wildcard $(sdir)/*.s))
+SRC += $(foreach sdir,$(FREERTOS_MODULES),$(wildcard $(sdir)/*.c))
+
+ifeq ($(LDSCRIPT),)
+ LDSCRIPT= $(FREERTOS_LDSCRIPT)
+endif