aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gmake_scripts/os_osx.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tools/gmake_scripts/os_osx.mk')
-rw-r--r--tools/gmake_scripts/os_osx.mk10
1 files changed, 9 insertions, 1 deletions
diff --git a/tools/gmake_scripts/os_osx.mk b/tools/gmake_scripts/os_osx.mk
index 8b008f4b..9bfc7024 100644
--- a/tools/gmake_scripts/os_osx.mk
+++ b/tools/gmake_scripts/os_osx.mk
@@ -1,10 +1,18 @@
+#
+# This file is subject to the terms of the GFX License. If a copy of
+# the license was not distributed with this file, you can obtain one at:
+#
+# http://ugfx.org/license.html
+#
+
# See readme.txt for the make API
# Requirements:
#
# OSX_SDK The location of the SDK eg. OSX_SDK = /Developer/SDKs/MacOSX10.7.sdk
-# OSX_ARCH The architecture flags eg. OSX_ARCH = -mmacosx-version-min=10.3 -arch i386
+# OSX_ARCH The architecture flags eg. OSX_ARCH = -mmacosx-version-min=10.3
#
SRCFLAGS += -isysroot $(OSX_SDK) $(OSX_ARCH)
LDFLAGS += -pthread -Wl,-syslibroot,$(OSX_SDK) $(OSX_ARCH)
+OPT_CPU = x86