diff options
author | Alex Gaynor <alex.gaynor@gmail.com> | 2015-06-22 20:45:41 -0400 |
---|---|---|
committer | Alex Gaynor <alex.gaynor@gmail.com> | 2015-06-22 20:45:41 -0400 |
commit | 02fe5a8d2d2d87830484f731e821054a21a9bf4f (patch) | |
tree | 6b2066d1411ffeb40e942e763beaa3dda1860b11 | |
parent | 02a299d8b2d70e4e145fbd420787ea35873d96f7 (diff) | |
download | cryptography-02fe5a8d2d2d87830484f731e821054a21a9bf4f.tar.gz cryptography-02fe5a8d2d2d87830484f731e821054a21a9bf4f.tar.bz2 cryptography-02fe5a8d2d2d87830484f731e821054a21a9bf4f.zip |
Remove our workarounds for pyasn.1 bugs, a new pyasn.1 is out!
-rw-r--r-- | setup.py | 4 | ||||
-rw-r--r-- | src/cryptography/hazmat/primitives/asymmetric/utils.py | 5 | ||||
-rw-r--r-- | tests/hazmat/primitives/test_asym_utils.py | 4 |
3 files changed, 4 insertions, 9 deletions
@@ -33,9 +33,9 @@ VECTORS_DEPENDENCY = "cryptography_vectors=={0}".format(about['__version__']) requirements = [ "idna>=2.0", - "pyasn1", + "pyasn1>=0.1.8", "six>=1.4.1", - "setuptools" + "setuptools", ] setup_requirements = [] diff --git a/src/cryptography/hazmat/primitives/asymmetric/utils.py b/src/cryptography/hazmat/primitives/asymmetric/utils.py index 29390e40..b10ea957 100644 --- a/src/cryptography/hazmat/primitives/asymmetric/utils.py +++ b/src/cryptography/hazmat/primitives/asymmetric/utils.py @@ -29,11 +29,6 @@ def decode_rfc6979_signature(signature): raise ValueError( "The signature contains bytes after the end of the ASN.1 sequence." ) - # pyasn1 can erroneously return this from top-level DER decoding. - # It's intended as a sentinel in recursive BER decoding, so it's - # returned even though an asn1Spec is provided. - if eoo.endOfOctets.isSameTypeWith(data) and data == eoo.endOfOctets: - raise ValueError("Invalid signature data. Unable to decode ASN.1") r = int(data.getComponentByName('r')) s = int(data.getComponentByName('s')) diff --git a/tests/hazmat/primitives/test_asym_utils.py b/tests/hazmat/primitives/test_asym_utils.py index c3fbedf9..35b77ca4 100644 --- a/tests/hazmat/primitives/test_asym_utils.py +++ b/tests/hazmat/primitives/test_asym_utils.py @@ -65,6 +65,6 @@ def test_decode_rfc6979_invalid_asn1(): decode_rfc6979_signature(b"0\x07\x02\x01\x01\x02\x02\x01") with pytest.raises(ValueError): - # This is the BER "end-of-contents octets," which pyasn1 is - # wrongly willing to return from top-level DER decoding. + # This is the BER "end-of-contents octets," which older versions of + # pyasn1 are wrongly willing to return from top-level DER decoding. decode_rfc6979_signature(b"\x00\x00") |