aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2016-01-23 09:26:07 -0500
committerAlex Gaynor <alex.gaynor@gmail.com>2016-01-23 09:26:07 -0500
commit30e199e0fb220a17b3089508a59d29a2924f10e4 (patch)
tree8bc559b53cd67d341b3582391bef2ac56656a46f
parent1af5dd9dcb1dd56fe3a0cedaf78427cda9c7b644 (diff)
downloadcryptography-30e199e0fb220a17b3089508a59d29a2924f10e4.tar.gz
cryptography-30e199e0fb220a17b3089508a59d29a2924f10e4.tar.bz2
cryptography-30e199e0fb220a17b3089508a59d29a2924f10e4.zip
Require a newer setuptools.
This lets a long confusing comment.
-rw-r--r--setup.py2
-rw-r--r--src/cryptography/hazmat/backends/__init__.py7
2 files changed, 2 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 098a6bbb..72675295 100644
--- a/setup.py
+++ b/setup.py
@@ -37,7 +37,7 @@ requirements = [
"idna>=2.0",
"pyasn1>=0.1.8",
"six>=1.4.1",
- "setuptools>=1.0",
+ "setuptools>=11.3",
]
setup_requirements = []
diff --git a/src/cryptography/hazmat/backends/__init__.py b/src/cryptography/hazmat/backends/__init__.py
index 256fee39..96a431dc 100644
--- a/src/cryptography/hazmat/backends/__init__.py
+++ b/src/cryptography/hazmat/backends/__init__.py
@@ -17,12 +17,7 @@ def _available_backends():
if _available_backends_list is None:
_available_backends_list = [
- # setuptools 11.3 deprecated support for the require parameter to
- # load(), and introduced the new resolve() method instead.
- # This can be removed if/when we can assume setuptools>=11.3. At
- # some point we may wish to add a warning, to push people along,
- # but at present this would result in too many warnings.
- ep.resolve() if hasattr(ep, "resolve") else ep.load(require=False)
+ ep.resolve()
for ep in pkg_resources.iter_entry_points(
"cryptography.backends"
)