aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2014-01-03 15:03:17 -0800
committerAlex Gaynor <alex.gaynor@gmail.com>2014-01-03 15:03:17 -0800
commit327742c8e6271e2b6d809e891bd8e518b89994d9 (patch)
tree324a70bd84ddbc3490f20c0e3413ef1ecc6e3315
parenteba623f88260a9a076ce3a4a71d1d61755327e05 (diff)
parentf96db83a64bb0ac40d04d27383d7c2defbcec491 (diff)
downloadcryptography-327742c8e6271e2b6d809e891bd8e518b89994d9.tar.gz
cryptography-327742c8e6271e2b6d809e891bd8e518b89994d9.tar.bz2
cryptography-327742c8e6271e2b6d809e891bd8e518b89994d9.zip
Merge branch 'master' into setup-install-extension
Conflicts: setup.py
-rw-r--r--cryptography/__about__.py2
-rw-r--r--docs/hazmat/bindings/index.rst2
-rw-r--r--docs/hazmat/primitives/hmac.rst9
-rw-r--r--setup.py12
-rw-r--r--tests/test_utils.py2
-rw-r--r--tests/utils.py4
6 files changed, 22 insertions, 9 deletions
diff --git a/cryptography/__about__.py b/cryptography/__about__.py
index 46212bff..54a9dbe6 100644
--- a/cryptography/__about__.py
+++ b/cryptography/__about__.py
@@ -26,7 +26,7 @@ __version__ = "0.1.dev1"
__author__ = ("Alex Gaynor, Hynek Schlawack, Donald Stufft, "
"Laurens Van Houtven, Jean-Paul Calderone, Christian Heimes, "
- "and individual contributors.")
+ "Paul Kehrer, and individual contributors.")
__email__ = "cryptography-dev@python.org"
__license__ = "Apache License, Version 2.0"
diff --git a/docs/hazmat/bindings/index.rst b/docs/hazmat/bindings/index.rst
index 809eddfc..e2a17591 100644
--- a/docs/hazmat/bindings/index.rst
+++ b/docs/hazmat/bindings/index.rst
@@ -6,7 +6,7 @@ Bindings
.. currentmodule:: cryptography.hazmat.bindings
``cryptography`` aims to provide low-level CFFI based bindings to multiple
-native C libraries. These provide no automatic initialisation of the library
+native C libraries. These provide no automatic initialization of the library
and may not provide complete wrappers for its API.
Using these functions directly is likely to require you to be careful in
diff --git a/docs/hazmat/primitives/hmac.rst b/docs/hazmat/primitives/hmac.rst
index b8f94fd2..dc5c54f8 100644
--- a/docs/hazmat/primitives/hmac.rst
+++ b/docs/hazmat/primitives/hmac.rst
@@ -74,8 +74,11 @@ message.
.. method:: verify(signature)
- Finalize the current context and securely compare digest to ``signature``.
+ Finalize the current context and securely compare digest to
+ ``signature``.
- :param bytes signature: The bytes of the HMAC signature recieved.
+ :param bytes signature: The bytes to compare the current digest
+ against.
:raises cryptography.exceptions.AlreadyFinalized: See :meth:`finalize`
- :raises cryptography.exceptions.InvalidSignature: If signature does not match digest
+ :raises cryptography.exceptions.InvalidSignature: If signature does not
+ match digest
diff --git a/setup.py b/setup.py
index 2ff57e97..fe37d9fb 100644
--- a/setup.py
+++ b/setup.py
@@ -10,14 +10,17 @@
# implied.
# See the License for the specific language governing permissions and
# limitations under the License.
+import os
from distutils.command.build import build
from setuptools import setup, find_packages
+base_dir = os.path.dirname(__file__)
+
about = {}
-with open("cryptography/__about__.py") as fp:
- exec(fp.read(), about)
+with open(os.path.join(base_dir, "cryptography", "__about__.py")) as f:
+ exec(f.read(), about)
CFFI_DEPENDENCY = "cffi>=0.6"
@@ -42,11 +45,16 @@ class cffi_build(build):
build.finalize_options(self)
+with open(os.path.join(base_dir, "README.rst")) as f:
+ long_description = f.read()
+
+
setup(
name=about["__title__"],
version=about["__version__"],
description=about["__summary__"],
+ long_description=long_description,
license=about["__license__"],
url=about["__uri__"],
diff --git a/tests/test_utils.py b/tests/test_utils.py
index c640367e..e3e53d63 100644
--- a/tests/test_utils.py
+++ b/tests/test_utils.py
@@ -50,7 +50,7 @@ def test_check_backend_support_skip():
funcargs={"backend": True})
with pytest.raises(pytest.skip.Exception) as exc_info:
check_backend_support(item)
- assert exc_info.value.args[0] == "Nope"
+ assert exc_info.value.args[0] == "Nope (True)"
def test_check_backend_support_no_skip():
diff --git a/tests/utils.py b/tests/utils.py
index beb2ca5d..693a0c8f 100644
--- a/tests/utils.py
+++ b/tests/utils.py
@@ -28,7 +28,9 @@ def check_backend_support(item):
supported = item.keywords.get("supported")
if supported and "backend" in item.funcargs:
if not supported.kwargs["only_if"](item.funcargs["backend"]):
- pytest.skip(supported.kwargs["skip_message"])
+ pytest.skip("{0} ({1})".format(
+ supported.kwargs["skip_message"], item.funcargs["backend"]
+ ))
elif supported:
raise ValueError("This mark is only available on methods that take a "
"backend")